Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[Solved] Show desktop button also minimises conky.

Post Reply
Message
Author
User avatar
Raymzap
Forum Regular
Forum Regular
Posts: 104
Joined: Mon Aug 25, 2014 9:40 am

[Solved] Show desktop button also minimises conky.

#1 Post by Raymzap » Tue Aug 07, 2018 2:38 pm

Hi.

When I hit the show desktop button, it also minimises conky. Is there a way to prevent this?

Thanks.
Last edited by Raymzap on Wed Aug 08, 2018 9:39 am, edited 1 time in total.
GNU/Linux User #470660

Linus Torvalds: "Microsoft isn't evil, they just make really crappy operating systems."

User avatar
male
Forum Regular
Forum Regular
Posts: 229
Joined: Thu Jan 23, 2014 8:38 am

Re: Show desktop button also minimises conky.

#2 Post by male » Tue Aug 07, 2018 4:33 pm

What desktop are we talking about?
Male is the capital of the Maldives and its wonderful people.

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 3257
Joined: Sun May 27, 2007 5:37 am

Re: Show desktop button also minimises conky.

#3 Post by asqwerth » Wed Aug 08, 2018 1:45 am

I believe it's the "minimise all windows" button, @male.

And this effect on a particular conky depends on the option used in that conky's own_window_type setting in the config text file .

Was it "normal" or "desktop"?

I think "normal" might make the conky behave like any other window, which is why it also gets minimised, while "desktop" will make the conky part of the desktop.

But I'm not sure that this is a consistent effect. It might also be interdependent on other conky config settings or maybe compositing as well. I'm not so sure.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
male
Forum Regular
Forum Regular
Posts: 229
Joined: Thu Jan 23, 2014 8:38 am

Re: Show desktop button also minimises conky.

#4 Post by male » Wed Aug 08, 2018 3:25 am

That's right, asqwerth. ;)

It is up to the window manager used. This can sometimes be very tricky with antiX. Especially because the user must at least log off and log on again after corresponding configuration changes.

antiX is delivered with

Code: Select all

# Create own window instead of using desktop (required in nautilus, pcmanfm and rox desktops)
own_window yes
own_window_transparent yes
own_window_hints undecorated,skip_taskbar   #sticky,

To play with would be

Code: Select all

own_window_type normal
own_window_type override
own_window_type desktop
and
own_window_class conky
But first he would have to check if the Conky continues to run in the background.
And, we're talking about conky1.9!
Male is the capital of the Maldives and its wonderful people.

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 3257
Joined: Sun May 27, 2007 5:37 am

Re: Show desktop button also minimises conky.

#5 Post by asqwerth » Wed Aug 08, 2018 4:19 am

Oops, I didn't notice this was in the antiX subforum!

Thought we were referring to MX and XFCE.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
Raymzap
Forum Regular
Forum Regular
Posts: 104
Joined: Mon Aug 25, 2014 9:40 am

Re: Show desktop button also minimises conky.

#6 Post by Raymzap » Wed Aug 08, 2018 4:57 am

male wrote:
Tue Aug 07, 2018 4:33 pm
What desktop are we talking about?
Hi male. Sorry, it's Space-IceWM and also the other IceWM ones. Sometimes conky does not get minimised. If I change wm then conky get's minimised again.
GNU/Linux User #470660

Linus Torvalds: "Microsoft isn't evil, they just make really crappy operating systems."

User avatar
male
Forum Regular
Forum Regular
Posts: 229
Joined: Thu Jan 23, 2014 8:38 am

Re: Show desktop button also minimises conky.

#7 Post by male » Wed Aug 08, 2018 8:54 am

@asqwerth,
it is generally valid. ;)

@Raymzap,
I was able to recreate the behavior you described.

The error is indicated by the option/variable

Code: Select all

own_window_type override
fixed. "Override" means Conky is not controlled by the window manager.

Open ~/.conkyrc and enter the above variable in the window section:

Code: Select all

# Create own window instead of using desktop (required in nautilus, pcmanfm and rox desktops)
own_window yes
own_window_transparent yes
own_window_hints undecorated,skip_taskbar,sticky
own_window_type override
Then log off and on :exclamation:
Male is the capital of the Maldives and its wonderful people.

User avatar
Raymzap
Forum Regular
Forum Regular
Posts: 104
Joined: Mon Aug 25, 2014 9:40 am

Re: Show desktop button also minimises conky.

#8 Post by Raymzap » Wed Aug 08, 2018 9:39 am

male wrote:
Wed Aug 08, 2018 8:54 am
@asqwerth,
it is generally valid. ;)

@Raymzap,
I was able to recreate the behavior you described.

The error is indicated by the option/variable

Code: Select all

own_window_type override
fixed. "Override" means Conky is not controlled by the window manager.

Open ~/.conkyrc and enter the above variable in the window section:

Code: Select all

# Create own window instead of using desktop (required in nautilus, pcmanfm and rox desktops)
own_window yes
own_window_transparent yes
own_window_hints undecorated,skip_taskbar,sticky
own_window_type override
Then log off and on :exclamation:
Perfect. I just had to also select Space-IceWM again and it works fine. Thank you. :-)
GNU/Linux User #470660

Linus Torvalds: "Microsoft isn't evil, they just make really crappy operating systems."

Post Reply

Return to “antiX”