Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Newer qBittorrent 4.1.1 Can that be installed in AntiX?

Post Reply
Message
Author
User avatar
namida12
Forum Guide
Forum Guide
Posts: 1769
Joined: Sun Apr 01, 2007 4:54 pm

Newer qBittorrent 4.1.1 Can that be installed in AntiX?

#1 Post by namida12 » Sat Jun 16, 2018 1:30 pm

I have V3.3.7 in AntiX is it possible this could be updated to a newer version?

Code: Select all

$ inxi -F
System:    Host: antix3 Kernel: 4.15.9-antix.1-amd64-smp x86_64 bits: 64 Desktop: IceWM 1.4.2 
           Distro: antiX-17.1_x64-full Heather Heyer 17 March 2018 
Machine:   Type: Laptop Mobo: MSI model: B350M GAMING PRO (MS-7A39) v: 1.0 serial: <root required> 
           UEFI [Legacy]: American Megatrends v: 2.30 date: 03/24/2017 
CPU:       Topology: Quad Core model: AMD Ryzen 5 1500X bits: 64 type: MT MCP L2 cache: 2048 KiB 
           Speed: 2062 MHz min/max: 1550/3500 MHz Core speeds (MHz): 1: 1408 2: 1382 3: 1374 4: 1375 5: 1375 
           6: 1372 7: 1375 8: 1372 
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] RV670 [Radeon HD 3690/3850] driver: radeon v: kernel 
           Display: server: X.Org 1.19.2 driver: ati,radeon unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Gallium 0.4 on AMD RV670 (DRM 2.50.0 / 4.15.9-antix.1-amd64-smp LLVM 3.9.1) 
           v: 3.3 Mesa 13.0.6 
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] RV670/680 HDMI Audio [Radeon HD 3690/3800 Series] 
           driver: snd_hda_intel 
           Card-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.15.9-antix.1-amd64-smp 
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 18:d6:c7:06:f9:4a 
Drives:    HDD Total Size: 232.89 GiB used: 150.68 GiB (64.7%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
Partition: ID-1: / size: 13.72 GiB used: 5.20 GiB (37.9%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 205.70 GiB used: 145.49 GiB (70.7%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 44.2 C mobo: N/A gpu: radeon temp: 88 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 214 Uptime: 1d 1h 14m Memory: 15.68 GiB used: 1.47 GiB (9.4%) Shell: bash inxi: 3.0.10 
green251@antix3:~

JR

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: Newer qBittorrent 4.1.1 Can that be installed in AntiX?

#2 Post by Stevo » Sat Jun 16, 2018 1:39 pm

Why not add the MX test repo and see if it can?

Oh, wait, I also have it in its own OBS repo if you want to just install it and the bleeding-edge libtorrent-rasterbar I built it against:

https://build.opensuse.org/package/show ... rent-4.1.X

I have several different releases of it in the same repo, but the newest is what will install by default. Instructions are here: https://software.opensuse.org//download ... bittorrent

User avatar
namida12
Forum Guide
Forum Guide
Posts: 1769
Joined: Sun Apr 01, 2007 4:54 pm

Re: Newer qBittorrent 4.1.1 Can that be installed in AntiX?

#3 Post by namida12 » Sat Jun 16, 2018 3:18 pm

Code: Select all

root@antix3:/home/green251# apt list --upgradable
Listing... Done
adobe-flash-properties-gtk/stretch 1:20180607.1-1mx17+1 amd64 [upgradable from: 1:20180508.1-1mx17+1]
adobe-flashplugin/stretch 1:20180607.1-1mx17+1 amd64 [upgradable from: 1:20180508.1-1mx17+1]
antix-libs/stretch,stretch 0.6.9 all [upgradable from: 0.6.8]
google-chrome-stable/stable 67.0.3396.87-1 amd64 [upgradable from: 67.0.3396.79-1]
libperl5.24/stable 5.24.1-3+deb9u4 amd64 [upgradable from: 5.24.1-3+deb9u3]
libtorrent-rasterbar9/unknown 1.1.7.git20180527.6ec6c1b340.patched-configure1-1~obs amd64 [upgradable from: 1.1.1-1+b1]
opera-stable/stable 53.0.2907.99 amd64 [upgradable from: 53.0.2907.68]
perl/stable 5.24.1-3+deb9u4 amd64 [upgradable from: 5.24.1-3+deb9u3]
perl-base/stable 5.24.1-3+deb9u4 amd64 [upgradable from: 5.24.1-3+deb9u3]
perl-modules-5.24/stable,stable 5.24.1-3+deb9u4 all [upgradable from: 5.24.1-3+deb9u3]
qbittorrent/unknown 4.1.1-0.1~obs amd64 [upgradable from: 3.3.7-3]
remaster-antix/stretch,stretch 0.6.7 all [upgradable from: 0.6.6]
root@antix3:/home/green251# 

Stevo,

Maybe this is for more experienced users?

Also have Rrsterbar9 trying to and install?
How do I purge "libtorrent-rasterbar9/" that apparently is still trying to install? Do not know that remove command?
]GPG error: http://download.opensuse.org/repositori ... an_Testing Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0FAD31CA8719FCE4The repository 'http://download.opensuse.org/repositori ... an_Testing Release' is not signed.[/quote

Code: Select all

root@antix3:/home/green251# apt-get install qbittorrent
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qbittorrent : Depends: libqt5core5a (>= 5.10.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5gui5 (>= 5.8.0) but 5.7.1+dfsg-3+b1 is to be installed
               Depends: libqt5network5 (>= 5.9.0~beta) but 5.7.1+dfsg-3+b1 is to be installed
E: Unable to correct problems, you have held broken packages.
root@antix3:/home/green251# 


User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: Newer qBittorrent 4.1.1 Can that be installed in AntiX?

#4 Post by Stevo » Sat Jun 16, 2018 4:25 pm

You followed the instructions provided by the OBS to add the repo for testing (Buster), not Debian 9. You will have to remove

Code: Select all

sudo rm -f /etc/apt/sources.list.d/home:stevenpusser:qbittorrent.list
or disable the repo you added and follow the directions for the Debian version you're running.

You also have to follow the directions to install the key for my matching Debian version repo to get rid of the GPG error.

About the rasterbar9 runtime library? I quote myself:
Oh, wait, I also have it in its own OBS repo if you want to just install it and the bleeding-edge libtorrent-rasterbar I built it against:
I hope that it's clear what "rasterbar9" is related to.

Post Reply

Return to “antiX”