Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Solved - VLC - Was Removed and not updated

Message
Author
User avatar
namida12
Forum Guide
Forum Guide
Posts: 1803
Joined: Sun Apr 01, 2007 4:54 pm

Solved - VLC - Was Removed and not updated

#1 Post by namida12 » Mon May 28, 2018 12:48 am

my last update ---

Commit Log for Fri May 25 07:42:58 2018

Removed the following packages:
vlc
vlc-plugin-base
vlc-plugin-vlsub

Upgraded the following packages:
antix-installer (1.0.1) to 1.0.4.1
control-centre-antix (0.6.7) to 0.6.9
curl (7.52.1-5+deb9u5) to 7.52.1-5+deb9u6
firefox-esr (52.7.3esr-1~deb9u1) to 52.8.0esr-1~deb9u1
gir1.2-packagekitglib-1.0 (1.1.5-2) to 1.1.5-2+deb9u1
google-chrome-stable (66.0.3359.139-1) to 66.0.3359.181-1
installer-data-antix (0.1.0) to 0.1.4
libcurl3 (7.52.1-5+deb9u5) to 7.52.1-5+deb9u6
libcurl3-gnutls (7.52.1-5+deb9u5) to 7.52.1-5+deb9u6
libpackagekit-glib2-18 (1.1.5-2) to 1.1.5-2+deb9u1
libvlc-bin (2.2.7-1~deb9u1) to 3.0.2-1.0nosystemd1
libvlc5 (2.2.7-1~deb9u1) to 3.0.2-1.0nosystemd1
libwavpack1 (5.0.0-2+deb9u1) to 5.0.0-2+deb9u2
linux-libc-dev (4.9.88-1) to 4.9.88-1+deb9u1
opera-stable (52.0.2871.99) to 53.0.2907.68
smxi-inxi-antix (0.4.7) to 0.4.9
user-management-antix (0.3.4) to 0.3.5
vlc-bin (2.2.7-1~deb9u1) to 3.0.2-1.0nosystemd1
vlc-data (2.2.7-1~deb9u1) to 3.0.2-1.0nosystemd1
vlc-l10n (2.2.7-1~deb9u1) to 3.0.2-1.0nosystemd1
vlc-plugin-qt (2.2.7-1~deb9u1) to 3.0.2-1.0nosystemd1
vlc-plugin-video-output (2.2.7-1~deb9u1) to 3.0.2-1.0nosystemd1
wavpack (5.0.0-2+deb9u1) to 5.0.0-2+deb9u2
wget (1.18-5+deb9u1) to 1.18-5+deb9u2

Installed the following packages:
libvlccore9 (3.0.2-1.0nosystemd1)

No VLC in menu any longer. Can't completely remove or add VLC through Synaptic

Code: Select all

$ inxi -F
System:    Host: antix3 Kernel: 4.15.9-antix.1-amd64-smp x86_64 bits: 64 Desktop: IceWM 1.4.2 
           Distro: antiX-17.1_x64-full Heather Heyer 17 March 2018 
Machine:   Type: Laptop Mobo: MSI model: B350M GAMING PRO (MS-7A39) v: 1.0 serial: <root required> 
           UEFI [Legacy]: American Megatrends v: 2.30 date: 03/24/2017 
CPU:       Topology: Quad Core model: AMD Ryzen 5 1500X bits: 64 type: MT MCP L2 cache: 2048 KiB 
           Speed: 1753 MHz min/max: 1550/3500 MHz Core speeds (MHz): 1: 1374 2: 1375 3: 1374 4: 1374 5: 1375 
           6: 1374 7: 1384 8: 1386 
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] RV670 [Radeon HD 3690/3850] driver: radeon v: kernel 
           Display: server: X.Org 1.19.2 driver: ati,radeon unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Gallium 0.4 on AMD RV670 (DRM 2.50.0 / 4.15.9-antix.1-amd64-smp LLVM 3.9.1) 
           v: 3.3 Mesa 13.0.6 
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] RV670/680 HDMI Audio [Radeon HD 3690/3800 Series] 
           driver: snd_hda_intel 
           Card-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.15.9-antix.1-amd64-smp 
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 18:d6:c7:06:f9:4a 
Drives:    HDD Total Size: 232.89 GiB used: 104.10 GiB (44.7%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
Partition: ID-1: / size: 13.72 GiB used: 5.08 GiB (37.0%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 205.70 GiB used: 99.02 GiB (48.1%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A gpu: radeon temp: 88 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 213 Uptime: 8h 27m Memory: 15.68 GiB used: 1.44 GiB (9.2%) Shell: bash inxi: 3.0.10 
green251@antix3:~

JR
Last edited by namida12 on Thu May 31, 2018 1:29 pm, edited 1 time in total.

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5737
Joined: Sat Jul 15, 2006 10:40 am

Re: VLC - Was Removed and not updated

#2 Post by anticapitalista » Mon May 28, 2018 5:49 am

What if you now do

Code: Select all

apt-get install vlc vlc-plugin-base vlc-plugin-vlsub
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5737
Joined: Sat Jul 15, 2006 10:40 am

Re: VLC - Was Removed and not updated

#3 Post by anticapitalista » Mon May 28, 2018 6:03 am

Also, if you have mx repos enabled, remove them. If you installed earlier vlc, you might need to purge it and try again. (apt-get purge vlc-*)
I assume you are using default stretch repos.

It worked on my box (no vlc)

Code: Select all

apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libvlc-bin libvlc5 libvlccore9 vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-qt vlc-plugin-video-output
Recommended packages:
  libproxy-tools vlc-plugin-notify vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-splitter vlc-plugin-visualization
The following NEW packages will be installed:
  libvlc-bin libvlc5 libvlccore9 vlc vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-qt vlc-plugin-video-output
0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
Need to get 11.6 MB of archives.
After this operation, 57.0 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
bfrost
Forum Novice
Forum  Novice
Posts: 20
Joined: Sat Jan 07, 2017 4:11 pm

Re: VLC - Was Removed and not updated

#4 Post by bfrost » Mon May 28, 2018 10:24 am

Also VLC and related libraries removed after install on a couple of machines. After first boot I changed my repos (through MX-Repo Manager) to Sweden and then after that updated and upgraded packages. If accepted suggested upgrades after first boot without changes mentioned before VLC and related packages where removed.

Note: used MX Linux 17.1 release iso when installing.

User avatar
namida12
Forum Guide
Forum Guide
Posts: 1803
Joined: Sun Apr 01, 2007 4:54 pm

Re: VLC - Was Removed and not updated

#5 Post by namida12 » Mon May 28, 2018 10:55 am

anticapitalista wrote:
Mon May 28, 2018 5:49 am
What if you now do

Code: Select all

apt-get install vlc vlc-plugin-base vlc-plugin-vlsub
anticapitalista,

Code: Select all

$ apt-get install vlc vlc-plugin-base vlc-plugin-vlsub
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
green251@antix3:~
$

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5737
Joined: Sat Jul 15, 2006 10:40 am

Re: VLC - Was Removed and not updated

#6 Post by anticapitalista » Mon May 28, 2018 11:10 am

Do it as root
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
namida12
Forum Guide
Forum Guide
Posts: 1803
Joined: Sun Apr 01, 2007 4:54 pm

Re: VLC - Was Removed and not updated

#7 Post by namida12 » Mon May 28, 2018 5:10 pm

anticapitalista wrote:
Mon May 28, 2018 11:10 am
Do it as root
root@antix3:/home/green251# apt-get install vlc vlc-plugin-base vlc-plugin-vlsub
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vlc-plugin-base : Depends: libfontconfig1 (>= 2.12) but 2.11.0-6.7+b1 is to be installed
E: Unable to correct problems, you have held broken packages.
root@antix3:/home/green251#

Still confused: Am I using wrong repositories?

Code: Select all

root@antix3:/home/green251# apt-get purge vlc-*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'vlc-bin' for glob 'vlc-*'
Note, selecting 'vlc-plugin-abi-3-0-0f' for glob 'vlc-*'
Note, selecting 'vlc-plugin-video-output' for glob 'vlc-*'
Note, selecting 'vlc-plugin-rdp' for glob 'vlc-*'
Note, selecting 'vlc-plugin-sdl' for glob 'vlc-*'
Note, selecting 'vlc-plugin-svg' for glob 'vlc-*'
Note, selecting 'vlc-plugin-samba' for glob 'vlc-*'
Note, selecting 'vlc-plugin-fluidsynth-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-fluidsynth' for glob 'vlc-*'
Note, selecting 'vlc-plugin-qt' for glob 'vlc-*'
Note, selecting 'vlc-plugin-notify-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-qt-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-video-output-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-skins2' for glob 'vlc-*'
Note, selecting 'vlc-plugin-visualization' for glob 'vlc-*'
Note, selecting 'vlc-l10n' for glob 'vlc-*'
Note, selecting 'vlc-nox' for glob 'vlc-*'
Note, selecting 'vlc-plugin-notify' for glob 'vlc-*'
Note, selecting 'vlc-plugin-video-splitter-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-zvbi' for glob 'vlc-*'
Note, selecting 'vlc-bin-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-jack-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-skins2-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-base-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-vlsub' for glob 'vlc-*'
Note, selecting 'vlc-plugin-jack' for glob 'vlc-*'
Note, selecting 'vlc-plugin-access-extra' for glob 'vlc-*'
Note, selecting 'vlc-data' for glob 'vlc-*'
Note, selecting 'vlc-plugin-svg-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-visualization-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-video-splitter' for glob 'vlc-*'
Note, selecting 'vlc-plugin-base' for glob 'vlc-*'
Note, selecting 'vlc-plugin-samba-dbgsym' for glob 'vlc-*'
Note, selecting 'vlc-plugin-access-extra-dbgsym' for glob 'vlc-*'
Note, selecting 'libvlccore9' instead of 'vlc-plugin-abi-3-0-0f'
Package 'vlc-plugin-rdp' is not installed, so not removed
Package 'vlc-bin-dbgsym' is not installed, so not removed
Package 'vlc-nox' is not installed, so not removed
Package 'vlc-plugin-access-extra' is not installed, so not removed
Package 'vlc-plugin-access-extra-dbgsym' is not installed, so not removed
Package 'vlc-plugin-base' is not installed, so not removed
Package 'vlc-plugin-base-dbgsym' is not installed, so not removed
Package 'vlc-plugin-fluidsynth' is not installed, so not removed
Package 'vlc-plugin-fluidsynth-dbgsym' is not installed, so not removed
Package 'vlc-plugin-jack' is not installed, so not removed
Package 'vlc-plugin-jack-dbgsym' is not installed, so not removed
Package 'vlc-plugin-notify' is not installed, so not removed
Package 'vlc-plugin-notify-dbgsym' is not installed, so not removed
Package 'vlc-plugin-qt-dbgsym' is not installed, so not removed
Package 'vlc-plugin-samba' is not installed, so not removed
Package 'vlc-plugin-samba-dbgsym' is not installed, so not removed
Package 'vlc-plugin-skins2' is not installed, so not removed
Package 'vlc-plugin-skins2-dbgsym' is not installed, so not removed
Package 'vlc-plugin-svg' is not installed, so not removed
Package 'vlc-plugin-svg-dbgsym' is not installed, so not removed
Package 'vlc-plugin-video-output-dbgsym' is not installed, so not removed
Package 'vlc-plugin-video-splitter' is not installed, so not removed
Package 'vlc-plugin-video-splitter-dbgsym' is not installed, so not removed
Package 'vlc-plugin-visualization' is not installed, so not removed
Package 'vlc-plugin-visualization-dbgsym' is not installed, so not removed
Package 'vlc-plugin-zvbi' is not installed, so not removed
Package 'vlc-plugin-sdl' is not installed, so not removed
Package 'vlc-plugin-vlsub' is not installed, so not removed
The following packages were automatically installed and are no longer required:
  liba52-0.7.4 libbasicusageenvironment1 libdca0 libdvbpsi10 libebml4v5 libgles1-mesa
  libgles2-mesa libgroupsock8 libkate1 liblirc-client0 liblivemedia57 libmatroska6v5
  libmpeg2-4 libopenmpt-modplug1 libqt5x11extras5 libsdl-image1.2 libshout3 libspeexdsp1
  libupnp6 libusageenvironment3 libvcdinfo0 libvlc-bin libvlc5 libvlccore8 libvlccore9
  libxcb-xv0
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  vlc-bin* vlc-data* vlc-l10n* vlc-plugin-qt* vlc-plugin-video-output*
0 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
After this operation, 43.2 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 168800 files and directories currently installed.)
Removing vlc-bin (3.0.2-1.0nosystemd1) ...
Removing vlc-data (3.0.2-1.0nosystemd1) ...
Removing vlc-l10n (3.0.2-1.0nosystemd1) ...
Removing vlc-plugin-qt:amd64 (3.0.2-1.0nosystemd1) ...
Removing vlc-plugin-video-output:amd64 (3.0.2-1.0nosystemd1) ...
Processing triggers for libvlc-bin:amd64 (3.0.2-1.0nosystemd1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
(Reading database ... 168488 files and directories currently installed.)
Purging configuration files for vlc-plugin-qt:amd64 (3.0.2-1.0nosystemd1) ...
Purging configuration files for vlc-plugin-video-output:amd64 (3.0.2-1.0nosystemd1) ...
root@antix3:/home/green251# 

Now try to install VLC?

User avatar
namida12
Forum Guide
Forum Guide
Posts: 1803
Joined: Sun Apr 01, 2007 4:54 pm

Re: VLC - Was Removed and not updated

#8 Post by namida12 » Mon May 28, 2018 5:19 pm

Code: Select all

$ su
Password: 
root@antix3:/home/green251# apt-get install vlc vlc-plugin-base vlc-plugin-vlsub
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc-plugin-base : Depends: libfontconfig1 (>= 2.12) but 2.11.0-6.7+b1 is to be installed
E: Unable to correct problems, you have held broken packages.
root@antix3:/home/green251# 

I think I am using Stretch....

Code: Select all

Repos:
  Active apt repos in: /etc/apt/sources.list.d/antix.list 
  1: deb http://iso.mxrepo.com/antix/stretch/ stretch main nosystemd
  Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
  1: deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/debian.list 
  1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
  2: deb http://security.debian.org/ stretch/updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
  1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
  No active apt repos in: /etc/apt/sources.list.d/onion.list 
  Active apt repos in: /etc/apt/sources.list.d/opera-stable.list 
  1: deb https://deb.opera.com/opera-stable/ stable non-free
  No active apt repos in: /etc/apt/sources.list.d/various.list 
root@antix3:/home/green251# 

JR

User avatar
rokytnji.1
Forum Regular
Forum Regular
Posts: 752
Joined: Sun Apr 13, 2014 9:06 pm

Re: VLC - Was Removed and not updated

#9 Post by rokytnji.1 » Mon May 28, 2018 5:41 pm

Go into synaptic and fix broken packages 1st is what I would do.

Then apt-get update. Did you purge VLC like Anti suggested?

User avatar
namida12
Forum Guide
Forum Guide
Posts: 1803
Joined: Sun Apr 01, 2007 4:54 pm

Re: VLC - Was Removed and not updated

#10 Post by namida12 » Mon May 28, 2018 5:48 pm

rokytnji.1 wrote:
Mon May 28, 2018 5:41 pm
Go into synaptic and fix broken packages 1st is what I would do.

Then apt-get update. Did you purge VLC like Anti suggested?
Yes, then I tried to reinstall. telling me I need ...
vlc-plugin-base : Depends: libfontconfig1 (>= 2.12) but 2.11.0-6.7+b1 is to be installed

Am guessing libfontconfig1 2.12 is not in my repositories

See attachment: 0 broken Packages

JR
You do not have the required permissions to view the files attached to this post.

Post Reply

Return to “antiX”