Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Problems installing xfce4 [Solved]

Message
Author
User avatar
keos
Forum Regular
Forum Regular
Posts: 193
Joined: Sat Mar 04, 2017 1:00 pm

Re: Problems installing xfce4

#11 Post by keos » Tue May 15, 2018 10:02 am

i fix it, i found another wicd icon at the menu so i removed the two icons at the panel and moved the one from the menu to the panel.

There still going on a minor problem: two icons of synaptic, gparted, etc at the menu system option.

The last problem is this, a delay of around a minute when the system start:

[....] configuring network interfaces ... ifup: waiting for lock on /run/network/ifstate.eth0

Do i have to open another post?
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Linux 4.15.0-1-amd64 #1 SMP Debian 4.15.4-1~mx17+1 (2018-02-23) x86_64 GNU/Linux

xfce4-panel 4.12.1

Devuan Ascii

xfce4-panel 4.12.2

User avatar
Richard
Posts: 2245
Joined: Fri Dec 12, 2008 10:31 am

Re: Problems installing xfce4

#12 Post by Richard » Wed May 16, 2018 12:18 am

I think it's all a part of your original problem, to install Xfce4 on antiX.

I got a great reply tonight that explains what is missing.
Xfce4 has to be guided to appear on Frugal.
I installed antiX on an EeePC netbook, then Xfce4 and it boots and runs. Algo feo, pero corregible.
I'll post about it tomorrow. Got to get up early and it's already late. :)
Last edited by Richard on Wed May 16, 2018 10:38 am, edited 1 time in total.
MX18b1: Lenovo T430: Intel Ivy Bridge i5-3320M, 8GB RAM, 4.9.0-8-amd64, 119 GB SSD
MX18b1: Eee&AA1 NBs: Dual Core Atom N270, 1GB RAM, 4.9.0-8-686, 150 GB HDD
DoubleCmd/Thunar, LibO613, Dropbox, Vivaldi/Firefox, CherryTree, Vbox. LinuxCounter #208633

User avatar
Richard
Posts: 2245
Joined: Fri Dec 12, 2008 10:31 am

Re: Problems installing xfce4

#13 Post by Richard » Wed May 16, 2018 7:57 am

from Member 736b69646f6f
“no sign of Xfce”
installing the xfce package doesn’t automatically edit the display manager configuration file.

1. edit /etc/slim.conf
find the line which looks like:
sessions rox-fluxbox,space-fluxbox,fluxbox,rox-icewm,space-icewm,icewm,rox-jwm,space-jwm,jwm,herbstluftwm
and change it to:
sessions rox-fluxbox,space-fluxbox,fluxbox,rox-icewm,space-icewm,icewm,rox-jwm,space-jwm,jwm,herbstluftwm,xfce4start

2. will need to kill/restart slim display manager (or just reboot) for the change to take effect.

3. Next time you visit slim login screen, Xfce will be among the available F1 selections.

Get ready to search the earlier forum messages, xfce ignores a handful of details,
like session autostart items already in place for the other window managers
Después de la primer vez que inicia el Xfce4 será el predeterminado.

Si tienes otras repos habilitados en antiX debe deshabilitarlos
hasta que alguien puede confirmar que no causa problemas.

antiX no usa systemd.
Muchos programas en internet que vienen en ficheros *.deb, no serán compatibles.
MX18b1: Lenovo T430: Intel Ivy Bridge i5-3320M, 8GB RAM, 4.9.0-8-amd64, 119 GB SSD
MX18b1: Eee&AA1 NBs: Dual Core Atom N270, 1GB RAM, 4.9.0-8-686, 150 GB HDD
DoubleCmd/Thunar, LibO613, Dropbox, Vivaldi/Firefox, CherryTree, Vbox. LinuxCounter #208633

User avatar
keos
Forum Regular
Forum Regular
Posts: 193
Joined: Sat Mar 04, 2017 1:00 pm

Re: Problems installing xfce4

#14 Post by keos » Wed May 16, 2018 9:51 am

Well ... i did something ... i don't know if it is going to work in the future, but till now -- after restart twice -- it is working good. I changed repos into synaptic from scid to testing and at the slim configuration i changed too, as Richard recommended to xfcestart.

VLC is installed and work fine.


Only one thing remain been a problem, a delay ...:


[....] configuring network interfaces ... ifup: waiting for lock on /run/network/ifstate.eth0
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Linux 4.15.0-1-amd64 #1 SMP Debian 4.15.4-1~mx17+1 (2018-02-23) x86_64 GNU/Linux

xfce4-panel 4.12.1

Devuan Ascii

xfce4-panel 4.12.2

User avatar
Richard
Posts: 2245
Joined: Fri Dec 12, 2008 10:31 am

Re: Problems installing xfce4

#15 Post by Richard » Wed May 16, 2018 10:29 am

Sounds like a conflict of network managers.
If you have more than one?
MX18b1: Lenovo T430: Intel Ivy Bridge i5-3320M, 8GB RAM, 4.9.0-8-amd64, 119 GB SSD
MX18b1: Eee&AA1 NBs: Dual Core Atom N270, 1GB RAM, 4.9.0-8-686, 150 GB HDD
DoubleCmd/Thunar, LibO613, Dropbox, Vivaldi/Firefox, CherryTree, Vbox. LinuxCounter #208633

User avatar
keos
Forum Regular
Forum Regular
Posts: 193
Joined: Sat Mar 04, 2017 1:00 pm

Re: Problems installing xfce4

#16 Post by keos » Wed May 16, 2018 12:09 pm

i went to synaptic and i surprised that not even one of the option for network manager are installed ... how is it possible?, i'm connected.
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Linux 4.15.0-1-amd64 #1 SMP Debian 4.15.4-1~mx17+1 (2018-02-23) x86_64 GNU/Linux

xfce4-panel 4.12.1

Devuan Ascii

xfce4-panel 4.12.2

User avatar
keos
Forum Regular
Forum Regular
Posts: 193
Joined: Sat Mar 04, 2017 1:00 pm

Re: Problems installing xfce4

#17 Post by keos » Wed May 16, 2018 12:28 pm

well, there is wicd:

Image
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Linux 4.15.0-1-amd64 #1 SMP Debian 4.15.4-1~mx17+1 (2018-02-23) x86_64 GNU/Linux

xfce4-panel 4.12.1

Devuan Ascii

xfce4-panel 4.12.2

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10095
Joined: Sun Dec 16, 2007 1:17 pm

Re: Problems installing xfce4

#18 Post by dolphin_oracle » Wed May 16, 2018 12:38 pm

if you installed network-manager, remove any eth* entries in /etc/network/interfaces.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
keos
Forum Regular
Forum Regular
Posts: 193
Joined: Sat Mar 04, 2017 1:00 pm

Re: Problems installing xfce4

#19 Post by keos » Wed May 16, 2018 1:22 pm

network-manager is not installed it is wicd what is installed.

https://postimg.cc/image/gawwjfytj/



Image
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Linux 4.15.0-1-amd64 #1 SMP Debian 4.15.4-1~mx17+1 (2018-02-23) x86_64 GNU/Linux

xfce4-panel 4.12.1

Devuan Ascii

xfce4-panel 4.12.2

User avatar
keos
Forum Regular
Forum Regular
Posts: 193
Joined: Sat Mar 04, 2017 1:00 pm

Re: Problems installing xfce4

#20 Post by keos » Wed May 16, 2018 2:27 pm

More information:
keos@kaos:~
$ lspci | grep -i ethernet
01:00.0 Ethernet controller: Qualcomm Atheros AR8162 Fast Ethernet (rev 10)
keos@kaos:~
$ lspci | grep -i network
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
keos@kaos:~
$ sudo ethtool -i interfaz
Cannot get driver information: No such device
keos@kaos:~
$ sudo ethtool -i eth0
driver: alx
version:
firmware-version:
expansion-rom-version:
bus-info: 0000:01:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no
keos@kaos:~
$ sudo ethtool -i wlan0
driver: rtl8192ce
version: 4.9.87-antix.1-amd64-smp
firmware-version: N/A
expansion-rom-version:
bus-info: 0000:02:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no
keos@kaos:~
$
#
# interfaces(5) file used by ifup(8) and ifdown(8)
# Used by ceni but not by wicd
#------------------------------------------------------------------------------

auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp

allow-hotplug eth1
iface eth1 inet dhcp

allow-hotplug eth2
iface eth2 inet dhcp

allow-hotplug eth3
iface eth3 inet dhcp



keos@kaos:~
$
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Linux 4.15.0-1-amd64 #1 SMP Debian 4.15.4-1~mx17+1 (2018-02-23) x86_64 GNU/Linux

xfce4-panel 4.12.1

Devuan Ascii

xfce4-panel 4.12.2

Post Reply

Return to “antiX”