Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Problems installing xfce4 [Solved]

Message
Author
User avatar
keos
Forum Regular
Forum Regular
Posts: 133
Joined: Sat Mar 04, 2017 1:00 pm

Problems installing xfce4 [Solved]

#1 Post by keos » Sun May 13, 2018 3:47 pm

hi,

Yes, i have to change the subject, im having some problems with the installation of the desktop xfce4, there are many desktop in antiX but not xfce :eek:

*the two wicd icons remaing at the panel after i remove add-start-antiX (if i understood what you said ...)

*At the menu list (left up corner) there is not even one icon ...

*An when i move the arrow to display different options at the menu i found double icons of gparted, synaptic, etc

This is a mess ... :alien:

When i start the system there is a delay of around a minute at this point: [....] configuring network interfaces ... ifup ...

I'm going to reinstall the system, something is very wrong.

Thanks.
Last edited by keos on Wed May 16, 2018 3:29 pm, edited 4 times in total.
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

antiX 17.1

Devuan

xfce4-panel 4.12.2

Firefox, Palemoon

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8456
Joined: Sun Dec 16, 2007 1:17 pm

Re: xfce show two wicd icons at the panel

#2 Post by dolphin_oracle » Sun May 13, 2018 4:05 pm

You will want to remove either the ~/.config/autostart entry or the version in desktop-session/startup.

It's just the client that launches twice. The underlying daemon should not be.
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)

User avatar
keos
Forum Regular
Forum Regular
Posts: 133
Joined: Sat Mar 04, 2017 1:00 pm

Re: Problems installing xfce4

#3 Post by keos » Mon May 14, 2018 8:37 am

sorry i made a mistake posting and editing at the wrong ...
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

antiX 17.1

Devuan

xfce4-panel 4.12.2

Firefox, Palemoon

User avatar
asqwerth
Forum Guide
Forum Guide
Posts: 2779
Joined: Sun May 27, 2007 5:37 am

Re: Problems installing xfce4

#4 Post by asqwerth » Mon May 14, 2018 8:44 am

Log out, and from the login window, press the function key as per the directions on screen to scroll through the selection of Window managers (I can't recall which function key it is right now).

The last one in the list will be XFCE, if you have installed it.

Select that then login again, to be in the XFCE environment.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
keos
Forum Regular
Forum Regular
Posts: 133
Joined: Sat Mar 04, 2017 1:00 pm

Re: Problems installing xfce4

#5 Post by keos » Mon May 14, 2018 12:38 pm

i reinstall the system, this time even when xfce4 is installed it do not show up at the login page.
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

antiX 17.1

Devuan

xfce4-panel 4.12.2

Firefox, Palemoon

User avatar
Richard
Posts: 1684
Joined: Fri Dec 12, 2008 10:31 am

Re: Problems installing xfce4

#6 Post by Richard » Mon May 14, 2018 8:54 pm

@Keos,
I don't remember if Xfce4 will not show up in the login screen of antiX.
I've installed Xfce4 on antiX before.
Seems like I used to have to use the F1 or some such to bring it up.
Then to run it, you need to switch to it before you press Enter on your password.
After the first time it is the preferred s until you change.

There must be something wrong somewhere. I've never had so much trouble.
MX is similar to Debiand, Windows, LinuxMint and Elementary so long as you stay
within the bounds of their systems where things have been tested.
Outside of that is a whole new, unknown world of experimentation.

I'm in the process of installing my snapshot of 32 bit antiX17 on a 16GB USB.
Then I'll install the Xfce-Lite via the antiX Package Installer.

It will take a while on the Xfce4 install via the 32bit AcerAspireOne netbook.
More info probably in the morning. Ok, it took 14 minutes; now to install Xfce4.
MX17.1: T430-2017, 8 GB RAM, 4.15.0-1-amd64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DoubleCmd, LO604, Dropbox, Slimjet, mPDFed, Py3, CherryT, Vbox

User avatar
Richard
Posts: 1684
Joined: Fri Dec 12, 2008 10:31 am

Re: Problems installing xfce4

#7 Post by Richard » Mon May 14, 2018 10:55 pm

@keos,
I am going to take this to the antiX forum.
I installed Xfce4-Lite onto my 16 GB USB
but can't find how to start it. Same as you.

Come on over to https://www.antixforum.com/
Change language if you wish.
Register and we'll find a solution.

Saludos, Richard.
MX17.1: T430-2017, 8 GB RAM, 4.15.0-1-amd64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DoubleCmd, LO604, Dropbox, Slimjet, mPDFed, Py3, CherryT, Vbox

User avatar
asqwerth
Forum Guide
Forum Guide
Posts: 2779
Joined: Sun May 27, 2007 5:37 am

Re: Problems installing xfce4

#8 Post by asqwerth » Tue May 15, 2018 12:20 am

For what it's worth, my antiX+XFCE install is a Virtualbox installation on my desktop PC, using antiX-17-beta3.

But I used full XFCE, not XFCE-Lite. That works.

viewtopic.php?p=432963#p432963
As an experiment, I previously installed XFCE on an AntiX VM by installing various XFCE packages from Synaptic rather than XFCE-Lite from the package installer.

I made a list of what I did:
1. installed Packages: xfce metapackage, whiskermenu-plugin, faenza-cupertino and greybird. Also installed papirus icons or whatever icon theme you like, e.g. Moka+Faba.
2. Then logout and at the login screen, press F1 to flip through the selection of window managers until you get to xfce, then log back in.
3. first time logging into xfce in antiX17, it will look weird because the default icon theme is missing lots of icons. You'll need to go to "Appearance" and change the icon set to any of the faenza ones or papirus. Whisker menu will have to be manually added to the panel if you want it.
4. apply greybird theme or any other theme that is compatible with XFCE.

It worked fine. Get various launchers set up on the panel if you want them. The AntiX control centre didn't show up in XFCE by default IIRC though, so I had to adjust the .desktop file. If you want MX-apps and MX Tools, you'll need to add the MX repo though. I am not sure if there are conflicts with antix tool packages, as I didn't try.

Regarding the default antix desktop and login manager: once you scroll through the whole list of other window managers (using F1) and select XFCE on your first bootup, I think it will start you in XFCE in subsequently logins. Not as nicely laid out graphically as lightdm, but usable.

Also, you can use antiX's systemd-less version of MATE: see this screenshot
viewtopic.php?p=408376#p408376

My old laptop used to use antiX+MATE until the hard drive got corrupted and died. When I wiped the HDD and reinstalled, I chose to go with MX16.1 instead.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
Richard
Posts: 1684
Joined: Fri Dec 12, 2008 10:31 am

Re: Problems installing xfce4

#9 Post by Richard » Tue May 15, 2018 12:47 am

Yes, I have installed antiX to HDD then Xfce4-Lite via Package Installer and it worked fine.
I may be reaching the limits of something, memory, disk space, but received no error messages.
I just made a frugal install on an EeePC netbook and installing Xfce4-Lite again.
Maybe somebody at antiX has some ideas or experiences.
Thanks.
MX17.1: T430-2017, 8 GB RAM, 4.15.0-1-amd64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DoubleCmd, LO604, Dropbox, Slimjet, mPDFed, Py3, CherryT, Vbox

User avatar
keos
Forum Regular
Forum Regular
Posts: 133
Joined: Sat Mar 04, 2017 1:00 pm

Re: Problems installing xfce4

#10 Post by keos » Tue May 15, 2018 8:43 am

o'k, a litter bit of progress ... i install xfce-power-manager and it change to another login, slim, then reboot the system and this time xfce can be displayed ...

But now i'm back again into the previous subject: two wicd icons at the panel and a new one a windows open with many option to different desktop and when i select xfce the double icons disappear for a moment to comeback again and again ...

Richard, no puedo entrar a registrarme en ese foro da siempre un error, indica que ya estoy registrado ...
Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

antiX 17.1

Devuan

xfce4-panel 4.12.2

Firefox, Palemoon

Post Reply

Return to “antiX”