Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

How to disable touchpad tapping in antiX 17?

Message
Author
User avatar
Raymzap
Forum Regular
Forum Regular
Posts: 104
Joined: Mon Aug 25, 2014 9:40 am

How to disable touchpad tapping in antiX 17?

#1 Post by Raymzap » Fri Feb 23, 2018 11:19 am

Hi.

How do I disable touchpad tapping in antiX 17?

Thanks.
GNU/Linux User #470660

Linus Torvalds: "Microsoft isn't evil, they just make really crappy operating systems."

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9043
Joined: Sun Dec 16, 2007 1:17 pm

Re: How to disable touchpad tapping in antiX 17?

#2 Post by dolphin_oracle » Fri Feb 23, 2018 11:21 am

I use syndameon for this.

from the arch wiki:

https://wiki.archlinux.org/index.php/To ... ile_typing

For example, to disable tapping and scrolling for 0.5 seconds after each keypress (ignoring modifier keys like Ctrl), use

Code: Select all

$ syndaemon -i 0.5 -t -K -R
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Raymzap
Forum Regular
Forum Regular
Posts: 104
Joined: Mon Aug 25, 2014 9:40 am

Re: How to disable touchpad tapping in antiX 17?

#3 Post by Raymzap » Fri Feb 23, 2018 11:27 am

dolphin_oracle wrote:I use syndameon for this.

from the arch wiki:

https://wiki.archlinux.org/index.php/To ... ile_typing

For example, to disable tapping and scrolling for 0.5 seconds after each keypress (ignoring modifier keys like Ctrl), use

Code: Select all

$ syndaemon -i 0.5 -t -K -R
Hi DO. I'd rather permanently disable tapping.
GNU/Linux User #470660

Linus Torvalds: "Microsoft isn't evil, they just make really crappy operating systems."

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9043
Joined: Sun Dec 16, 2007 1:17 pm

Re: How to disable touchpad tapping in antiX 17?

#4 Post by dolphin_oracle » Fri Feb 23, 2018 11:34 am

Code: Select all

Option "TouchpadOff" "2"
in the /etc/X11/xorg.conf.d/synaptics.conf file, and then log out and log in should do the trick.

other options for that switch

Switch off the touchpad. Valid values are:
0 Touchpad is enabled
1 Touchpad is switched off
2 Only tapping and scrolling is switched off

more info here:

ftp://www.x.org/pub/X11R7.5/doc/man/man ... ics.4.html
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Raymzap
Forum Regular
Forum Regular
Posts: 104
Joined: Mon Aug 25, 2014 9:40 am

Re: How to disable touchpad tapping in antiX 17?

#5 Post by Raymzap » Fri Feb 23, 2018 2:15 pm

dolphin_oracle wrote:

Code: Select all

Option "TouchpadOff" "2"
in the /etc/X11/xorg.conf.d/synaptics.conf file, and then log out and log in should do the trick.
...
I did that (but used the "1" option) and it borked something. I no longer get a graphical desktop. I can login via terminal but startx does nothing. :frown:
GNU/Linux User #470660

Linus Torvalds: "Microsoft isn't evil, they just make really crappy operating systems."

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9043
Joined: Sun Dec 16, 2007 1:17 pm

Re: How to disable touchpad tapping in antiX 17?

#6 Post by dolphin_oracle » Fri Feb 23, 2018 2:20 pm

Did you put the option in line with the other options in the file?

I tried it here and it certainly turned off tapping and scrolling.


Otherwise, I guess take it back out.
Last edited by dolphin_oracle on Fri Feb 23, 2018 2:31 pm, edited 1 time in total.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Raymzap
Forum Regular
Forum Regular
Posts: 104
Joined: Mon Aug 25, 2014 9:40 am

Re: How to disable touchpad tapping in antiX 17?

#7 Post by Raymzap » Fri Feb 23, 2018 2:30 pm

dolphin_oracle wrote:Did you put the option in line with the other options in the file?

I tried it here and it certainly turned of tapping and scrolling.


Otherwise, I guess take it back out.
I put a # in front of the original line and kept the "1" inline with the other options.

I also logged in via the terminal and re-edited the file to remove the new line and kept the original line without the # but something is still broken. :confused:
Last edited by Raymzap on Fri Feb 23, 2018 2:31 pm, edited 1 time in total.
GNU/Linux User #470660

Linus Torvalds: "Microsoft isn't evil, they just make really crappy operating systems."

User avatar
Raymzap
Forum Regular
Forum Regular
Posts: 104
Joined: Mon Aug 25, 2014 9:40 am

Re: How to disable touchpad tapping in antiX 17?

#8 Post by Raymzap » Fri Feb 23, 2018 2:31 pm

Sorry, I removed the text here as it was a double post.
GNU/Linux User #470660

Linus Torvalds: "Microsoft isn't evil, they just make really crappy operating systems."

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9043
Joined: Sun Dec 16, 2007 1:17 pm

Re: How to disable touchpad tapping in antiX 17?

#9 Post by dolphin_oracle » Fri Feb 23, 2018 2:36 pm

I don't see any existing line.

this is my file as edited.

Code: Select all

Section "InputClass"
        Identifier      "Touchpad"                      # required
        MatchIsTouchpad "yes"                           # required
        Driver          "synaptics"                     # required
        Option          "MinSpeed"              "0.5"
        Option          "MaxSpeed"              "1.0"
        Option          "AccelFactor"           "0.075"
        Option          "TapButton1"            "1"
        Option          "TapButton2"            "2"     # multitouch
        Option          "TapButton3"            "3"     # multitouch
        Option          "VertTwoFingerScroll"   "1"     # multitouch
        Option          "HorizTwoFingerScroll"  "1"     # multitouch
        Option          "VertEdgeScroll"        "1"
        Option          "CoastingSpeed"         "8"
        Option          "CornerCoasting"        "1"
        Option          "CircularScrolling"     "1"
        Option          "CircScrollTrigger"     "7"
        Option          "EdgeMotionUseAlways"   "1"
        Option          "LBCornerButton"        "8"     # browser "back" btn
        Option          "RBCornerButton"        "9"     # browser "forward" btn
        Option	    "TouchpadOff"		"2"	#turn off touchpad tapping and scrolling
EndSection
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Richard
Posts: 1933
Joined: Fri Dec 12, 2008 10:31 am

Re: How to disable touchpad tapping in antiX 17?

#10 Post by Richard » Fri Feb 23, 2018 2:42 pm

antiX thread, only saw the 17.
Irrelevant post
Last edited by Richard on Fri Feb 23, 2018 2:55 pm, edited 1 time in total.
MX17.1: Lenovo T430-2017, 8 GB RAM, 4.15.0-1-amd64, intel_pstate, 119 GB SSD
MX17.1: AA1(ZG5) / EeePC-1005HA, 1 GB RAM, 4.15.0-1-686-pae ____ 150 GB HDD
DC9, LibO610, Dropbox, FF, FFesr, mPDFed, CherryT, Vbox. Linux Counter #288562

Post Reply

Return to “antiX”