Welcome!

Please read this important information about Spectre and Meltdown vulnerabilities.
Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 Final release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

grub bug at boot time: no symbol table

Message
Author
greenpossum
Forum Novice
Forum  Novice
Posts: 2
Joined: Wed Oct 25, 2017 7:06 am

grub bug at boot time: no symbol table

#1 Postby greenpossum » Wed Oct 25, 2017 7:30 am

OS: AntiX 17 32-bit, fresh install

Hardware:

1. Asus EEE PC 900, 32-bit, 1GB RAM, 8 GB disk
2. VirtualBox 32-bit, 1GB RAM, 8 GB disk

What happens: On power up, grub flashes a message saying "no symbol table" before showing the graphical boot menu. After selecting AntiX, it again shows "no symbol table", and a couple of lines later Press any key to continue. If a key is pressed or one waits a few seconds, the boot will continue as normal.

This appears to be an upstream bug in grub, a search on the phrase "grub error no symbol table" shows that this happens in many distros. However this Debian bug report seems to be the most informative:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=841297

Even though it mentions grub-efi it happens with other boot loaders too, as the search results show. Also this bug seems to have been there perhaps a year or two, and the latest report from a couple of months ago has no solution. The best clue I think is that the load video line in grub.cfg triggers it and perhaps one of the video modules doesn't have symbols.

I first happened on this bug when I tried to fix the warning that vga= was deprecated in favour of gfxpayload but the bug also happens with vga= I tried the suggested fixes in posts, grub-install, update-grub, etc. to no avail.

Although it's just an annoyance slowing down boot, it would be nice if someone could hunt down the bug and take the glory. Debugging grub is a bit beyond me unfortunately.

Cheers and thanks for AntiX, it's just the thing for my ancient netbook. :happy:

User avatar
rokytnji.1
Forum Regular
Forum Regular
Posts: 509
Joined: Sun Apr 13, 2014 9:06 pm

Re: grub bug at boot time: no symbol table

#2 Postby rokytnji.1 » Sat Oct 28, 2017 10:35 am

I ran AntiX for years on EEEPC 900's and wrote tutorials on just that hardware. Virtual Box running on EEEPC 900 with a 800 MHZ celeron processor?

That is not my territory. I would never even think of doing that . Even on my current Single core atom n270 9 inch net-book with a touch screen and 2 gig of ram with a 60 gig SSD drive. Which I replaced my EEEPC's with.

Back then. I ran legacy grub. Now. With 16.2 presently on my touch screen net-book. Which uses grub2. Still no problemo with a regular install. So I think they may be a virtual box setup problem of some sort. Which I am not qualified to answer on.

Later on < in the future >. I will be reinstalling AntiX < 17 Stretch version > on my touch screen net-book. Just procrastinating because of my touch screen hardware. Because I use a little elbow grease to set that up.

Good luck with it. Sorry I am not qualified to trouble shoot this.

Edit. Read your bug report after I posted. Maybe a Debian Stretch bug you found about. I guess I'll find out when I reinstall AntiX on my net-book.

greenpossum
Forum Novice
Forum  Novice
Posts: 2
Joined: Wed Oct 25, 2017 7:06 am

Re: grub bug at boot time: no symbol table

#3 Postby greenpossum » Sun Oct 29, 2017 9:57 pm

Yes, you read it correctly eventually. It happens on both platforms, real and virtual. And it happens in other distros too so I think it's a grub bug, possibly due to some change in the toolchain used to build grub. Good luck with your install.

For the benefit of others as well, I found that unetbootin doesn't create a suitable USB stick but the live USB builder in AntiX 17 does. So I built the USB stick for my netbook using the virtual AntiX 17 writing to the USB stick using USB passthrough (great feature).


Return to “antiX”

Who is online

Users browsing this forum: No registered users and 2 guests