Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

no video after antiX 17 kernel upgrade to 4.13

Message
Author
User avatar
entropyfoe
Forum Regular
Forum Regular
Posts: 776
Joined: Thu Apr 19, 2007 11:42 am

no video after antiX 17 kernel upgrade to 4.13

#1 Post by entropyfoe » Sat Oct 21, 2017 6:05 pm

I am taking this out of the liquorix thread where it does not belong.

I did upgrade the kernel in my antiX 17 beta2 fully updated.
I can select either the new kernel 4.13 antix 64 bit or the stock 4.10.

The 4.10 still works, but the new one gives a black screen log in.

So I logged in, that works so the system is there.
But when I startx, I get nothing but a fatal error, "no screens"

So how to get video?
Can I run one of the scripts sgfxi or smxi ?
Will that get me an xorg and an nvidia driver?

Or, if this is a long path, I will try downloading antix 17 rc1 and starting over.
I am getting close, and with some advice to help me when I am the edge of my linux experience, I think I can do this.

Thanks anticapitalista and all the kernel experts here.
Last edited by entropyfoe on Sun Oct 22, 2017 1:55 pm, edited 1 time in total.
Asus Prime 370X-Pro
AMD Ryzen 1600X (6 cores @ 3.6 GHz)
16 Gig DDR4 3200 (G Skill)
Nvidia -MSI GeForce GT 710 fanless
Samsung 960 NVMe SSD nvme0n1 P1,P2, and P3=MX-17, P4=antiX-17
1TB SSD sda1= Data, 2TB WD =backups
on-board ethernet & sound

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9270
Joined: Wed Jul 12, 2006 2:26 pm

Re: no video after antiX 17 kernel upgrade to 4.13

#2 Post by kmathern » Sat Oct 21, 2017 6:31 pm

Was the nvidia driver for the 4.10 kernel installed using sgfxi?

If it was you might try sgfxi's -! 40 option, here's what sgfxi's help says about it:

Code: Select all

-! 40 Create modules for all your kernels (nVidia only). Will loop through and test
      each if can be made, then create the modules, excluding your running kernel.
      You must have already installed an nVidia driver with sgfxi to use -! 40
      Note: if your installed driver is NOT the default sgfxi offers, you have to
      use either the -o <driver number> OR the -B option (if you are using current beta driver)
      as well as the -! 40 option. EG: to install beta to all kernels: sgfxi -B -! 40
      -! 40 must be the LAST option in your list of options or errors will occur!
You can run the -! 40 sgfxi command while at the desktop in X and running the 4.10 kernel.
The version of the nvidia driver that's currently installed for the 4.10 kernel does also need to support the 4.13 kernel.
Even if it fails during installation because it doesn't support a 4.13 kernel, your existing nvidia install for the 4.10 kernel should keep working.

Code: Select all

sgfxi -! 40

User avatar
entropyfoe
Forum Regular
Forum Regular
Posts: 776
Joined: Thu Apr 19, 2007 11:42 am

Re: no video after antiX 17 kernel upgrade to 4.13

#3 Post by entropyfoe » Sat Oct 21, 2017 7:09 pm

I get no desktop in 4.13, only a terminal, and startx fails with the fatal error 'NO SCREENS'

I did not use sgfxi to install the nvidia driver
I used the antix control center,

or does that just invoke the sgfxi script?
So, could I run the script from my 4.10 kernel, accept what ever sgfxi recommends for the nvidia
( I have this :
Graphics: Card: NVIDIA GK208 [GeForce GT 710B]
Display Server: X.Org 1.19.2 driver: nvidia Resolution: 1920x1080@60.00hz
OpenGL: renderer: GeForce GT 710/PCIe/SSE2 version: 4.5.0 NVIDIA 375.82
Asus Prime 370X-Pro
AMD Ryzen 1600X (6 cores @ 3.6 GHz)
16 Gig DDR4 3200 (G Skill)
Nvidia -MSI GeForce GT 710 fanless
Samsung 960 NVMe SSD nvme0n1 P1,P2, and P3=MX-17, P4=antiX-17
1TB SSD sda1= Data, 2TB WD =backups
on-board ethernet & sound

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9270
Joined: Wed Jul 12, 2006 2:26 pm

Re: no video after antiX 17 kernel upgrade to 4.13

#4 Post by kmathern » Sat Oct 21, 2017 7:21 pm

entropyfoe wrote:I did not use sgfxi to install the nvidia driver
I used the antix control center,

or does that just invoke the sgfxi script?
I don't know what the antix control center uses to install the nvidia driver, if you do the nvidia install while in X it's probably not using sgfxi.

You can only run sgfxi -! 40 thing I mentioned if sgfxi is what was used originally to install the nvidia driver for the 4.10 kernel.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15632
Joined: Fri Dec 15, 2006 8:07 pm

Re: no video after antiX 17 kernel upgrade to 4.13

#5 Post by Stevo » Sat Oct 21, 2017 7:50 pm

You can always reboot with the older kernel to get back to a GUI, right?

Check if you have the Debian version, which is appears you do, by running

Code: Select all

apt policy nvidia-driver
If so, try reinstalling the nvidia-kernel-dkms package

Code: Select all

apt install --reinstall nvidia-kernel-dkms
Watch the output to see what kernels it's building for and if there are any failures. There a command to trigger rebuilds for all kernels for dkms, but I don't remember it offhand...I'm sure the Google can turn it up.

User avatar
entropyfoe
Forum Regular
Forum Regular
Posts: 776
Joined: Thu Apr 19, 2007 11:42 am

Re: no video after antiX 17 kernel upgrade to 4.13

#6 Post by entropyfoe » Sat Oct 21, 2017 8:35 pm

kmathern

Yup,
I don't know what the antix control center uses to install the nvidia driver, if you do the nvidia install while in X it's probably not using sgfxi.
It was while in x.
You can only run sgfxi -! 40 thing I mentioned if sgfxi is what was used originally to install the nvidia driver for the 4.10 kernel.
So my option I was thinking was to download the antix rc1, try it out, then install nvidia (need for stability) with sgfxi

Then I can use that option for all kernels which is cool.
Asus Prime 370X-Pro
AMD Ryzen 1600X (6 cores @ 3.6 GHz)
16 Gig DDR4 3200 (G Skill)
Nvidia -MSI GeForce GT 710 fanless
Samsung 960 NVMe SSD nvme0n1 P1,P2, and P3=MX-17, P4=antiX-17
1TB SSD sda1= Data, 2TB WD =backups
on-board ethernet & sound

User avatar
entropyfoe
Forum Regular
Forum Regular
Posts: 776
Joined: Thu Apr 19, 2007 11:42 am

Re: no video after antiX 17 kernel upgrade to 4.13

#7 Post by entropyfoe » Sat Oct 21, 2017 8:38 pm

Stevo
Yup, I can get back to my normal antix 17 desktop woth the 4.10 kernel.

I will have to look into that dkms stuff, this is a bit outside my linux knowledge, so an opportunity to learn

I was also thinking of installing the antix 17 rc1 as a trial, then I could use the sgfxi to get the nvidia driver, and then use the all kernels option
Asus Prime 370X-Pro
AMD Ryzen 1600X (6 cores @ 3.6 GHz)
16 Gig DDR4 3200 (G Skill)
Nvidia -MSI GeForce GT 710 fanless
Samsung 960 NVMe SSD nvme0n1 P1,P2, and P3=MX-17, P4=antiX-17
1TB SSD sda1= Data, 2TB WD =backups
on-board ethernet & sound

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15632
Joined: Fri Dec 15, 2006 8:07 pm

Re: no video after antiX 17 kernel upgrade to 4.13

#8 Post by Stevo » Sat Oct 21, 2017 10:15 pm

You should run that command to see if nvidia-driver is installed from Debian. Since that 375.82 is the Stretch version, odds are that it is, and that the antiX installer installed it and the nvidia-kernel-dkms package. Those automatically rebuild the drivers for a new kernel if its headers are also installed, which makes me suspect that perhaps something is wrong concerning the headers. It's easy to manually install the wrong headers if you are not careful. I know that the Stretch nvidia driver builds on the 4.13 Liquorix kernel--am running it right now, in fact. But we can only check if you run those simple commands.

Other options: run the antiX Nvidia installer from the command line when booted to the 4.13 kernel CLI, if it offers that mode. I think it might make sure you have the current headers installed. Otherwise, install module-assistant if necessary and run

Code: Select all

m-a prepare
when booted to the new kernel to make sure you have the headers.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9270
Joined: Wed Jul 12, 2006 2:26 pm

Re: no video after antiX 17 kernel upgrade to 4.13

#9 Post by kmathern » Sun Oct 22, 2017 9:23 am

I think this dkms command will build/install the nvidia module for the 4.13 kernel if it (dkms) was used to install the nvidia driver for the 4.10 kernel. You can execute the command while running from the 4.10 kernel.

Code: Select all

sudo dkms install nvidia/375.82 -k 4.13{press tab key  to autocomplete} 

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5631
Joined: Sat Jul 15, 2006 10:40 am

Re: no video after antiX 17 kernel upgrade to 4.13

#10 Post by anticapitalista » Sun Oct 22, 2017 9:27 am

antiX-17 uses ddm-mx.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

Post Reply

Return to “antiX”