Welcome!

Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-16.1 release info here
  • antiX-17-b1-full release info here
  • antiX-16.2 release info here
New users
  • Please read this first, and don't forget to add system and hardware information to posts!
  • Read Forum Rules

apt-get FAIL

For help or questions about 64-bit version of MEPIS, this is the forum to use.
Message
Author
User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Age: 2016
Joined: Wed Aug 02, 2006 12:12 pm

apt-get FAIL

#1 Postby eemaestro » Sun Sep 27, 2015 11:12 am

Today is the third consecutive day apt-get has failed to get certain 64bit AMD repo's.....

Code: Select all

# apt-get update && apt-get upgrade
.
.
.
Hit http://main.mepis-deb.org mepis12cr/non-free Translation-en
W: Failed to fetch http://ftp.us.debian.org/dists/wheezy/updates/main/binary-amd64/Packages  404  Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://ftp.us.debian.org/dists/wheezy/updates/contrib/binary-amd64/Packages  404  Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://ftp.us.debian.org/dists/wheezy/updates/non-free/binary-amd64/Packages  404  Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://ftp.us.debian.org/dists/wheezy/updates/main/binary-i386/Packages  404  Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://ftp.us.debian.org/dists/wheezy/updates/contrib/binary-i386/Packages  404  Not Found [IP: 64.50.233.100 80]

W: Failed to fetch http://ftp.us.debian.org/dists/wheezy/updates/non-free/binary-i386/Packages  404  Not Found [IP: 64.50.233.100 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

Is there anything I need to change in my repo. source file(s)?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9007
Age: 59
Joined: Wed Jul 12, 2006 2:26 pm

Re: apt-get FAIL

#2 Postby kmathern » Sun Sep 27, 2015 11:23 am

eemaestro wrote:W: Failed to fetch http://ftp.us.debian.org/dists/wheezy/updates/main/binary-amd64/Packages 404 Not Found [IP: 64.50.233.100 80]

'wheezy/updates' is for the security updates repo (security.debian.org), this:

Code: Select all

deb http://security.debian.org/ wheezy/updates main contrib non-free


Post your sources if you still have questions.

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Age: 2016
Joined: Wed Aug 02, 2006 12:12 pm

Re: apt-get FAIL

#3 Postby eemaestro » Mon Sep 28, 2015 11:24 am

Code: Select all

$cat sources.list
# copied from http://www.mepis.org/docs/en/index.php?title=Sources.list_MEPIS_12

deb http://ftp.us.debian.org/debian/ wheezy main contrib non-free

deb http://ftp.us.debian.org/ wheezy/updates main contrib non-free

deb http://ftp.us.debian.org/debian/ wheezy-updates main contrib non-free

deb http://ftp.us.debian.org/debian/ wheezy-backports main contrib non-free

# deb http://www.deb-multimedia.org/ wheezy main non-free

# Mepis mirror
deb http://mepis.mirrorcatalogs.com/packages/mepis/ mepis-12.0 main

# MEPIS master pools, please use only if mirror is slow or down
# deb ftp://ftp.mepis.com/mepis/ mepis-12.0 main

# Mepis Community Main and Test Repos
deb http://main.mepis-deb.org/mepiscr/repo/ mepis12cr main non-free 
#deb http://main.mepis-deb.org/mepiscr/testrepo/ mepis12cr test


This morning I updated using Synaptic. It appeared to download a bunch of
amd64.deb library packages. I caught the tail of its terminal window output using KDE. I
appended this below.

Code: Select all

dpkg: warning: files list file for package 'libpng12-0:i386' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xserver-xorg-video-qxl' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xfsprogs' missing; assuming package has no files currently installed
(Reading database ... 138348 files and directories currently installed.)
Preparing to replace libldap-2.4-2:amd64 2.4.31+really2.4.40+dfsg-1~bpo70+1 (using .../libldap-2.4-2_2.4.31+really2.4.40+dfsg-1+deb8u1~bpo70+1_amd64.deb) ...
Unpacking replacement libldap-2.4-2:amd64 ...
Selecting previously unselected package libavformat55:amd64.
Unpacking libavformat55:amd64 (from .../libavformat55_6%3a10.1-1~bpo70+1_amd64.deb) ...
Selecting previously unselected package libavdevice54:amd64.
Unpacking libavdevice54:amd64 (from .../libavdevice54_6%3a10.1-1~bpo70+1_amd64.deb) ...
Selecting previously unselected package libavresample1:amd64.
Unpacking libavresample1:amd64 (from .../libavresample1_6%3a10.1-1~bpo70+1_amd64.deb) ...
Selecting previously unselected package libavfilter4:amd64.
Unpacking libavfilter4:amd64 (from .../libavfilter4_6%3a10.1-1~bpo70+1_amd64.deb) ...
Selecting previously unselected package libvdpau1:amd64.
Unpacking libvdpau1:amd64 (from .../libvdpau1_0.4.1-7_amd64.deb) ...
Preparing to replace libav-tools 6:0.8.17-1 (using .../libav-tools_6%3a10.1-1~bpo70+1_amd64.deb) ...
Unpacking replacement libav-tools ...
Preparing to replace libbsd0:amd64 0.4.2-1 (using .../libbsd0_0.7.0-2~bpo70+2_amd64.deb) ...
Unpacking replacement libbsd0:amd64 ...
Selecting previously unselected package libfreerdp1:amd64.
Unpacking libfreerdp1:amd64 (from .../libfreerdp1_1.0.1-1.1+deb7u3_amd64.deb) ...
Selecting previously unselected package libiscsi2:amd64.
Unpacking libiscsi2:amd64 (from .../libiscsi2_1.12.0-2~bpo70+1_amd64.deb) ...
Selecting previously unselected package libboost-thread1.49.0.
Unpacking libboost-thread1.49.0 (from .../libboost-thread1.49.0_1.49.0-3.2_amd64.deb) ...
Selecting previously unselected package librados2.
Unpacking librados2 (from .../librados2_0.80.7-1~bpo70+1_amd64.deb) ...
Selecting previously unselected package librbd1.
Unpacking librbd1 (from .../librbd1_0.80.7-1~bpo70+1_amd64.deb) ...
Selecting previously unselected package libisc95.
Unpacking libisc95 (from .../libisc95_1%3a9.9.5.dfsg-4~bpo70+1_amd64.deb) ...
Selecting previously unselected package libdns100.
Unpacking libdns100 (from .../libdns100_1%3a9.9.5.dfsg-4~bpo70+1_amd64.deb) ...
Selecting previously unselected package libisccc90.
Unpacking libisccc90 (from .../libisccc90_1%3a9.9.5.dfsg-4~bpo70+1_amd64.deb) ...
Selecting previously unselected package libisccfg90.
Unpacking libisccfg90 (from .../libisccfg90_1%3a9.9.5.dfsg-4~bpo70+1_amd64.deb) ...
Selecting previously unselected package libbind9-90.
Unpacking libbind9-90 (from .../libbind9-90_1%3a9.9.5.dfsg-4~bpo70+1_amd64.deb) ...
Selecting previously unselected package liblwres90.
Unpacking liblwres90 (from .../liblwres90_1%3a9.9.5.dfsg-4~bpo70+1_amd64.deb) ...
Preparing to replace bind9-host 1:9.8.4.dfsg.P1-6+nmu2+deb7u7 (using .../bind9-host_1%3a9.9.5.dfsg-4~bpo70+1_amd64.deb) ...
Unpacking replacement bind9-host ...
Preparing to replace dnsutils 1:9.8.4.dfsg.P1-6+nmu2+deb7u7 (using .../dnsutils_1%3a9.9.5.dfsg-4~bpo70+1_amd64.deb) ...
Unpacking replacement dnsutils ...
Selecting previously unselected package python3.2-minimal.
Unpacking python3.2-minimal (from .../python3.2-minimal_3.2.3-7_amd64.deb) ...
Selecting previously unselected package python3.2.
Unpacking python3.2 (from .../python3.2_3.2.3-7_amd64.deb) ...
Selecting previously unselected package python3-minimal.
Unpacking python3-minimal (from .../python3-minimal_3.2.3-6_all.deb) ...
Selecting previously unselected package python3.
Unpacking python3 (from .../python3_3.2.3-6_all.deb) ...
Preparing to replace devscripts 2.12.6+deb7u2 (using .../devscripts_2.14.11~bpo70+1_amd64.deb) ...
Unpacking replacement devscripts ...
Preparing to replace firefox 40.0.3~mozillabinaries-1mcr120+1 (using .../firefox_41.0~mozillabinaries-1mcr120+1_amd64.deb) ...
Unpacking replacement firefox ...
Selecting previously unselected package libproxy-tools.
Unpacking libproxy-tools (from .../libproxy-tools_0.3.1-6_amd64.deb) ...
Preparing to replace qemu-utils 1.1.2+dfsg-6a+deb7u11 (using .../qemu-utils_1%3a2.1+dfsg-12~bpo70+1_amd64.deb) ...
Unpacking replacement qemu-utils ...
Processing triggers for man-db ...
gdbm fatal: read error
Processing triggers for menu ...
Processing triggers for desktop-file-utils ...
Setting up libldap-2.4-2:amd64 (2.4.31+really2.4.40+dfsg-1+deb8u1~bpo70+1) ...
Setting up libavformat55:amd64 (6:10.1-1~bpo70+1) ...
Setting up libavdevice54:amd64 (6:10.1-1~bpo70+1) ...
Setting up libavresample1:amd64 (6:10.1-1~bpo70+1) ...
Setting up libavfilter4:amd64 (6:10.1-1~bpo70+1) ...
Setting up libvdpau1:amd64 (0.4.1-7) ...
Setting up libav-tools (6:10.1-1~bpo70+1) ...

Configuration file `/etc/avserver.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** avserver.conf (Y/I/N/O/D/Z) [default=N] ? N
Setting up libbsd0:amd64 (0.7.0-2~bpo70+2) ...
Setting up libfreerdp1:amd64 (1.0.1-1.1+deb7u3) ...
Setting up libiscsi2:amd64 (1.12.0-2~bpo70+1) ...
Setting up libboost-thread1.49.0 (1.49.0-3.2) ...
Setting up librados2 (0.80.7-1~bpo70+1) ...
Setting up librbd1 (0.80.7-1~bpo70+1) ...
Setting up libisc95 (1:9.9.5.dfsg-4~bpo70+1) ...
Setting up libdns100 (1:9.9.5.dfsg-4~bpo70+1) ...
Setting up libisccc90 (1:9.9.5.dfsg-4~bpo70+1) ...
Setting up libisccfg90 (1:9.9.5.dfsg-4~bpo70+1) ...
Setting up libbind9-90 (1:9.9.5.dfsg-4~bpo70+1) ...
Setting up liblwres90 (1:9.9.5.dfsg-4~bpo70+1) ...
Setting up bind9-host (1:9.9.5.dfsg-4~bpo70+1) ...
Setting up dnsutils (1:9.9.5.dfsg-4~bpo70+1) ...
Setting up python3.2-minimal (3.2.3-7) ...
Setting up python3.2 (3.2.3-7) ...
Setting up python3-minimal (3.2.3-6) ...
Setting up python3 (3.2.3-6) ...
running python rtupdate hooks for python3.2...
running python post-rtupdate hooks for python3.2...
Setting up devscripts (2.14.11~bpo70+1) ...
Installing new version of config file /etc/bash_completion.d/devscripts.chdist ...
Installing new version of config file /etc/cowpoke.conf ...
Setting up firefox (41.0~mozillabinaries-1mcr120+1) ...
Setting up libproxy-tools (0.3.1-6) ...
Setting up qemu-utils (1:2.1+dfsg-12~bpo70+1) ...
Processing triggers for menu ...

Successfully applied all changes. You can close the window now.


I typed N because I didn't understand what it was trying to do or why. This is a workstation, not a server. I don't recall ever having seen this output from Synaptic Packet Manager before. Maybe somebody will recognize
what's going on. I am kinda lost.

There's still a snafu in sound under Firefox 40.0.3. No sound until I do a cold boot, and even then I need to let the computer go completely cold for a minute before I reapply power. However, I can play an mp3 file in audacity and hear it without rebooting. So I know the snafu isn't in the sound hardware.

I was under the impression I could update deb packages using either Synaptic or APT or both, so long as I don't try to run both at the same time.

EDIT: corrected myself
Last edited by eemaestro on Mon Sep 28, 2015 12:33 pm, edited 1 time in total.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9007
Age: 59
Joined: Wed Jul 12, 2006 2:26 pm

Re: apt-get FAIL

#4 Postby kmathern » Mon Sep 28, 2015 11:48 am

If you closely compare your list to the http://www.mepis.org/docs/en/index.php?title=Sources.list_MEPIS_12 wiki list you'll see that you miscopied the security.debian.org repo entry.

Make the changes below
eemaestro wrote:$cat sources.list
# copied from http://www.mepis.org/docs/en/index.php?title=Sources.list_MEPIS_12

deb http://ftp.us.debian.org/debian/ wheezy main contrib non-free

deb http://ftp.us.debian.org/ wheezy/updates main contrib non-free (delete)
deb http://security.debian.org/ wheezy/updates main contrib non-free (replace with this)

deb http://ftp.us.debian.org/debian/ wheezy-updates main contrib non-free

deb http://ftp.us.debian.org/debian/ wheezy-backports main contrib non-free

# deb http://www.deb-multimedia.org/ wheezy main non-free

# Mepis mirror
deb http://mepis.mirrorcatalogs.com/packages/mepis/ mepis-12.0 main

# MEPIS master pools, please use only if mirror is slow or down
# deb ftp://ftp.mepis.com/mepis/ mepis-12.0 main

# Mepis Community Main and Test Repos
deb http://main.mepis-deb.org/mepiscr/repo/ mepis12cr main non-free
#deb http://main.mepis-deb.org/mepiscr/testrepo/ mepis12cr test


edit: I'm ignoring the rest of the stuff you posted because it has nothing to do with the original problem.

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Age: 2016
Joined: Wed Aug 02, 2006 12:12 pm

Re: apt-get FAIL

#5 Postby eemaestro » Mon Sep 28, 2015 12:28 pm

Thank you for spotting the difference. I exited Synaptic, replace the etc/apt/sources.list line you recommended, kmathern, and reran apt.

Code: Select all

# apt-get update && apt-get upgrade
Hit http://ftp.us.debian.org wheezy Release.gpg
Hit http://ftp.us.debian.org wheezy-updates Release.gpg                                           
Hit http://dl.google.com stable Release.gpg                                                       
Hit http://mepis.mirrorcatalogs.com mepis-12.0 Release.gpg                                 
Hit http://ftp.us.debian.org wheezy-backports Release.gpg                                 
Hit http://main.mepis-deb.org mepis12cr Release.gpg                                       
Hit http://dl.google.com stable Release                                                   
Hit http://security.debian.org wheezy/updates Release.gpg                                         
Hit http://ftp.us.debian.org wheezy Release                                                       
Hit http://mepis.mirrorcatalogs.com mepis-12.0 Release                                             
Hit http://ftp.us.debian.org wheezy-updates Release                                               
Hit http://main.mepis-deb.org mepis12cr Release                                                   
Hit http://dl.google.com stable/main amd64 Packages                                               
Hit http://ftp.us.debian.org wheezy-backports Release                                             
Hit http://mepis.mirrorcatalogs.com mepis-12.0/main amd64 Packages                                 
Hit http://security.debian.org wheezy/updates Release                                             
Hit http://dl.google.com stable/main i386 Packages                                                 
Hit http://ftp.us.debian.org wheezy/main amd64 Packages                                           
Hit http://mepis.mirrorcatalogs.com mepis-12.0/main i386 Packages                                 
Hit http://ftp.us.debian.org wheezy/contrib amd64 Packages                                         
Hit http://main.mepis-deb.org mepis12cr/main amd64 Packages                                       
Hit http://ftp.us.debian.org wheezy/non-free amd64 Packages                                       
Hit http://security.debian.org wheezy/updates/main amd64 Packages                                 
Hit http://ftp.us.debian.org wheezy/main i386 Packages                                             
Hit http://main.mepis-deb.org mepis12cr/non-free amd64 Packages                                   
Hit http://ftp.us.debian.org wheezy/contrib i386 Packages                                         
Hit http://ftp.us.debian.org wheezy/non-free i386 Packages                                         
Hit http://security.debian.org wheezy/updates/contrib amd64 Packages                               
Hit http://main.mepis-deb.org mepis12cr/main i386 Packages                                         
Hit http://ftp.us.debian.org wheezy/contrib Translation-en                                         
Hit http://ftp.us.debian.org wheezy/main Translation-en                                           
Hit http://security.debian.org wheezy/updates/non-free amd64 Packages                             
Hit http://main.mepis-deb.org mepis12cr/non-free i386 Packages                                     
Hit http://ftp.us.debian.org wheezy/non-free Translation-en                                       
Hit http://ftp.us.debian.org wheezy-updates/main amd64 Packages                                   
Hit http://ftp.us.debian.org wheezy-updates/contrib amd64 Packages                                 
Hit http://security.debian.org wheezy/updates/main i386 Packages                                   
Ign http://dl.google.com stable/main Translation-en_US                                             
Hit http://security.debian.org wheezy/updates/contrib i386 Packages                               
Hit http://ftp.us.debian.org wheezy-updates/non-free amd64 Packages                               
Ign http://dl.google.com stable/main Translation-en                                               
Hit http://ftp.us.debian.org wheezy-updates/main i386 Packages                                     
Hit http://ftp.us.debian.org wheezy-updates/contrib i386 Packages                                 
Hit http://security.debian.org wheezy/updates/non-free i386 Packages                               
Hit http://ftp.us.debian.org wheezy-updates/non-free i386 Packages                                 
Ign http://mepis.mirrorcatalogs.com mepis-12.0/main Translation-en_US                             
Hit http://ftp.us.debian.org wheezy-updates/contrib Translation-en                       
Hit http://security.debian.org wheezy/updates/contrib Translation-en                               
Hit http://ftp.us.debian.org wheezy-updates/main Translation-en                                   
Ign http://mepis.mirrorcatalogs.com mepis-12.0/main Translation-en                                 
Hit http://ftp.us.debian.org wheezy-updates/non-free Translation-en                               
Hit http://ftp.us.debian.org wheezy-backports/main amd64 Packages                       
Hit http://security.debian.org wheezy/updates/main Translation-en                       
Hit http://ftp.us.debian.org wheezy-backports/contrib amd64 Packages                     
Hit http://ftp.us.debian.org wheezy-backports/non-free amd64 Packages                   
Hit http://security.debian.org wheezy/updates/non-free Translation-en
Hit http://ftp.us.debian.org wheezy-backports/main i386 Packages   
Hit http://ftp.us.debian.org wheezy-backports/contrib i386 Packages
Hit http://ftp.us.debian.org wheezy-backports/non-free i386 Packages
Hit http://ftp.us.debian.org wheezy-backports/contrib Translation-en
Hit http://ftp.us.debian.org wheezy-backports/main Translation-en 
Hit http://ftp.us.debian.org wheezy-backports/non-free Translation-en
Ign http://main.mepis-deb.org mepis12cr/main Translation-en_US     
Hit http://main.mepis-deb.org mepis12cr/main Translation-en
Ign http://main.mepis-deb.org mepis12cr/non-free Translation-en_US
Hit http://main.mepis-deb.org mepis12cr/non-free Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  intel-microcode libnl-3-200 libnl-genl-3-200 libnl-route-3-200
The following packages will be upgraded:
  libvdpau1
1 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 31.7 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://security.debian.org/ wheezy/updates/main libvdpau1 amd64 0.4.1-7+deb7u1 [31.7 kB]
Fetched 31.7 kB in 0s (269 kB/s)   
dpkg: warning: files list file for package 'libpng12-0:i386' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xserver-xorg-video-qxl' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xfsprogs' missing; assuming package has no files currently installed
(Reading database ... 139284 files and directories currently installed.)
Preparing to replace libvdpau1:amd64 0.4.1-7 (using .../libvdpau1_0.4.1-7+deb7u1_amd64.deb) ...
Unpacking replacement libvdpau1:amd64 ...
Setting up libvdpau1:amd64 (0.4.1-7+deb7u1) ...

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9007
Age: 59
Joined: Wed Jul 12, 2006 2:26 pm

Re: apt-get FAIL

#6 Postby kmathern » Mon Sep 28, 2015 12:41 pm

Everything looks normal to me other than the 3 dpkg warnings:

Code: Select all

dpkg: warning: files list file for package 'libpng12-0:i386' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xserver-xorg-video-qxl' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xfsprogs' missing; assuming package has no files currently installed


I've never see that type of warning before, but I think it's because I don't run a 64bit install with multiarch support enabled.

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Age: 2016
Joined: Wed Aug 02, 2006 12:12 pm

Re: apt-get FAIL

#7 Postby eemaestro » Mon Sep 28, 2015 12:58 pm

Seems to be the ubiquitous youtube channel for which sound has failed in Firefox.

UPDATE: I am now listening to youtube audio in Opera. So definitely seems to be a Firefox media problem.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 13454
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: apt-get FAIL

#8 Postby Stevo » Mon Sep 28, 2015 4:21 pm

You may need some media settings changed in about:config

What do you have for the gstreamer and ffmpeg settings?

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1010
Age: 2016
Joined: Wed Aug 02, 2006 12:12 pm

Re: apt-get FAIL

#9 Postby eemaestro » Mon Sep 28, 2015 5:24 pm

I ran apt. It seems to have worked, as opposed to earlier tries.
Thank you.
Firefox started playing sound again next time after I restarted the computer.
Strange, but true.


Return to “64-bit Regulars”

Who is online

Users browsing this forum: No registered users and 1 guest