Welcome!

Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-16.1 release info here
  • antiX-17-b1-full release info here
  • antiX-16.2 release info here
New users
  • Please read this first, and don't forget to add system and hardware information to posts!
  • Read Forum Rules

kdewallet

For help or questions about 64-bit version of MEPIS, this is the forum to use.
Message
Author
User avatar
beckwith
Forum Regular
Forum Regular
Posts: 475
Joined: Thu Feb 15, 2007 9:27 pm

kdewallet

#1 Postby beckwith » Wed Apr 29, 2015 5:06 am

I upgraded a friend's laptop from Mepis 8 to Mepis 12 (he loves Mepis).
But now the following window opens
The application 'KDE Daemon has requested to open
the wallet 'localwallet'. Please enter the password for
this wallet below.

Since we don't know what this password is, the wireless network
simply disconnects. My friend says ignoring the password allows
the network to work, but then after some time it disconnects. I
find it even worse. Originally ignoring the wallet issue allowed
his machine to connect to my wireless network. Now it won't even
do that.
Any assistance would be muchly appreciated.

User avatar
m_pav
Forum Guide
Forum Guide
Posts: 2561
Age: 50
Joined: Sun Aug 06, 2006 3:02 pm

Re: kdewallet

#2 Postby m_pav » Wed Apr 29, 2015 12:14 pm

The KDE wallet is a royal PITA. The password for the wallet is the first password your friend used, the first time it popped up, most likely the password to a wireless access point he/she was trying to connect to.
I warn all newbies about this tool and advise them to either use the same password as their login the very first time they see any reference to a wallet pop up, or to leave both password fields empty and press OK or next. With no password entered, it will ask if you want to store your passwords unencrypted to which you answer yes, then it will never bother you again.

To disable KDE Wallet:
first ensure kwalletmanager is installed, you can check this in synaptic, or run the following command in a terminal as a regular user
apt-cache policy kwalletmanager
You'll see plainly if it is installed or not

open 'System Setting' => 'Account Details' => click on 'KDE Wallet'
verify that 'Enable the KDE Wallet subsystem' is unchecked.
when it was checked before => click on 'Apply' (right underneath)

The above process is dependent on your KDE version and it may require your wallet password, however, below is the path I'd choose;
simply edit ~.kde/share/config/kwalletrc so it reads like the example below

Code: Select all

[Wallet]
Close When Idle=false
Enabled=false
First Use=false
Use One Wallet=true
and to "fix" it, delete the kwallet folder from ~/.kde/share/apps/kwallet. Deleting this folder doesn't truly fix it, it removes all encrypted password data from kdewallet, so if it should pop up again, do as I have said above, feed it nothing (as in no passwords) so it starves and dies.
Mike P

Regd Linux User #472293
(Mine)Lenovo T560, i7-6600U, 16GB, 2.0TB SSHD, MX16 64-bit
(Wifes) Asus M4A88TD-M, AMD Phenom II x4 955 CPU, nVidia GF610, 6Gb, 500GB+320GB, MX16 + KDE
(Kids) Intel NUC, J1900, 4GB, 64GB SSD, MX16

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 11380
Joined: Wed Jul 12, 2006 5:54 am

Re: kdewallet

#3 Postby lucky9 » Wed Apr 29, 2015 4:53 pm

One of the first things I do on a new installation of KDE is disable KWallet in System Settings.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
beckwith
Forum Regular
Forum Regular
Posts: 475
Joined: Thu Feb 15, 2007 9:27 pm

Re: kdewallet

#4 Postby beckwith » Wed Apr 29, 2015 9:07 pm

I did as m_pav said: this got rid of kdewallet - butafter a a few minutes the wireless connection
disconnected again

EDIT

A reboot and is now OK. Many thanks


Return to “64-bit Regulars”

Who is online

Users browsing this forum: No registered users and 2 guests