Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

calibre - broken packages

For help or questions about 64-bit version of MEPIS, this is the forum to use.
Message
Author
User avatar
beckwith
Forum Regular
Forum Regular
Posts: 475
Joined: Thu Feb 15, 2007 9:27 pm

calibre - broken packages

#1 Post by beckwith » Mon Jan 05, 2015 2:28 am

I can't install calibre (1.22.0+dsg1-1-bc) due to broken packages.
You people suggested this app or coolreader3 (not in repos).
Linux user 449018, since 1994, Mepis (3.4 onwards) 2006, now Debian 7.8
Desktop: HP 500-315a i54460, - Debian 7.8
Laptop: Toshiba Satellite L500D/006 - Depian 7.8
Toy: Raspberry PI/mkBii - Raspian 2015-01-31
ePad: Asus - Android

User avatar
towwire
Forum Regular
Forum Regular
Posts: 310
Joined: Fri Oct 15, 2010 12:15 pm

Re: calibre - broken packages

#2 Post by towwire » Mon Jan 05, 2015 4:00 am

I have never had any trouble with Calibre itself, but then I don't use Synaptic to install it. I've always use their script in a terminal to install and used it again when Calibre said that there was an update. I've never lost anything that way, but I do keep a backup just incase.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9359
Joined: Wed Jul 12, 2006 2:26 pm

Re: calibre - broken packages

#3 Post by kmathern » Mon Jan 05, 2015 10:09 am

I think if you temporarily set 'wheezy-backports' as the preferred distro, it should fix the broken packages problem and allow Synaptic to install calibre.

User avatar
arjaybe
Forum Guide
Forum Guide
Posts: 1671
Joined: Wed Jul 12, 2006 6:51 pm

Re: calibre - broken packages

#4 Post by arjaybe » Mon Jan 05, 2015 2:17 pm

Go to this site: http://calibre-ebook.com/download_linux and follow the instructions for binary install. Do the same thing for updates. It's easy and you'll always have the latest version.
Intel Celeron 1007U with integrated HD Graphics 2500, 4GB RAM

A thug state led by an overweening twat.

Green Comet

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16582
Joined: Fri Dec 15, 2006 8:07 pm

Re: calibre - broken packages

#5 Post by Stevo » Mon Jan 05, 2015 4:15 pm

Coolreader3 is in the M12 test repo still, since no one has responded to it:

http://forum.mepiscommunity.org/viewtop ... 88&t=35898

Fbreader is another good ebook reader.

User avatar
beckwith
Forum Regular
Forum Regular
Posts: 475
Joined: Thu Feb 15, 2007 9:27 pm

Re: calibre - broken packages

#6 Post by beckwith » Wed Jan 07, 2015 10:22 pm

OK, so I have calibre now running.
New problem - calibre thinks that
1) Chronicles_of_Sherlock_Holmes.epub
2) Chronicles_Sherlock_Holmes_II.epub
are duplicates, and they are not.
Linux user 449018, since 1994, Mepis (3.4 onwards) 2006, now Debian 7.8
Desktop: HP 500-315a i54460, - Debian 7.8
Laptop: Toshiba Satellite L500D/006 - Depian 7.8
Toy: Raspberry PI/mkBii - Raspian 2015-01-31
ePad: Asus - Android

User avatar
Paul..
Forum Guide
Forum Guide
Posts: 2277
Joined: Sun Mar 18, 2007 6:34 pm

Re: calibre - broken packages

#7 Post by Paul.. » Wed Jan 07, 2015 10:49 pm

beckwith wrote:OK, so I have calibre now running.
New problem - calibre thinks that
1) Chronicles_of_Sherlock_Holmes.epub
2) Chronicles_Sherlock_Holmes_II.epub
are duplicates, and they are not.
Brute force & stupid approach: make a copy/backup of "II"...rename the copy to something w/o Sherlock_Holmes in it...and move the original "II" to another directory?

Daily: MSI 890FXA-GD70 | AMD Phenom II X6 1055T | GeForce GTX 750 Ti | 8G
Test: Thinkpad T431s | Intel i5-3437U | Intel 3rd gen Graphics | 4G

User avatar
SilverBear
Forum Guide
Forum Guide
Posts: 1047
Joined: Sun Jul 23, 2006 7:51 pm

Re: calibre - broken packages

#8 Post by SilverBear » Thu Jan 08, 2015 12:51 am

Beckwith, my man!
We have 2 different issues here. I Bear Truth:
1] Kovid Goyal, the dev of calabre RECOMMENDS that people NOT install calibre from distro repos -- those versions are always out of date.
I've been a Calibre Fan for 3 years now. I don't know everthing about it, but I know I can't do without it, and that the more I learn about how Kovid programmes things, the more I understand about databases and python regular expressions .
So: install from http://calibre-ebook.com/download_linux no matter what distro you're running.

2]
New problem - calibre thinks that
1) Chronicles_of_Sherlock_Holmes.epub
2) Chronicles_Sherlock_Holmes_II.epub
are duplicates, and they are not.
If you are COMPLETELY certain that the texts are identical (by the titles it seems to me that they may not be) you can highlight them both and the right-click to choose edit metadata > merge book records to exactly specify how you want to handle the dups.
Here is a screenshot of a similar situaton in the current version of calibre:
(hmmm: cannot seem to upload an image directly from my hdd, forum will only accept a URL or an attachment. Please see attachment.)
KSE's screenshot ut will not show the right-click menus, but you'll see what I mean when you try it.
You do not have the required permissions to view the files attached to this post.
"masai7" Intel i7 3770k; 16GB RAM; GeForce GTX-750

User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 4982
Joined: Sat Nov 11, 2006 10:42 pm

Re: calibre - broken packages

#9 Post by uncle mark » Thu Jan 08, 2015 10:41 am

SilverBear wrote:
New problem - calibre thinks that
1) Chronicles_of_Sherlock_Holmes.epub
2) Chronicles_Sherlock_Holmes_II.epub
are duplicates, and they are not.
If you are COMPLETELY certain that the texts are identical (by the titles it seems to me that they may not be) ...
I think you've got it backwards.
Desktop: Custom build Asus/AMD/nVidia -- MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15
Assorted junk: assorted Linuxes

User avatar
SilverBear
Forum Guide
Forum Guide
Posts: 1047
Joined: Sun Jul 23, 2006 7:51 pm

Re: calibre - broken packages

#10 Post by SilverBear » Thu Jan 08, 2015 6:25 pm

uncle mark wrote:
SilverBear wrote:
New problem - calibre thinks that
1) Chronicles_of_Sherlock_Holmes.epub
2) Chronicles_Sherlock_Holmes_II.epub
are duplicates, and they are not.
If you are COMPLETELY certain that the texts are identical (by the titles it seems to me that they may not be) ...
I think you've got it backwards.
I think you're right! :bagoverhead:
Well, in that case, go into Edit Metadata Individually and assign the first volume a Series name, like: "Chronicles of Sherlock." It'll get numbered "1" and when you do the same to Volume II, that will automatically become "2" in the series.
"masai7" Intel i7 3770k; 16GB RAM; GeForce GTX-750

Post Reply

Return to “64-bit Regulars”