Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Keyboard quit respondng in wine

Here you can post threads/topics about programs like vmware, parallels, qemu, virtualbox, dosbox and all the other virtual machines/emulators that exist. This includes how to setup, suggestions on what works well with MEPIS and what doesn't, etc.
Post Reply
User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2914
Joined: Thu May 01, 2014 10:12 am

Keyboard quit respondng in wine

#1

Post by mmikeinsantarosa » Sun Jul 20, 2014 10:37 pm

Not sure if it's appropriate to answer your own question but I spent a couple hours trying to get my keyboard to work in wine. Figured somebody else could use this.
I had installed a game and all was fine until I quit and started it back up. The mouse worked but the keyboard didn't respond at all. Initially running wine to install the app resulted in a shortcut/launcher for the game on my desktop.

On another site I found the answer that worked for me:

insert XMODIFIERS='' just after env in the launcher string.
ie;
old line

Code: Select all

env WINEPREFIX="/home/mike/.wine" wine C:\\Program\ Files\\AGD\ Interactive\\King\'s\ Quest\ I\\Launcher.exe 

new line:

Code: Select all

env XMODIFIERS='' WINEPREFIX="/home/mike/.wine" wine C:\\Program\ Files\\AGD\ Interactive\\King\'s\ Quest\ I\\Launcher.exe 
LT: MX18.2 Quad Core model: Intel Core i7-6820HQ Kernel: 5.0.0-7.1-liquorix-amd64 x86_64

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 11875
Joined: Sun Dec 16, 2007 1:17 pm

Re: Keyboard quit respondng in wine

#2

Post by dolphin_oracle » Mon Jul 21, 2014 10:30 am

Glad you found your solution, and thanks for the follow up! Maybe it will help someone in the future.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

Post Reply

Return to “VMs/Emulators”