Page 1 of 2

Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 8:14 am
by awsim
I with the help of oracle, have just successfully installed MX17 to a usb with persistence.Everything seems to work fine with the exception of Bluetooth.I select to search for an adapter which it does,then select the device which it does , then I select to pair and connect it doesn't connect and freezes. On occasion it does connect but then no sound emits from the Bluetooth speaker ,only the onboard speakers which are very faint.
Can anyone help with this.

Re: Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 8:24 am
by mw1649

Re: Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 9:03 am
by GuiGuy
I have found that recent Bluetooth speakers (and receivers) do not work, even with MSwindows,
because they are made for use with smartphones only - drivers for PCs are lacking.

Re: Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 10:52 am
by awsim
This is my output:$ dmesg | grep Blue
[ 92.798178] Bluetooth: Core ver 2.22
[ 92.798195] Bluetooth: HCI device and connection manager initialized
[ 92.798200] Bluetooth: HCI socket layer initialized
[ 92.798203] Bluetooth: L2CAP socket layer initialized
[ 92.798216] Bluetooth: CO socket layer initialized
[ 97.836105] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 97.836107] Bluetooth: BNEP filters: protocol multicast
[ 97.836112] Bluetooth: BNEP socket layer initialized
[ 104.826664] Bluetooth: RFCOMM TTY layer initialized
[ 104.826673] Bluetooth: RFCOMM socket layer initialized
[ 104.826680] Bluetooth: RFCOMM ver 1.11
[ 195.903615] Bluetooth: hci0 command 0x0402 tx timeout
Can anyone help with this?

Re: Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 11:14 am
by Jerry3904
Output please for this command:

Code: Select all

hcitool dev
Also

Code: Select all

inxi -F

Re: Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 11:44 am
by awsim
Hi Jerry 3904 hci0 00:11:22:98:76:54
Then:System: Host: mx1 Kernel: 4.14.0-3-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine: Device: laptop System: Acer product: Aspire E1-571 v: V2.04 serial: N/A
Mobo: Acer model: EA50_HC_HR v: Type2 - Board Version serial: N/A
UEFI [Legacy]: Acer v: V2.04 date: 09/14/2012
Battery BAT1: charge: 2.8 Wh 100.0% condition: 2.8/47.5 Wh (6%)
CPU: Dual core Intel Core i3-2328M (-MT-MCP-) cache: 3072 KB
clock speeds: max: 2200 MHz 1: 2195 MHz 2: 2195 MHz 3: 2195 MHz 4: 2195 MHz
Graphics: Card: Intel 2nd Generation Core Integrated Graphics Controller
Display Server: x11 (X.Org 1.19.2 ) driver: vesa Resolution: 1368x768@0.00hz
OpenGL: renderer: Gallium 0.4 on llvmpipe (LLVM 3.9, 256 bits) version: 3.3 Mesa 13.0.6
Audio: Card Intel 7 Series/C216 Family High Def. Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.14.0-3-amd64
Network: Card-1: Broadcom Limited NetLink BCM57785 Gigabit Ethernet PCIe driver: tg3
IF: eth0 state: down mac: b8:88:e3:c9:bd:56
Card-2: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
IF: wlan0 state: up mac: 08:3e:8e:7f:1a:03
Drives: HDD Total Size: 103.5GB (8.4% used)
ID-1: /dev/sda model: FUJITSU_MHW2080B size: 80.0GB
ID-2: USB /dev/sdb model: Cruzer_Glide_3.0 size: 15.7GB
ID-3: USB /dev/sdc model: TransMemory size: 7.8GB
Partition: ID-1: / size: 3.0G used: 1.9G (65%) fs: overlay dev: N/A
ID-2: /home size: 2.3G used: 229M (11%) fs: ext4 dev: /dev/loop1
Sensors: System Temperatures: cpu: 51.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 214 Uptime: 2:07 Memory: 1015.6/3766.2MB Client: Shell (bash) inxi: 2.3.54 you
Is this what want ?

Re: Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 11:54 am
by Jerry3904
So if you right-click the BT icon in the Notification Area, is BT on? Have you tried clicking "Setup New Device"?

Re: Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 2:44 pm
by awsim
Yes I get a flashed message in the upper r/h corner that says BT speaker connected but no sound comes out of the speaker. Sometimes it is recognised but doesn't connect.Built in speakers will produce sound but of course it is very soft.

Re: Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 3:17 pm
by Jerry3904
OK, good. Next question: have you used MX Select Sound to select which card to use (if you have more than one)?

Re: Problems with Bluetooth in MX17

Posted: Thu Mar 22, 2018 3:36 pm
by awsim
It seems I have only one sound card this one Audio: Card Intel 7 Series/C216 Family High Def. Audio Controller driver: snd_hda_intel as shown above.