The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Installation of a TP-Link TL-WN823N usb wifi dongle - SOLVED

User avatar
Forum Regular
Forum Regular
Posts: 521
Joined: Sat Jul 02, 2016 1:14 am

Re: Installation of a TP-Link TL-WN823N usb wifi dongle


Post by aus9 » Wed Feb 01, 2017 7:09 pm


I have read the replies this morning so glad to have helped. I am bit confused on whether you are on the 4.9 kernel so if so thanks to kmathern but I would also like to thank Paul..

I am not trying to force you to stay with my style, Linux is about freedom so you can test that 4.9 series and its upgraded firmware any time.

below are the steps for you to take if you elect to compile the module 8192eu

step one
download the source driver this is a one time download until you see they have changed something....but ignore the file that changed one month ago as its not relevant to us.
click the green button for clone/download and then click download zip

the irrelevant file can be viewed in your browser here
https://github.com/Mange/rtl8192eu-linu ... /README.md

Essentially IMHO there won't be any further code improvements to this driver and you can see it has had no substantial improvements for about one year.
but if it works....IT WORKS heh heh

step two
unpack the downloaded zip file by clicking it in your file manager

I suspect you have already done this based on your post number 19

suggested extra steps, copy the unpacked folder to your back up areas such as usb stick or spare partition etc

step three
suggestion move the unpacked folder out of Downloads and put it at the top of your home folder
suggestion rename it using your file manager to something simple for me (tp)
eg for me

step four
download the current kernel headers for compiling a new kernel module

--remember this assumes module 8192eu, if you go to the k for 4.9 series for the module rtl8xxxu you do not do this as module is already built for that module
-----thats why when you get a chance you might want to test both methods for wifi strenght and stability.

so when you update your kernel your current 8192eu module will fail as its not yet built.

Luckily Linux has a command to help with that here it is.....assumes you have ethernet connection

Code: Select all

sudo apt-get install linux-headers-$(uname -r)
^^ this is bit you may have forgot to do at post 19?

but if you have updated the kernel by wifi and have no ethernet connection available above command won't work

instead....before you reboot into new kernel search for that kernel download to find out its number

one way is

Code: Select all

dpkg -l | grep linux-image
dpkg -l | grep linux-image
ii linux-image-4.2.0-0.bpo.1-amd64 4.2.6-3~bpo8+4 amd64 Linux 4.2 for 64-bit PCs
ii linux-image-4.7.0-0.bpo.1-amd64-unsigned 4.7.8-1mx16+2 amd64 Linux 4.7 for 64-bit PCs
ii linux-image-4.8.0-2.1-liquorix-amd64 4.8-2mx150+2 amd64 Linux 4.8 for 64-bit PCs
ii linux-image-liquorix-amd64 4.8-2mx150+2 amd64 Linux image for liquorix on 64-bit PCs

so pretend I want the headers to 4.7 series for some reason as example

Code: Select all

apt search linux-headers-4.7.0-0.bpo.1
you will see an image like this


the automatic means it was a dependency of the other so to install the headers while on the OLD kernel but jut downloaded the new one I would do this

Code: Select all

sudo apt install linux-headers-4.7.0-0.bpo.1-amd64
step five

compile the new module

Code: Select all

sudo su
cd tp/Driver
make && make install
I manually moved the "made" kernel module in my previous post and then ran the depmod -a command but that is because I don't have the hardware.
For you the make install should work, fingers crossed.

Others can feel free to correct my errors if any :bagoverhead:
Last edited by aus9 on Thu Feb 02, 2017 12:14 am, edited 2 times in total.
good Luck from MX-16 user

User avatar
Forum Regular
Forum Regular
Posts: 521
Joined: Sat Jul 02, 2016 1:14 am

Re: Installation of a TP-Link TL-WN823N usb wifi dongle


Post by aus9 » Wed Feb 01, 2017 7:16 pm

ignore this post please!

in case the GPL police question me I have uploaded the source after distributing the kernel module here
https://www.dropbox.com/s/6ewdboiz8feh3 ... r.zip?dl=0
good Luck from MX-16 user

User avatar
Forum Novice
Forum  Novice
Posts: 71
Joined: Fri Dec 28, 2007 3:36 pm

Re: Installation of a TP-Link TL-WN823N usb wifi dongle


Post by texchuck » Thu Feb 02, 2017 3:41 am


You are correct that I missed step 4 in my attempt to compile. I am very novice on this stuff! I am actually still running 4.7, but your compiled driver works very well here. I tried the PC in the building where I was having so much trouble and the signal is now strong everywhere. It also works better with my home router. The built-in Broadcom wifi receiver would sometimes drop when only two feet from the router! If TP-Link can manufacture, package, and market a good wifi dongle for 15 euros, why can't HP just put a good wifi card inside their box from the start?? So much for my rant.

Many thanks, again, for your help. :happy:

Post Reply

Return to “Forum How-to's”