The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

RT2870 wifi in MX14-2 [Sorted]

Questions about Networking that deals with wireless cards, ethernet, modems, samba and anything else related to these, including software help. Tutorials for any of these can be posted too.

Remember to provide relevant info in your posts, such as the following information:

Version of Mepis being used
Card Manufacturer (i.e. Linksys)
Card Model (i.e. WMP54G)
Type: (PCI or PCMCIA)
Current Kernel in use on their system (i.e. 2.6.10)
Udev or Hotplug
Exact steps taken to get the card working if it is not immediately recognized by MEPIS.
Post Reply
User avatar
Forum Regular
Forum Regular
Posts: 629
Joined: Sun May 03, 2009 2:34 pm

RT2870 wifi in MX14-2 [Sorted]


Post by TenderFoot » Mon Oct 13, 2014 1:31 pm

Having now installed MX14-2 to my new rigs, I tried the usual method http://ubuntuforums.org/showthread.php? ... st12936176 for installing the drivers.  Unfortunately I overlooked kmathern's guidance in http://forum.mepiscommunity.org/viewtop ... 19&t=36774 (#346825) so didn't include the patch (concentrating on M11 at time of thread)!

Can my oversight be rectified?  (I'm not to deeply into personalising this version so it would be no big deal to start again!).
Last edited by TenderFoot on Tue Oct 14, 2014 8:05 pm, edited 1 time in total.

User avatar
Forum Regular
Forum Regular
Posts: 629
Joined: Sun May 03, 2009 2:34 pm

Re: RT2870 wifi in MX14-2


Post by TenderFoot » Tue Oct 14, 2014 4:23 pm

OK - panic over!

After much juggling with paths finally applied the patch successfully and after a reboot all is well.

Don't know what effect having installed both the original and patched versions is in the overall scheme but at least I now know it can be done with inevitable reinstall of MX!

[Just as a matter of interest my PCLos uses kernel 3.12.20 but didn't need the patch?]

Just for the record, whilst the patch worked perfectly in MX14-2 it failed in MX14 (which. at the moment is my preferred version for Compiz reasons!) it failed at the make stage Tracing back the make failure, discovered that /usr/include/sys folder was absent so copied from MX14-2 and all was well!

Post Reply

Return to “Networking”