Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

M8 No wifi (MT7601U) or wired (RTL811G) networking! [Solved]

Questions about Networking that deals with wireless cards, ethernet, modems, samba and anything else related to these, including software help. Tutorials for any of these can be posted too.

Remember to provide relevant info in your posts, such as the following information:

Version of Mepis being used
Card Manufacturer (i.e. Linksys)
Card Model (i.e. WMP54G)
Type: (PCI or PCMCIA)
Current Kernel in use on their system (i.e. 2.6.10)
Udev or Hotplug
Exact steps taken to get the card working if it is not immediately recognized by MEPIS.
Message
Author
User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 597
Joined: Sun May 03, 2009 2:34 pm

Re: No wifi or wired networking!

#31 Post by TenderFoot » Tue Sep 16, 2014 5:14 pm

Yes, I will (quite probably during the desperate attempt to get it going prior to posting, I did also try Mepis Network Assistant - which I usually try to avoid 'cos it's so hateful!).

In the meantime, have managed to sort the usual gpg issues and reload Synaptic (but not the actual updating whilst the connection is unreliable) but observe that firmware-ralink 2.3 lists the rt2870 for the wireless though there is no indication in the tray of its existence?

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 597
Joined: Sun May 03, 2009 2:34 pm

Re: No wifi or wired networking!

#32 Post by TenderFoot » Wed Sep 17, 2014 1:02 pm

kmathern - as a consequence of trying to invoke radeon drivers (another thread) I had to reinstall M8 but am happy to report everything has, so far, gone smoothly and the wired connection seems to be stable!

Referring back to your first reply
Post # 347798

The lack of a wired connection will also be a problem for building the MT7601U wireless driver because you'll need to manually download kernel headers, build-essential, etc. from a install with a working internet connection and then install them in M8 with dpkg.
Any chance of moving forward with that?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9288
Joined: Wed Jul 12, 2006 2:26 pm

Re: No wifi or wired networking!

#33 Post by kmathern » Wed Sep 17, 2014 1:16 pm

TenderFoot wrote:...Any chance of moving forward with that?
You can probably move forward now with that. (maybe in a new topic)

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 597
Joined: Sun May 03, 2009 2:34 pm

Re: No wifi or wired networking!

#34 Post by TenderFoot » Wed Sep 17, 2014 1:32 pm

Ok - I continued here because the thread opened with both.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9288
Joined: Wed Jul 12, 2006 2:26 pm

Re: No wifi or wired networking! [Solved for wired]

#35 Post by kmathern » Wed Sep 17, 2014 1:47 pm

TenderFoot wrote:Ok - I continued here because the thread opened with both.
I would've opened a new topic.

(revised) Anyway, download these three packages:
ftp://ftp.mepis.com/mepis/pool/main/l/l ... _amd64.deb
ftp://ftp.mepis.com/mepis/pool/main/l/l ... _amd64.deb
ftp://ftp.mepis.com/mepis/pool/main/l/l ... _amd64.deb

Install them with KPackage like you installed the kernel package earlier, install the linux-kbuild & -common packages first.

Run the following as root. It'll install build-essential and all the other compiler related stuff you need to build the MT7601U wireless driver module. The module-assistant package might already be installed.

Code: Select all

apt-get update
apt-get install module-assistant
m-a prepare

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 597
Joined: Sun May 03, 2009 2:34 pm

Re: No wifi or wired networking! [Solved for wired]

#36 Post by TenderFoot » Wed Sep 17, 2014 2:30 pm

I'd just started a new topic but have now cancelled!

And yes, have just discovered the missing dependency linux-kbuild when the second one failed! (I'd just fix it through Synaptic but the wired connection has de-stablised again!)

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9288
Joined: Wed Jul 12, 2006 2:26 pm

Re: No wifi or wired networking! [Solved for wired]

#37 Post by kmathern » Wed Sep 17, 2014 2:35 pm

TenderFoot wrote:...(I'd just fix it through Synaptic but the wired connection has de-stablised again!)
Do have the USB wireless dongle/adapter/widget plugged in right now? If so I would unplug it just to make sure it's not part of the problem.

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 597
Joined: Sun May 03, 2009 2:34 pm

Re: No wifi or wired networking! [Solved for wired]

#38 Post by TenderFoot » Wed Sep 17, 2014 2:46 pm

That's a thought but, anyway, it's done up to and including m-a prepare without error.

Can I now proceed per http://ubuntuforums.org/showthread.php? ... st12936176 ?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9288
Joined: Wed Jul 12, 2006 2:26 pm

Re: No wifi or wired networking! [Solved for wired]

#39 Post by kmathern » Wed Sep 17, 2014 2:53 pm

TenderFoot wrote:That's a thought but, anyway, it's done up to and including m-a prepare without error.

Can I now proceed per http://ubuntuforums.org/showthread.php? ... st12936176 ?
Yes, and you can skip the part about the headers.

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 597
Joined: Sun May 03, 2009 2:34 pm

Re: No wifi or wired networking! [Solved for wired]

#40 Post by TenderFoot » Wed Sep 17, 2014 3:13 pm

Sorted! Even typing this reply from it!

I'll modify the title to better reflect the content and solutions.

Now for the graphics...

Post Reply

Return to “Networking”