Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

M8 No wifi (MT7601U) or wired (RTL811G) networking! [Solved]

Questions about Networking that deals with wireless cards, ethernet, modems, samba and anything else related to these, including software help. Tutorials for any of these can be posted too.

Remember to provide relevant info in your posts, such as the following information:

Version of Mepis being used
Card Manufacturer (i.e. Linksys)
Card Model (i.e. WMP54G)
Type: (PCI or PCMCIA)
Current Kernel in use on their system (i.e. 2.6.10)
Udev or Hotplug
Exact steps taken to get the card working if it is not immediately recognized by MEPIS.
Message
Author
User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 600
Joined: Sun May 03, 2009 2:34 pm

M8 No wifi (MT7601U) or wired (RTL811G) networking! [Solved]

#1 Post by TenderFoot » Mon Sep 15, 2014 10:10 am

As a follow-up to http://forum.mepiscommunity.org/viewtop ... 19&t=36774 would the same technique (pointed to by kmathern) work for M8 on the same machine?

A secondary (or even primary) problem is that I cannot even get a wired connection to work and thus cannot perform any download/update either on that machine. I've never heard of a wired connection not working!
Last edited by TenderFoot on Wed Sep 17, 2014 3:25 pm, edited 3 times in total.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22421
Joined: Wed Jul 19, 2006 6:13 am

Re: No wifi or wired networking!

#2 Post by Jerry3904 » Mon Sep 15, 2014 10:29 am

Can you provide some background by pasting in the output of these two commands

Code: Select all

inxi -F

Code: Select all

ifconfig
The second one needs to be run as root.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9318
Joined: Wed Jul 12, 2006 2:26 pm

Re: No wifi or wired networking!

#3 Post by kmathern » Mon Sep 15, 2014 10:41 am

The inxi script isn't installed on M8, and without at least a wired connection you won't be able to install it using the instructions in the wiki: http://www.mepis.org/docs/en/index.php? ... stallation

The lack of a wired connection will also be a problem for building the MT7601U wireless driver because you'll need to manually download kernel headers, build-essential, etc. from a install with a working internet connection and then install them in M8 with dpkg.


edit: this new motherboard you have, does it have a spare pci/pci-e slot that you could put a NIC card in? (and hopefully the NIC would be recognized by the kernel without requiring any additional driver). There's also some usb -> ethernet adapter gizmos that might work.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22421
Joined: Wed Jul 19, 2006 6:13 am

Re: No wifi or wired networking!

#4 Post by Jerry3904 » Mon Sep 15, 2014 10:55 am

Ah, M8 ...
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 600
Joined: Sun May 03, 2009 2:34 pm

Re: No wifi or wired networking!

#5 Post by TenderFoot » Mon Sep 15, 2014 11:10 am

Thanks for prompt response.

Code: Select all

root@MicroOne:/home/Chris# inxi -F
bash: inxi: command not found

root@MicroOne:/home/Chris# ifconfig
eth0      Link encap:Ethernet  HWaddr bc:5f:f4:eb:4f:38
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:309 (309.0 B)  TX bytes:0 (0.0 B)
          Interrupt:254 Base address:0x2000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:552 (552.0 B)  TX bytes:552 (552.0 B)
As you can see the inxi command/script is not recognised!

Btw lsusb does "see" the wifi dongle.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22421
Joined: Wed Jul 19, 2006 6:13 am

Re: No wifi or wired networking!

#6 Post by Jerry3904 » Mon Sep 15, 2014 11:32 am

The wired connection is "up" and should connect automatically. Can you connect if you run manually as root:

Code: Select all

dhclient eth0
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 600
Joined: Sun May 03, 2009 2:34 pm

Re: No wifi or wired networking!

#7 Post by TenderFoot » Mon Sep 15, 2014 11:40 am

Whilst I do have a couple of spare nic they are not low-profile which the case demands (and weren't very reliable and why I purchased the dongles prior to this project!).

At this time I think the most important objective would be to get the wired interface operative to facilitate any further progress? Surely there can't be any compatibility issues there?

EDIT Jerry, our posts are crossing but will try your suggestion!

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 600
Joined: Sun May 03, 2009 2:34 pm

Re: No wifi or wired networking!

#8 Post by TenderFoot » Mon Sep 15, 2014 12:02 pm

The first line is presumably due to a previous attempt which got "lost" when saving output!

Code: Select all

root@MicroOne:/home/Chris# dhclient
There is already a pid file /var/run/dhclient.pid with pid 9520
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/bc:5f:f4:eb:4f:38
Sending on   LPF/eth0/bc:5f:f4:eb:4f:38
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
No DHCPOFFERS received.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16183
Joined: Fri Dec 15, 2006 8:07 pm

Re: No wifi or wired networking!

#9 Post by Stevo » Mon Sep 15, 2014 12:08 pm

M8 came with the little network-manager doodad on the taskbar--are you saying the gear spins around without ever connecting when you use it?

I wonder if mnetwork may be interfering--I also have memories about that application doing that.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9309
Joined: Sun Dec 16, 2007 1:17 pm

Re: No wifi or wired networking!

#10 Post by dolphin_oracle » Mon Sep 15, 2014 12:12 pm

what is the ethernet port chipset? The kernel is m8 would be pretty old.....you might be missing firmware or something.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

Post Reply

Return to “Networking”