The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

RT2500 with Kernel 2.6.7

Questions about Networking that deals with wireless cards, ethernet, modems, samba and anything else related to these, including software help. Tutorials for any of these can be posted too.

Remember to provide relevant info in your posts, such as the following information:

Version of Mepis being used
Card Manufacturer (i.e. Linksys)
Card Model (i.e. WMP54G)
Type: (PCI or PCMCIA)
Current Kernel in use on their system (i.e. 2.6.10)
Udev or Hotplug
Exact steps taken to get the card working if it is not immediately recognized by MEPIS.
User avatar
Posts: 25807
Joined: Wed Jul 19, 2006 6:13 am

Re: RT2500 with Kernel 2.6.7


Post by Jerry3904 » Wed Sep 03, 2014 7:47 am

FWIW: Mepis 3.3 (released end of 2004) used the new tools developed by and for Sphinxos; not the other way around, as many were led to believe.
I didn't know that. What tools, in particular?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
Posts: 9715
Joined: Wed Jul 12, 2006 2:26 pm

Re: RT2500 with Kernel 2.6.7


Post by kmathern » Wed Sep 03, 2014 8:08 am

ko wrote:...Lucid-GNU may well be the last dedicated Sphinxos user. He is using a 10-year old release....:-) Maybe Lucid-Gnu could try to switch to (old) Debian sources, upgrade the 2.6.7 kernel to kernel 2.6.24 (+ newer compiling tools), get the 2.6.24 kernel sources and then compile himself the rt2500 module that he needs?...
What Debian release was Sphinxos 4.0 / Mepis 2004.4 based on? I'm guessing Woody and/or Sarge.

The 2.6.24 kernel first appeared in the Debian repos in Jan. 2008 when Lenny was "testing".

I think there might some some problems installing a Lenny kernel & headers on a Woody/Sarge based release, just like it's problem now trying to install a Jessie kernel & headers on Wheezy.

Come to think of it, it might not be a problem. The rt2500 module is builtin to the 2.6.24 kernel, so it doesn't need to be compiled. That means you wouldn't need to install the header packages (linux-headers-2.6.24-*-common, linux-headers-2.6.24-*-<arch>). Those packages are what's usually the problem when trying to install a kernel from a newer Debian release, the linux-image-* package usually installs without problems. For example I'm using the linux-image-3.16-trunk-amd64 kernel package from Debian Experimental on my MX14 install. It installed without any problems and runs okay, but I can't install the matching linux-headers-* packages, so I can't compile things (kernel modules), so far I haven't needed to anyway.

User avatar
Posts: 20151
Joined: Fri Dec 15, 2006 8:07 pm

Re: RT2500 with Kernel 2.6.7


Post by Stevo » Wed Sep 03, 2014 12:41 pm

Off topic, but if the Experimental kernel headers won't install because of requiring gcc-4.8, it could be fixed by editing the /debian folder and rebuilding the packages. That's what I have to do for the upstream Liquorix kernels. I just use kfind to see what files in /debian have the string "4.8" in them, and then a text editor to replace them with 4.7.

The first build after editing the control file will fail (usually), but it's supposed to. The control file will then get reassembled from template files with python scripts, so the second build command will succeed.

However, the python scripts must use a newer version of python than in M11, because they fail there...

User avatar
Forum Regular
Forum Regular
Posts: 2457
Joined: Wed Jul 12, 2006 4:43 am

Re: RT2500 with Kernel 2.6.7


Post by ko » Thu Sep 04, 2014 6:55 am

Jerry3904 wrote:
FWIW: Mepis 3.3 (released end of 2004) used the new tools developed by and for Sphinxos; not the other way around, as many were led to believe.
I didn't know that. What tools, in particular?
The Mepis Control Centre first appeared in Mepis 3.? around Dec. 2004 and was a near copy of the Sphinxos Kontrol Zentrum developed for and included in the earlier released Sphinxos 4.0. The system tool approach with integrated utilities was much later abandoned again in Mepis (as it took too much time from Warren to maintain it).

Sphinxos 4.0 used debian testing and sid repositories and some packages from a (no longer existing) Mepis testing repository ( deb http://2004.mepis.org/mepis testing main ).

Time to put an end to all things SphinxOS. It's history. The CD-discs are no longer useful and will be discarded.
Ko Bros Linux User #312596.  MX14.4, MX14.3, Mepis 12, Debian 7, antiX 15, Peppermint 5...and sometimes Win7

Forum Novice
Forum  Novice
Posts: 2
Joined: Tue Sep 02, 2014 9:54 am

Re: RT2500 with Kernel 2.6.7


Post by Lucid-Gnu » Tue Sep 09, 2014 12:28 pm


i downloaded the driver-sourcecode for a wlan-pcmcia-card with rt2500-chipset (rt2500pci) (MSI Wireless 11G - Cardbus "CB54G2) here:

http://sourceforge.net/projects/rt2400/ (direct download-link)

now, since i am a noob?, i am having troubles compiling the sourcecode on the SphinxOS 4.0 MEPIS
, are we able to solve this problem ?

As i mentioned above i downloaded the "tar-gz" file into my "home/<user-name>/tmp"-directory
using tar -x(extract)z(using gunzip)f(working on a file) = tar -xzf rt73xxxxx.tar.gz

then i changed into the created "rt73xxx.."-directory and into the "Module"-directory
pwd = /home/<user-name>/tmp/rt73../Module

i continued typing "make" whereas i got an error message which said:

Code: Select all

make: *** /lib/modules/2.6.7/build: Datei oder Verzeichnis nicht gefunden.  Schluss.
rt73.ko failed to build!
make: *** [module] Fehler 1

i then changed into the directory for the build-directory and did a "ls -l"
and saw a soft/symbolic-link

build -->/usr/source/2.6.7

so i renamed the soft/symbolic link build to "build-dir_original"
and created a new directory called build in the same directory (namely /lib/modules/2.6.7/ (build) )
So i tried to compile the drivers again typing "make" in the directory the tar-file created when extracted (/home/<user>/tmp/rt73xx.../Module ).
This time the error message changed to:

Code: Select all

make[1]: Entering directory `/lib/modules/2.6.7/build'
make[1]: *** Keine Regel, um »modules« zu erstellen.  Schluss.
make[1]: Leaving directory `/lib/modules/2.6.7/build'
rt73.ko failed to build!
make: *** [module] Fehler 1
What am i supposed to do now, please ?

Post Reply

Return to “Networking”