Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Part of Internet Inaccessible

Questions about Networking that deals with wireless cards, ethernet, modems, samba and anything else related to these, including software help. Tutorials for any of these can be posted too.

Remember to provide relevant info in your posts, such as the following information:

Version of Mepis being used
Card Manufacturer (i.e. Linksys)
Card Model (i.e. WMP54G)
Type: (PCI or PCMCIA)
Current Kernel in use on their system (i.e. 2.6.10)
Udev or Hotplug
Exact steps taken to get the card working if it is not immediately recognized by MEPIS.
Message
Author
morollan7
Forum Novice
Forum  Novice
Posts: 3
Joined: Sun Aug 17, 2014 11:01 am

Part of Internet Inaccessible

#1 Post by morollan7 » Sun Aug 17, 2014 11:18 am

What adjustments can be made to allow Linux (Mepis 12) to reach the entire Internet? A whole chunk (Ubuntu, Pricewatch, Google, Yahoo,
probably others) tells me can't find server. But those areas are available through Windows (ugh!) so I have to keep a Virtualbox of Windows
on my box. Nobody's ever been able to tell me why or what can be done about it. Anybody have any ideas?

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 8971
Joined: Wed Jul 12, 2006 1:42 am

Re: Part of Internet Inaccessible

#2 Post by Adrian » Sun Aug 17, 2014 11:37 am

Nobody's ever been able to tell me why or what can be done about it.
Since this is your first post here I am not sure what else you tried, you need to troubleshoot and see where the problem is.

Try to ping google.com and see if you get a response, then try to ping the Google IP address (for example 74.125.228.99) and see if it makes a difference. It might be a DNS problem, did you configure the DNS settings manually?

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 11380
Joined: Wed Jul 12, 2006 5:54 am

Re: Part of Internet Inaccessible

#3 Post by lucky9 » Sun Aug 17, 2014 12:07 pm

It has to be a configuration that you've changed since there have been no problems noted elsewhere.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

morollan7
Forum Novice
Forum  Novice
Posts: 3
Joined: Sun Aug 17, 2014 11:01 am

Re: Part of Internet Inaccessible

#4 Post by morollan7 » Sun Aug 17, 2014 12:25 pm

lucky9 wrote:It has to be a configuration that you've changed since there have been no problems noted elsewhere.
I haven't made any configuration changes at all from first setup. And the problem isn't just with Mepis. I abandoned Linux Mint
because of this. I was wondering if it could be a problem with the configuration of my ISP? Linux Mint (back when I was using
version 13) worked fine for a while and then I noticed the update and package managers were fouling up.

I guess you can tell I have absolutely no idea of what I'm doing :confused: . I got out of Windows because I was tired of it being slowed
down by the antivirus programs you have to use. If I couldn't even fix that, it's obvious I need help.

User avatar
joany
Forum Veteran
Forum Veteran
Posts: 5919
Joined: Mon Feb 12, 2007 1:45 pm

Re: Part of Internet Inaccessible

#5 Post by joany » Sun Aug 17, 2014 12:50 pm

This is almost surely a DNS issue. There is nothing about Linux per se that would have anything to do with locating servers. If you haven't made changes to your DNS settings since installing, you're probably using your ISP's DNS servers, which would be the default OOTB.

However, this does not rule out the possibility that some software update or unintentional setting change might have affected your network settings. The way to find out is to open up the network manager and have a look. When you edit your connection, you should have "Automatic (DHCP) addresses only" selected. If there are no entries listed in the "DNS Servers" window, then you should be using your ISP's DNS servers by default. If there are entries in the "DNS Servers" window, try removing them, then reboot and see if things go back to "normal."
Last edited by joany on Sun Aug 17, 2014 12:53 pm, edited 1 time in total.
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4408
Joined: Wed Jul 12, 2006 4:05 pm

Re: Part of Internet Inaccessible

#6 Post by timkb4cq » Sun Aug 17, 2014 12:51 pm

It's probably your router. I used to have a router that wouldn't hand out the DNS settings to Linux because it didn't *quite* follow the standard. After months of complaints they issued an updated firmware that fixed the problem.
There are two possible solutions to that. Either reflash the router with updated firmware, or manually set your DNS to an outside DNS server like Google's. The directions for the former are router specific. To do the latter:
Go to Start -> Settings -> System Settings -> Network & Connectivity -> Network Settings
If you have a wired connection, Click on the name of your wired connection in the box then choose Edit.
Under the IPV4 Adress tab, change the pulldown from Automatic (DHCP) to Automatic (DHCP) addresses only
Now fill in the DNS Servers box with 8.8.8.8, 8.8.4.4 Click OK
Those are Google's public DNS servers. There are many other public DNS servers you can use if you prefer.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
joany
Forum Veteran
Forum Veteran
Posts: 5919
Joined: Mon Feb 12, 2007 1:45 pm

Re: Part of Internet Inaccessible

#7 Post by joany » Sun Aug 17, 2014 12:55 pm

timkb4cq wrote:It's probably your router. I used to have a router that wouldn't hand out the DNS settings to Linux because it didn't *quite* follow the standard. After months of complaints they issued an updated firmware that fixed the problem.
There are two possible solutions to that. Either reflash the router with updated firmware, or manually set your DNS to an outside DNS server like Google's. The directions for the former are router specific. To do the latter:
Go to Start -> Settings -> System Settings -> Network & Connectivity -> Network Settings
If you have a wired connection, Click on the name of your wired connection in the box then choose Edit.
Under the IPV4 Adress tab, change the pulldown from Automatic (DHCP) to Automatic (DHCP) addresses only
Now fill in the DNS Servers box with 8.8.8.8, 8.8.4.4 Click OK
Those are Google's public DNS servers. There are many other public DNS servers you can use if you prefer.
Good catch. I hadn't considered the router angle. One comment, however. I believe a reboot will be required if you change DNS servers to 8.8.8.8 and 8.8.4.4 in order for the changes to go into effect. Or maybe stopping and starting network services.
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4408
Joined: Wed Jul 12, 2006 4:05 pm

Re: Part of Internet Inaccessible

#8 Post by timkb4cq » Sun Aug 17, 2014 1:01 pm

Yep, I think you're right that restarting the network is required. You can click the ethernet jack icon in the system tray, then the circled red X in the Interfaces: panel to stop the connection. Then double click on the name in the Connection: panel to restart it.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9526
Joined: Sun Dec 16, 2007 1:17 pm

Re: Part of Internet Inaccessible

#9 Post by dolphin_oracle » Sun Aug 17, 2014 4:18 pm

I have a Motorola router from my isp with this same problem. Att dsl. It doesn't forward the dns servers correctly. Also fixed by setting the dns servers in my home router by hand. If you don't want to mess with the router you can try specifying the Google dns servers in your network Manger settings. There is a tab to set a preferred dns and you do not have to use a static in to utilize the feature. Handy if you use multiple networks and don't have admin access to the router.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
joany
Forum Veteran
Forum Veteran
Posts: 5919
Joined: Mon Feb 12, 2007 1:45 pm

Re: Part of Internet Inaccessible

#10 Post by joany » Sun Aug 17, 2014 6:27 pm

dolphin_oracle wrote:I have a Motorola router from my isp with this same problem. Att dsl. It doesn't forward the dns servers correctly. Also fixed by setting the dns servers in my home router by hand. If you don't want to mess with the router you can try specifying the Google dns servers in your network Manger settings. There is a tab to set a preferred dns and you do not have to use a static in to utilize the feature. Handy if you use multiple networks and don't have admin access to the router.
In addition to Google, another choice is OpenDNS. You can find out about it here: http://www.opendns.com/

(Some people don't trust Google because of their reputation of collecting data from subscribers. But that's a whole other topic.)
MX-14; 3.12-0.bpo.1-686-pae kernel using 4GB RAM
2.4GHz AMD Athlon 4600+
NVidia GeForce 6150 LE; 304.121 Display Driver
You didn't slow down because you're old; you're old because you slowed down.

Post Reply

Return to “Networking”