Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

eth0: auto-negotiating....(M8) [Resolved - sort of!]

Questions about Networking that deals with wireless cards, ethernet, modems, samba and anything else related to these, including software help. Tutorials for any of these can be posted too.

Remember to provide relevant info in your posts, such as the following information:

Version of Mepis being used
Card Manufacturer (i.e. Linksys)
Card Model (i.e. WMP54G)
Type: (PCI or PCMCIA)
Current Kernel in use on their system (i.e. 2.6.10)
Udev or Hotplug
Exact steps taken to get the card working if it is not immediately recognized by MEPIS.
Message
Author
User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 604
Joined: Sun May 03, 2009 2:34 pm

eth0: auto-negotiating....(M8) [Resolved - sort of!]

#1 Post by TenderFoot » Thu Feb 06, 2014 11:56 am

Across my 5 multi-boot machines, both M8 and M11 install and function more or less flawlessly.

However, on one machine a very peculiar problem manifests itself when in cli (when trying to add proprietary nvidia drivers which isn't relevant per ce). As soon as in cli the display keeps echoing

Code: Select all

eth0: auto-negotiating...
in a loop at 5 sec intervals.

Thus it is very difficult to enter any command which mixes with the above output!

This only occurs in M8 on this one machine. It may be useful to add that the symptom disappears if I actually plug in a wired connection.

[I've done a lot of googling but everything seems to assume that it is what I want to activate not eliminate!]

As a secondary question which may or may not be related. The wifi connection works well, but does not connect at start-up though checked to do so. Once the tray icon is clicked and my n/w is selected (from a list of one!) everything is fine but end up with two icons - rising blue bars and the red transmitters?
Last edited by TenderFoot on Fri Feb 07, 2014 10:28 am, edited 2 times in total.

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 11380
Joined: Wed Jul 12, 2006 5:54 am

Re: eth0: auto-negotiating....(M8)

#2 Post by lucky9 » Thu Feb 06, 2014 1:52 pm

You can use the Mepis Network Assistant to try or not try and connect at boot for wifi or wired.

As for the 'problem' with the nvidia driver. Just download the correct driver ahead of time and just boot into init 3. Assume root privileges and enter the sh nvidiablahblah string. (I always use cd and dir to move and/or list the contents of directories so I get the string correct.) Hit Enter.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 604
Joined: Sun May 03, 2009 2:34 pm

Re: eth0: auto-negotiating....(M8)

#3 Post by TenderFoot » Thu Feb 06, 2014 4:17 pm

But MNWA isn't much help - both Wireless and Interfaces are greyed out. In all other respects this is the default configuration as deployed on other machines.

Wireless works perfectly once started it just seems to be the wired option that is getting in the way (unless it is actually connected).

It may "simply" be an issue with the Sis lan chip that was resolved in M11?

User avatar
lucky9
Forum Veteran
Forum Veteran
Posts: 11380
Joined: Wed Jul 12, 2006 5:54 am

Re: eth0: auto-negotiating....(M8)

#4 Post by lucky9 » Thu Feb 06, 2014 6:16 pm

I wouldn't argue against it.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 604
Joined: Sun May 03, 2009 2:34 pm

Re: eth0: auto-negotiating....(M8)

#5 Post by TenderFoot » Thu Feb 06, 2014 6:41 pm

OK. Since nvidia/resolution problem has now been resolved, I may never need to drop down to cli so if it is still going on in the background, "ignorance is bliss" so long as it does not otherwise interfere with performance (and don't think it is).

But do I need both tray icons - ie can knemo be disabled?

User avatar
qtech
Forum Regular
Forum Regular
Posts: 662
Joined: Wed Nov 28, 2007 12:21 pm

Re: eth0: auto-negotiating....(M8)

#6 Post by qtech » Fri Feb 07, 2014 1:56 am

TenderFoot wrote:...I may never need to drop down to cli so if it is still going on in the background, "ignorance is bliss" so long as it does not otherwise interfere with performance (and don't think it is)...
The "eth0: auto-negotiating" message means that your network card is attempting to engage in a conversation with another device (e.g. a router or cable modem). The message disappears when you connect the ethernet cable because the NIC is successfully able to communicate.

Google "eth0: auto-negotiating" and the NIC's manufacturer name/model.


Oh, and good luck with that never dropping to cli again thing. :p

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 604
Joined: Sun May 03, 2009 2:34 pm

Re: eth0: auto-negotiating....(M8)

#7 Post by TenderFoot » Fri Feb 07, 2014 10:27 am

As indicated in OP, "googling" only tells me how to start eth0 probing not stop it (or at least echoing the interfering message)! Searching on Sis191 is no more revealing.

Anyway, should I need to get "deep down and dirty", my TP-LinK WR702N client (the only TP-Link device I've ever had fully functioning!) can be plugged in to shut it up (echoing)!

In the meantime "ignorance is still bliss"... :popcorn:

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9347
Joined: Wed Jul 12, 2006 2:26 pm

Re: eth0: auto-negotiating....(M8) [Resolved - sort of!]

#8 Post by kmathern » Fri Feb 07, 2014 11:16 am

TenderFoot wrote:...However, on one machine a very peculiar problem manifests itself when in cli...

Code: Select all

eth0: auto-negotiating...
...the symptom disappears if I actually plug in a wired connection....
I wonder if it might be that your wireless adapter & connection is only working while X is up and running? What interface is assigned to your wireless adapter when it's actually working? (wlan*, eth*, etc.). If it's being assigned the eth0 interface, the "eth0: auto-negotiating..." messages you're getting might have something to do with your wireless adapter, not your wired connection.

With X up and running & the wireless internet connection working, what does the ifconfig command return? (you need to run that command as root)

Also what is the wireless device? (the wireless adapter/device the computer is using, not the TP-LinK WR702N you mention -- which appears to be a router)

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 604
Joined: Sun May 03, 2009 2:34 pm

Re: eth0: auto-negotiating....(M8) [Resolved - sort of!]

#9 Post by TenderFoot » Fri Feb 07, 2014 4:49 pm

Output form ifconfig

Code: Select all

eth0      Link encap:Ethernet  HWaddr 00:1c:25:5a:7c:5b
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:19 Base address:0xdead

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:41 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2136 (2.0 KiB)  TX bytes:2136 (2.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:17:9a:b7:b4:00
          inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::217:9aff:feb7:b400/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:391 errors:0 dropped:0 overruns:0 frame:0
          TX packets:304 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:167942 (164.0 KiB)  TX bytes:42842 (41.8 KiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-17-9A-B7-B4-00-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
The wifi adapter is a DLink GL22 usb dongle.

[PS The TP-Link is a miniature multifunction device which can be a router but mine are (I have a couple because they're so useful in an emergency!) set up in client mode.so that it acts as wireless cable connection. Also can be used, for example, in the lan port of pvr, set-top box or tv!]

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9347
Joined: Wed Jul 12, 2006 2:26 pm

Re: eth0: auto-negotiating....(M8) [Resolved - sort of!]

#10 Post by kmathern » Fri Feb 07, 2014 5:02 pm

Okay, it looks like the DLink wireless adapter is using the wlan0 interface.
Is there any reason you can't shutdown the eth0 interface?

Code: Select all

ifconfig eth0 down

Post Reply

Return to “Networking”