Welcome!

Please read this important information about Spectre and Meltdown vulnerabilities.
Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 Final release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

scanner not detected

Questions about printers and scanners, hardware-related and/or software-related can be asked here, as well as posting of tutorials.
Message
Author
User avatar
beckwith
Forum Regular
Forum Regular
Posts: 475
Joined: Thu Feb 15, 2007 9:27 pm

scanner not detected

#1 Postby beckwith » Fri Dec 12, 2014 11:41 pm

This is a follow on from post #34932
I still can't get the scanner (HP6700) to be recognised.
I've done all the the things suggested. Contacted xsane-devel
(who told me the scanner waas not supported, unless by hplip).
The problem two-fold
1) i get this error
Error during CMS conversion
Could not open scanner ICM profile

2) xsane detected my web cam, but not the scanner, both usb
devices.
Now I am happy the xsane say the device is not supported, but it
was working before I install M12 on new hardware. I also
have proof that it was working: scans of documents with
dates less than 6 months ago, from a scanner I have owned
for more than year.
"sane-find-scanner" finds the scanner.
"scanimage -L" does not find the scanner

EDIT

This is what happened... I had a serious disk error on my desktop
system, and had to move to using my laptop: to be able to print
the printer/scanner was reconfigured to use wireless - previously
is was a usb device to the desktop. It is still wireless, 'cos
I like both machines to be able to print - - - but this was a change.
As the failing h/w was eight years old, I decided to not just replace
the harddrive, but the whole system, so M12 was re-installed, must
be up to two years since the original h/w got M12, a lot has changed
in the repos over that time.
The laptop has not had M12 re-installed, but when I tried use the
scanner (by usb) it also fails. So I'm deducing the main change is
that the printer running as wireless is the major change. I've
tried reverting it to usb (not that this is desirable), but now I don't
seem able to make it work as usb printer!

EDIT #2

downloaded HPLIP from HP site. Now the CMS error has gone, and the
scanner is detected!
Linux user 449018, since 1994, Mepis (3.4 onwards) 2006, now Debian 7.8
Desktop: HP 500-315a i54460, - Debian 7.8
Laptop: Toshiba Satellite L500D/006 - Depian 7.8
Toy: Raspberry PI/mkBii - Raspian 2015-01-31
ePad: Asus - Android

Return to “Print/Scan”

Who is online

Users browsing this forum: No registered users and 1 guest