Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Driver for HP 6520-e all in onne series

Questions about printers and scanners, hardware-related and/or software-related can be asked here, as well as posting of tutorials.
Message
Author
User avatar
FLACKBAIT
Forum Novice
Forum  Novice
Posts: 26
Joined: Tue May 05, 2009 5:56 pm

Re: Driver for HP 6520-e all in onne series

#11 Post by FLACKBAIT » Thu Apr 17, 2014 11:49 am

Did all that and it did fix one of the probllems, but not the printer problem. This is the error message after I reinstll:

W: Failed to fetch main.mepis-deb.org/mepiscr/testrepo/pool/test/h/hplip/hplip-cups_3.13.3-1mcr110+1_all.deb
404 Not Found

User avatar
FLACKBAIT
Forum Novice
Forum  Novice
Posts: 26
Joined: Tue May 05, 2009 5:56 pm

Re: Driver for HP 6520-e all in onne series

#12 Post by FLACKBAIT » Thu Apr 17, 2014 12:13 pm

Did all of the above and it did fix one problem, but not the printer problem. it can not find hplip-cups 3.13.3 version in the repository testpro when I do an upgrade. i'm still at 3.12.9 HP install keeps defaulting to USB setup instead of wireless.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9302
Joined: Wed Jul 12, 2006 2:26 pm

Re: Driver for HP 6520-e all in onne series

#13 Post by kmathern » Thu Apr 17, 2014 1:18 pm

FLACKBAIT wrote:Did all that and it did fix one of the probllems, but not the printer problem. This is the error message after I reinstll:

W: Failed to fetch main.mepis-deb.org/mepiscr/testrepo/pool/test/h/hplip/hplip-cups_3.13.3-1mcr110+1_all.deb
404 Not Found
The hplip version currently in the M11 (and M12) testrepos is the 3.14.3-0mcr110+1 version.

The 3.14.3-0mcr110+1 hplip packages were uploaded to the pool folder correctly (they're here: http://main.mepis-deb.org/mepiscr/testr ... t/h/hplip/) replacing the 3.13.3-1mcr110+1 version packages, but it looks like two of the 3.13.3-1 version packages still have entries in the package list, hpijs and hplip-cups. That might be what's causing the problem.

The hpijs and hplip-cups packages aren't in the 3.14.3 version of hplip, they've been replaced by printer-driver-hpijs & printer-driver-hpcups.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4304
Joined: Wed Jul 12, 2006 4:05 pm

Re: Driver for HP 6520-e all in onne series

#14 Post by timkb4cq » Thu Apr 17, 2014 1:40 pm

The problem is that the hpijs & hplip-cups packages were "dummy packages" in 3.13.3. There's no actual content inside, they just depend on the renamed packages printer-driver-hpijs & printer-driver-hpcups so that they'll get installed when an upgrade is done. In 3.12.9 they had content. Those dummy packages should have stayed in the repo for those folks who hadn't already upgraded but they accidentally got removed when the new version went in.

They've been put back now. Sorry for the inconvenience.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
FLACKBAIT
Forum Novice
Forum  Novice
Posts: 26
Joined: Tue May 05, 2009 5:56 pm

Re: Driver for HP 6520-e all in onne series

#15 Post by FLACKBAIT » Fri Apr 18, 2014 1:23 pm

Reloaded the module. hp-cups is at 3.13.3 and all other hplip modules are at 3.14.3 Nice try but no cigar. HP setup consistantly indicates that I have a USB cable link between the laptop and printer. I click on the wireless setup, but it doesn't take. Also, HP setup goes into a loop at step 5 and goes back to step 2.. I have to cancel to get out. I go back and delete in Settings/systems and sure enough, it shows a usb connection. Any suggestions?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9302
Joined: Wed Jul 12, 2006 2:26 pm

Re: Driver for HP 6520-e all in onne series

#16 Post by kmathern » Fri Apr 18, 2014 1:39 pm

FLACKBAIT wrote:Reloaded the module. hp-cups is at 3.13.3 and all other hplip modules are at 3.14.3 Nice try but no cigar. HP setup consistantly indicates that I have a USB cable link between the laptop and printer. I click on the wireless setup, but it doesn't take. Also, HP setup goes into a loop at step 5 and goes back to step 2.. I have to cancel to get out. I go back and delete in Settings/systems and sure enough, it shows a usb connection. Any suggestions?
You should also now have a printer-driver-hpcups package installed, the 3.14.3 version.

If you do you can remove the hplip-cups package because it did it's job of transitioning to the printer-driver-hpcups package and is nolonger needed.


edit:
For the problems you're having with HP setup someone else will have to help, I don't own a Hp printer.

User avatar
FLACKBAIT
Forum Novice
Forum  Novice
Posts: 26
Joined: Tue May 05, 2009 5:56 pm

Re: Driver for HP 6520-e all in one series

#17 Post by FLACKBAIT » Sat Apr 19, 2014 1:20 am

I removed hplib-cups. Still doesn't work. When I use HP install, it never makes the jump from the usb to wireless after I pull the cable in step 5 and click finish.. It goes back to step 2 and goes on to step 5. HP install will not close. I have to cancel it. It detects the prinnter. I can print documents as long as I keep the usb cable plugged in. It goes nuts when I pull the usb cable.

I am coming to the conclusion that HP install does not support a HP 6520 in a wirless mode. Do I have to wait until Mepis 12 comes out? When I try to install the printer using settings/system settings, I can define the printer. When I try to print I get a message telling me that I am using the wrong driver.

%! userdict dup(\004) cvn{}put (004\004) cvn{}put
% You are using the wrong driver.

I don't have this problem in Windows 7 or XP. I can print to the printer in the wireless mode.

Post Reply

Return to “Print/Scan”