Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Printer not printing in MX14rc2, simple solution

Questions about printers and scanners, hardware-related and/or software-related can be asked here, as well as posting of tutorials.
Post Reply
Message
Author
User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6008
Joined: Wed Jul 12, 2006 2:10 am

Printer not printing in MX14rc2, simple solution

#1 Post by Eadwine Rose » Fri Mar 21, 2014 8:17 pm

I figured I'd share this, as the problem that caused this was really weird, but the solution is easy.


I just tried to print my work planning, always went just fine, but this time.. no dice. Try again, nothing. Try another document, nothing. Turn off printer, reboot, turn back on.. nope.

What the hell? It worked fine yesterday, I didn't do anything to it. :confused:

Look in the hp toolbox, printer queue stopped, idle. *shrug* Weird.. but whatever I try, no printing.


Then I start the menu-system-printing program
right click on my printer, properties
policies.. enabled was UNchecked.

Checked it, hit apply, printer starts spitting out all the previous print attemps, problem solved.

What caused this, I have no idea, but considering this is something that would be handy to know if others encounter it I figured I'd post it.
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
m_pav
Forum Guide
Forum Guide
Posts: 2670
Joined: Sun Aug 06, 2006 3:02 pm

Re: Printer not printing in MX14rc2, simple solution

#2 Post by m_pav » Sat Mar 22, 2014 2:56 am

I have seen it a few times too. The printer is paused for some unknown reason and the printer icon for the device in the Printing (configure Printers) menu has a pause icon overlay on it. So far, only seen it on Brother and Canon printers, not on Epson or Kyocera, but the latter are all I have.
Mike P

Regd Linux User #472293
(Mine)Lenovo T560, i7-6600U, 16GB, 2.0TB SSHD, MX17 64-bit
(Wifes) Asus M4A88TD-M, AMD Phenom II x4 955 CPU, nVidia GF610, 6Gb, 500GB+320GB, MX17 + KDE
(Kids) Intel NUC, J1900, 4GB, 64GB SSD, MX17

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6008
Joined: Wed Jul 12, 2006 2:10 am

Re: Printer not printing in MX14rc2, simple solution

#3 Post by Eadwine Rose » Sat Mar 22, 2014 3:40 am

There was no indicator visible here.. I just happened to be lucky that I started looking in the right spot. Usually it is the last thing you find and you hit your forehead for it being something so simple.
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
m_pav
Forum Guide
Forum Guide
Posts: 2670
Joined: Sun Aug 06, 2006 3:02 pm

Re: Printer not printing in MX14rc2, simple solution

#4 Post by m_pav » Sat Mar 22, 2014 4:23 am

I wonder if this is something we need to lay down as a possible bug, given that between you and I, we have 3 occurrences of the same thing from a very small base of testers.
Mike P

Regd Linux User #472293
(Mine)Lenovo T560, i7-6600U, 16GB, 2.0TB SSHD, MX17 64-bit
(Wifes) Asus M4A88TD-M, AMD Phenom II x4 955 CPU, nVidia GF610, 6Gb, 500GB+320GB, MX17 + KDE
(Kids) Intel NUC, J1900, 4GB, 64GB SSD, MX17

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6008
Joined: Wed Jul 12, 2006 2:10 am

Re: Printer not printing in MX14rc2, simple solution

#5 Post by Eadwine Rose » Sat Mar 22, 2014 4:41 am

I just wonder if it will be a repeat offender so to speak. If it only occurs once it is hard to lay the finger on where the problem happens. Maybe an upgrade of sorts, maybe something else that triggers it. I did not touch it directly in any case and it has been printing fine since the install.
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4354
Joined: Wed Jul 12, 2006 4:05 pm

Re: Printer not printing in MX14rc2, simple solution

#6 Post by timkb4cq » Sat Mar 22, 2014 7:24 am

There was a security related update to cups-filters & libcupsfilters1 released about a week ago. I wouldn't be surprised if that's what triggered the issue.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6008
Joined: Wed Jul 12, 2006 2:10 am

Re: Printer not printing in MX14rc2, simple solution

#7 Post by Eadwine Rose » Mon Mar 31, 2014 4:22 pm

One thing that triggers this is if you start printing something from LO and the printer is at that stage still off.

Turn on the printer, still nothing, then enable the printer and hoppa, printout comes out.

I don't know if this is repeatable.

Too bad.. the 840c that got fried (literally..) turned itself on when a print message was sent to it.
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

Post Reply

Return to “Print/Scan”