Welcome!

Please read this important information about Spectre and Meltdown vulnerabilities.
Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 Final release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

Mepis-12 no desktop

You can ask for help with video cards, tv cards, dvb, monitors, webcams, digital cameras and software related to these devices, here. Tutorials about these devices can be posted here, too.
Message
Author
User avatar
towwire
Forum Regular
Forum Regular
Posts: 257
Joined: Fri Oct 15, 2010 12:15 pm

Mepis-12 no desktop

#1 Postby towwire » Wed Dec 10, 2014 2:47 pm

I have a gigabyte F2A88X-UP4 motherboard, AMD A10-7850K APU with R7 Graphics. I had the disappearing mouse and found that the video driver could be the cause. I ran sgfxi and just followed the defaults. So how do I get to the desktop, when booting my screen is black and shows the following:
MEPIS Linux 12.0 mepis12 tty1
mepis12 login:

Or get back to the old driver.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9127
Age: 59
Joined: Wed Jul 12, 2006 2:26 pm

Re: Mepis-12 no desktop

#2 Postby kmathern » Wed Dec 10, 2014 3:22 pm

You usually need to run sgfxi twice when installing the proprietary driver (fglrx or nvidia).

User avatar
towwire
Forum Regular
Forum Regular
Posts: 257
Joined: Fri Oct 15, 2010 12:15 pm

Re: Mepis-12 no desktop

#3 Postby towwire » Wed Dec 10, 2014 3:25 pm

kmathern wrote:You usually need to run sgfxi twice when installing the proprietary driver (fglrx or nvidia).

I have run it 3 times already. Still only get back to tty1 screen, never to login for desktop.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9127
Age: 59
Joined: Wed Jul 12, 2006 2:26 pm

Re: Mepis-12 no desktop

#4 Postby kmathern » Wed Dec 10, 2014 3:32 pm

towwire wrote:
kmathern wrote:You usually need to run sgfxi twice when installing the proprietary driver (fglrx or nvidia).

I have run it 3 times already. Still only get back to tty1 screen, never to login for desktop.
Okay, this should set it back to the radeon driver

Code: Select all

sgfxi -N radeon


I don't know if you need to run sgfxi multiple times when reverting back to the opensource driver.

User avatar
towwire
Forum Regular
Forum Regular
Posts: 257
Joined: Fri Oct 15, 2010 12:15 pm

Re: Mepis-12 no desktop

#5 Postby towwire » Wed Dec 10, 2014 4:44 pm

kmathern wrote:Okay, this should set it back to the radeon driver

Code: Select all

sgfxi -N radeon


I don't know if you need to run sgfxi multiple times when reverting back to the opensource driver.

Did not work, now have black screen with a flashing curser. Followed directions and shutdown for at least 30 seconds as told. Now how do I get to a spot to try your command again?

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9127
Age: 59
Joined: Wed Jul 12, 2006 2:26 pm

Re: Mepis-12 no desktop

#6 Postby kmathern » Wed Dec 10, 2014 4:59 pm

At the black screen with flashing cursor try <Ctrl> + <Alt> + <F1> to see if that will get you a usable console to work in.

If it does, login and run the `sgfxi -N radeon` command again.

If that still doesn't work it might be that the Wheezy radeon xorg driver doesn't support your AMD A10-7850K APU/R7 Graphics. If that's the case remove the /etc/X11/xorg.conf file and it should then use either the fbdev or vesa driver.


Return to “Video-Related”

Who is online

Users browsing this forum: No registered users and 2 guests