Welcome!
Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

how to fix mp3 playback in Iceweasel ?

Problems with your sound card are to be posted here, as well as tutorials to share with others.
User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1009
Joined: Wed Aug 02, 2006 12:12 pm

how to fix mp3 playback in Iceweasel ?

#1

Post by eemaestro » Wed Jun 10, 2015 5:15 pm

Upon loading this URL in Iceweasel,
http://www.holophonic.ch/archivio/testa ... phonic.mp3
the error message said "Video can't be played because the file is corrupt."
I noticed under Edit...Preferences...Advanced...Applications nothing is set up
to handle mp3's. Doesn't look right.

Could somebody check this URL & see if Iceweasel plays the sound? Or
alternatively post the URL of an mp3 you know plays sound when you con-
nect your browser to it?

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 24581
Joined: Wed Jul 19, 2006 6:13 am

Re: how to fix mp3 playback in Iceweasel ?

#2

Post by Jerry3904 » Wed Jun 10, 2015 5:22 pm

That works for me, if "works" means various scratchy sounds.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19291
Joined: Fri Dec 15, 2006 8:07 pm

Re: how to fix mp3 playback in Iceweasel ?

#3

Post by Stevo » Wed Jun 10, 2015 5:25 pm

It plays in our Firefox 38.0.5. I think Iceweasel needs some gstreamer packages to play anything that's not ogg or webm natively.

Here's some other mp3 links that also play in a new tab in Firefox: http://www.kfiam640.com/podcast/BillHandel.xml

A test page with various formats: http://hpr.dogphilosophy.net/test/

Flac is the only one I can't play.

But jeesh, this thread with the answer is the first result to come up when I Googled the problem:

http://crunchbang.org/forums/viewtopic.php?pid=394974

i.e., you need the -bad gstreamer plugins package.

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1009
Joined: Wed Aug 02, 2006 12:12 pm

Re: how to fix mp3 playback in Iceweasel ?

#4

Post by eemaestro » Wed Jun 10, 2015 10:59 pm

Unfortunately, Stevo, I couldn't hear ***any*** of the recordings for the first two URLs you posted in IceWeasel 31.7.0. Next I'll investigate the last URL you posted to see if it mentions the -bad gstreamer plugins package so I can understand it enough to fix it. Thanks, Stevo.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8193
Joined: Wed Jul 12, 2006 2:10 am

Re: how to fix mp3 playback in Iceweasel ?

#5

Post by Eadwine Rose » Thu Jun 11, 2015 12:15 am

gstreamer0.10-plugins-bad I wager.
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19291
Joined: Fri Dec 15, 2006 8:07 pm

Re: how to fix mp3 playback in Iceweasel ?

#6

Post by Stevo » Thu Jun 11, 2015 12:17 am

Eadwine Rose wrote:gstreamer0.10-plugins-bad I wager.
+1 :number1:
Give the lady a cigar!

Edit: or maybe no cigar, :p the #! thread said it was the gstreamer1.0-plugins-bad package from wheezy-backports that seemed to provide the fix.
Last edited by Stevo on Thu Jun 11, 2015 1:35 pm, edited 1 time in total.

User avatar
eemaestro
Forum Guide
Forum Guide
Posts: 1009
Joined: Wed Aug 02, 2006 12:12 pm

Re: how to fix mp3 playback in Iceweasel ?

#7

Post by eemaestro » Thu Jun 11, 2015 12:02 pm

Running Iceweasel 31.7.0 in 64-bit wheezy, MEPIS 12.0
Dunno if this appl. is 32 or 64-bit --Help doesn't say.

Jun 10,

Nothing worked. When I double-clicked on an mp3 already on my computer,
which I'd already listened to, Audacity popped up. It played according
to Audacity's display. But I heard nothing. So it did not work.
Now I know why youtube is so popular. It just works. Period.
Going to bed. Will sort out this audio codecs crap during daylight hours.

Jun 11,

Before changing anything,

I went to the test page http://hpr.dogphilosophy.net/test/ to experiment.

I heard every file format except for MP3 and FLAC, the bottom two. These
both popped up errror messages when I clicked on each. The two error
messages were different. I did not write either one down.

Okay, bettors, having read the webpage at Stevo's third URL, I downloaded
the package like so:

Code: Select all

#apt-get install gstreamer0.10-plugins-bad
# apt-get install gstreamer0.10-plugins-bad
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gstreamer0.10-plugins-bad is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
and restarted Firefox. (rebooted w/ <ALT><SysRq> REISUB)
Last two audio formats on the test page still don't work.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19291
Joined: Fri Dec 15, 2006 8:07 pm

Re: how to fix mp3 playback in Iceweasel ?

#8

Post by Stevo » Thu Jun 11, 2015 1:18 pm

Apparently Iceweasel's 31.7 HTML5 is not fully cooked yet, since I can't get those sample links to make any sound either in Iceweasel. Reverting to Firefox 38.0.6, they again worked, so that's my suggested fix.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8193
Joined: Wed Jul 12, 2006 2:10 am

Re: how to fix mp3 playback in Iceweasel ?

#9

Post by Eadwine Rose » Thu Jun 11, 2015 1:26 pm

I just tested, and on my browsers (both chrome and iceweasel) the flac thing won't work, everything else works. It states: Cannot actually decode this media.

I downloaded the flac file and it does play in VLC. Maybe that will give someone a hint as to what is missing *shrug* :smile:



Edit: just read Stevo's post, that explains it then.
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19291
Joined: Fri Dec 15, 2006 8:07 pm

Re: how to fix mp3 playback in Iceweasel ?

#10

Post by Stevo » Thu Jun 11, 2015 1:37 pm

Update: It seems the linked thread says it was the gstreamer1.0-plugins-bad package from wheezy-backports that seemed to provide the fix, not the 0.10 stock Wheezy version.

Post Reply

Return to “Sound”