Welcome!

Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-16.1 release info here
  • antiX-17-b1-full release info here
  • antiX-16.2 release info here
New users
  • Please read this first, and don't forget to add system and hardware information to posts!
  • Read Forum Rules

MX14: failed upgrade of adobe flash with Flash Manager

Here users can ask questions about security and tutorials about security can be posted to help others, too.
Message
Author
User avatar
tobin
Posts: 27
Joined: Tue Nov 27, 2007 4:14 pm

MX14: failed upgrade of adobe flash with Flash Manager

#1 Postby tobin » Thu Aug 10, 2017 6:02 pm

Goal: upgrade this MX14 installation to latest flash; help appreciated!

I get "Process finished: Errors have occurred."
with no further explanation, which is unfortunate.

Situation: sse2 capable atom processor, only 1 GB mem.
/etc/debian_version says 7.9
Upgraded from iceweasel 38.4 to firefox 52.2 via synaptic despite
no edit to sources.list (I see a very recent thread on this).
Attempting to upgrade flash. Current version is 11,2,202,616 which
is working.
Tried "upgrade" in Flash Manager (FM) but failed. I did this
with no browser process active. Tried "remove" and this failed too.
I notice that initializing FM (please wait, loading) stage
takes an amazing 3 minutes 40 seconds. There is hard-wired
ethernet connection.

All synaptic packages matching "flash" are up-to-date. I believe
sources.list is stock from when MX14 was installed.

If I could just see the error messages why FM is unhappy,
perhaps I could diagnose myself...

I am using FM because I understand this is the proper way to
administer adobe flash on mx14.

Thanks.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 13055
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX14: failed upgrade of adobe flash with Flash Manager

#2 Postby Stevo » Thu Aug 10, 2017 6:19 pm

It's been deprecated in favor of just installing the adobe-flashplugin package.

User avatar
tobin
Posts: 27
Joined: Tue Nov 27, 2007 4:14 pm

Re: [solved] MX14: failed upgrade of adobe flash with Flash Manager

#3 Postby tobin » Thu Aug 10, 2017 6:59 pm

This worked. Big thanks.

For others following this solution:
I upgraded the mx14 sources.list.d/* with the sed(1) command
of the 20 Jun 2017 posting (summary: switch to mxrepo.com).

Ran synaptic. Refreshed packages. Searched for flash.
Installed adobe-flashplugin (synaptic knew to automatically remove
the old package). I did *not* upgrade mx-flash package to ver 17.1,
as I now understand Flash Manager is deprecated.

Thoughts:
I understood the concept of MX's Flash Manger. Adobe Flash is a unique
piece of software in that is proprietary. And I understood
the feature of auto-update given adobe's frentic version rollouts
(although I wouldn't choose to use that feature).
Yet being outside the normal synaptic install method took
user education (I came to mx from mepis, starting a decade ago).
And now, going back, will take user education yet again. And in general,
I humbly suggest a GUI program reveal the cause of error message
or failure. Then, perhaps, a user can administer self aid!

Again thanks. There are lots of linux distros. There is only one core group
here of helpful folk who assist wayward administrators/users.

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 7367
Age: 42
Joined: Wed Jul 12, 2006 1:42 am

Re: MX14: failed upgrade of adobe flash with Flash Manager

#4 Postby Adrian » Thu Aug 10, 2017 7:21 pm

Thanks for the feedback, I'm the original writer of the mx-flash program, it's a valid point you make, we should probably even remove the mx-flash from MX14 like we did in MX16.1 or just install one that displays a helping message instructing people to install adobe-flashplugin.

I have to say though that although MX14 is still supported and it gets security patches it not a priority for me to write and tweak programs since in the meantime we've had MX15, MX16 and now MX16.1 versions that need my attention. Any reason why you are stuck with MX14 (it's a 3-year old release, I think we did much better since then).

User avatar
tobin
Posts: 27
Joined: Tue Nov 27, 2007 4:14 pm

Re: MX14: failed upgrade of adobe flash with Flash Manager

#5 Postby tobin » Fri Aug 11, 2017 7:57 pm

Hi,
Thanks for support.

> Why stuck with MX14?

I'm trying this machine which has MX14 (installed long ago) just to
see if latest firefox & adobe flash versions fix a web-based photobook
site's issue I observe on my everyday machine which has old flash version.

This machine (MX14 for now) is a wimp. Atom processor 1.6 GHz and
only 1 GiB memory. Firefox is slow. Video doesn't play smoothly.
I'm wondering if antiX would be any better? (i.e. how much difference
does the window manager make) Only using machine temporarily as vehicle
to see if old flash version was my problem.

If you think MX14 is old, you'll like this: my other, everyday machine
is still Mepis! (to support old video card; plus I'm quite fond). I have to have firefox
(version 39) fake-out that it is a later version (45) to make google
happy. Mepis: "it just works."


Return to “Security”

Who is online

Users browsing this forum: No registered users and 1 guest