Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[RISOLTO] VGA 791=deprecato....

Forum italiano degli utenti Mepis
Post Reply
Message
Author
User avatar
massimo
Forum Novice
Forum  Novice
Posts: 37
Joined: Fri Sep 15, 2017 1:12 pm

[RISOLTO] VGA 791=deprecato....

#1 Post by massimo » Mon Sep 10, 2018 4:56 am

Utilizzo antix 17 dall'inizio e l'ho installato da cd nella versione base. Funziona tutto bene e ne sono soddisfatto. Mi sono accorto casualmente che in fase di avvio, per un istante, appare la scritta del titolo. Non rilevo malfunzionamenti ma non ho trovato spiegazioni comprensibili su questo fatto. Soprattutto mi premerebbe sapere se potrebbero sorgere problemi in futuro. Se poi si può eliminare questa scritta rimuovendo le cause in maniera semplice e guidata, bene, sennò me la tengo.
Last edited by massimo on Tue Sep 11, 2018 1:43 am, edited 1 time in total.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2016
Joined: Wed Apr 11, 2018 5:09 pm

Re: VGA 791=deprecato....

#2 Post by fehlix » Mon Sep 10, 2018 10:36 am

Il messaggio che vedete è perché "VGA=" come parametro linux è deprecato.
Usa invece il parametro predefinito di GFX con /etc/default/grub

GRUB_GFXMODE=auto
GRUB_GFXPAYLOAD_LINUX=keep

o impostare manualmente ad un risultato desiderato come questo:
Ecco alcune righe del mio file grub-defaults:

Code: Select all

#( /etc/default/grub):
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

#GRUB_GFXMODE=auto
#GRUB_GFXMODE=1024x768
GRUB_GFXMODE=1280x1024
GRUB_GFXPAYLOAD_LINUX=keep
Per ulteriori informazioni leggi questo:
https://www.gnu.org/software/grub/manua ... mode.html
https://www.gnu.org/software/grub/manua ... fxpayload
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
massimo
Forum Novice
Forum  Novice
Posts: 37
Joined: Fri Sep 15, 2017 1:12 pm

Re: VGA 791=deprecato....

#3 Post by massimo » Mon Sep 10, 2018 10:55 am

Questo è quello che risulta sul mio pc. Come dovrei procedere?

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="vga=791 quiet ipv6.disable=1"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_DISABLE_OS_PROBER=false
GRUB_BACKGROUND=/usr/share/wallpaper/back.jpg

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2016
Joined: Wed Apr 11, 2018 5:09 pm

Re: VGA 791=deprecato....

#4 Post by fehlix » Mon Sep 10, 2018 11:05 am

Il vecchio "VGA=791" corrisponde a "1024x768".
Sopprimere "VGA=791".
e cambiare
GRUB_CMDLINE_LINUX_DEFAULT="vga=791 quiet ipv6.disable=1".
troppo
GRUB_CMDLINE_LINUX_DEFAULT="quiet ipv6.disable=1".

Dan aggiungere:
GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=keep

e generare un nuovo grub-menu con

Code: Select all

sudo update-grub
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
massimo
Forum Novice
Forum  Novice
Posts: 37
Joined: Fri Sep 15, 2017 1:12 pm

Re: VGA 791=deprecato....

#5 Post by massimo » Mon Sep 10, 2018 1:59 pm

Ho seguito le istruzioni. La scritta "anomala" è sparita. Grazie

Post Reply

Return to “Forum Italiano”