Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Dopo il ripristino con lo snapshot la distro non si avvia.

Forum italiano degli utenti Mepis
Message
Author
User avatar
penguin
Forum Regular
Forum Regular
Posts: 274
Joined: Wed Jan 04, 2017 3:15 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#11 Post by penguin » Sun Jan 28, 2018 3:03 am

Grazie Spartak77.
Thank you. I had difficulty to express in correct way :).

Piazolla.Try and Error. Is not difficult.

piazzolla
Forum Novice
Forum  Novice
Posts: 10
Joined: Fri Jan 26, 2018 2:42 am

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#12 Post by piazzolla » Sun Jan 28, 2018 3:51 am

MX LINUX X PROBLEMA SNAPSHOT-RISPOSTA
Scusa, ma vedendo che nessuno rispondeva pensavo che mi aveste abbandonato e questo mi premeva in quanto prima usovo puppy linux e da quando ho scoperto MX linux ho visto che è fatta molto meglio e la traduzione in italiano è ottima. Premesso questo, non vedendo come si fa a rispondere citando cercherò di arrangiarmi come posso.
Una piccola premessa; penguin ha scritto che con la versione 16.1 non ha mai avuto problemi per lo snapshot; ti risulta anche a te? In quanto se fosse così installo questa versione.
Vengo alle tue domande:
tenendo presente tutti i consigli su installare da DVD,
1. piazzolla wrote:
Ho installato da usb live MX17 sulla prima di queste partizioni (sda6) come root. Dopo averla personalizzata, ho fatto lo snapshot e tramite questo (masterizzato su una usb live) ho reinstallato lo snapshot su sda6. Che senso ha ? Cioè, hai fatto l'installazione sul computer, hai fatto la personalizzazione, ne hai ricavato una snapshot e tramite la usb-live hai reinstallato il tuo stesso sistema personalizzato sopra a se stesso in sda6 ? Perchè ?
RISPOSTA: io con windows ho installato windows 7, l'ho personalizzato ed ho creato un'immagine che mi serve in qualsiasi stato di emergenza; se il pc viene ad esempio attaccato da virus o non mi parte più per qualsiasi problema, ripristino windows sulla stessa partizione in cui era installato e risolvo ogni problema.
Stessa cosa vorrei farla con mx 17 usando mx snapshot.
2. piazzolla wrote:
Ho installato da usb live MX17 sulla prima di queste partizioni (sda6) come root.
RISPOSTA: volevo dire solo che durante l'installazione nella schermata appariva la scritta root e non l'ho cambiata. Solo questo.
3. piazzolla wrote:
E poi non ho creato la partizione di swap.
RISPOSTA: il pc è recente ed abbastanza potente.
4. piazzolla wrote: se installo da usb live ORIGINALE MX 17 su sda7 e poi riavvio, mi appaiono tutte le opzioni di grub ed anche la possibilità di avviare SDA6 (che mi si avvia normalmente). Ma fare tutto questo occupa molto tempo.
RISPOSTA: lo so che l'installazione è veloce, ma ho visto che se ad esempio formatto sda7 (la stessa cosa succederebbe se ci faccio un'installazione di un altro sistema operativo sopra) la schermata del grub non mi appare più e mi ritorna quella "delle cinque righe della foto postata" per cui non posso avviare niente.
Ti ringrazio tanto per cercare di risolvere questo mio problema.

piazzolla
Forum Novice
Forum  Novice
Posts: 10
Joined: Fri Jan 26, 2018 2:42 am

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#13 Post by piazzolla » Sun Jan 28, 2018 7:19 am

Credo di aver trovato l'errore; penguin ha detto che nella versione mx 16.1 da lui usata lo snapshot ha sempre funzionato bene. Ho installato la mx 16.1 usando le stesse procedure che avevo usato per la versione 17 e lo snapshot (quindi con il grub2 reinstallato, avendo addiruttura formattato la partizione prima di rifare il ripristino) ha funzionato benissimo.
Deve essere quindi un bug della mx 17.

User avatar
penguin
Forum Regular
Forum Regular
Posts: 274
Joined: Wed Jan 04, 2017 3:15 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#14 Post by penguin » Sun Jan 28, 2018 7:24 am

Hmmm. piazolla.
Oggi io deciso di instalare MX Linux 17. Questione di tempo. In questo momento sto instalando i miei package. Forse provo anche Snapshoot di MX17.Ma .... io uso una altra metoda per ripristinare i miei Linux. Nell mio SSD se hai visto nell post, il mio gpared (io ho ARCH and MX LinuX )- Nell steso laptop io ho anche un altro HDD(montata nel posto di DVD Writter),dove che instalato Sparky Linux ed una altra partizione libera come storage. Per ripristinare il miei Linux io uso qt4-fsarchiver (per rispristinare MX Linux , io avvio Arch Linux, ripristino MX Linux ed salvo i filo di backup nell un partizione(storage) ed faccio versa per Arch Linux).Tu puo usare Pupy Linux per fare questa (che Pupi usi ? Il famoso pupy dell jan-csipesz o Carolina Avanguarde :))- Ok. E facile. Per fare snapshoot/ripristinare - chi servono solo pochi minuti (4 o 5). E posibile di usare anche dd command o gdiskdump (gui del dd command). Io avvio Arch ed uso gdiskdump or dd utility ed per creare iso or image dell MX Linux ed versa per Arch Linux. Da Windows ? E facile. Io uso DriveSnapshot per fare snapshot dell MX Linux or Arch Linux da Windows.E possibile di fare anche snapshoot di Windows Live com DriveSnapshoot. Perche io ho 2 Linux? Prima - Per Provare ed usare, Seconda - Io posso leggere i fili di MX Linux da Arch e versa. Da Windows io uso Paragon Linux File Systems for Windows per vedere e leggere i fili di LInux.E un circo perfetto? Perche io non uso MX Snapshoot? Perche e piu facile per fare snapshoot/backup di un Sistema Linux non aviato ed piu facile di ripristinare. E piu logico di fare backup di MX Linux di chiamo una volta a messe con qt4-archiver or dd-Tute due fanno un coppia identica di MX Linux,anche UUID rimane non taccato(originale). Tu usi MX Snapshoot original. Dicciamo dopo 10 messi, qualcosa succede con MX Linux. Tu ripristerai il MX Linux Snapshoot Originale ed i tutti programi ed altre cose di 10 messi vano via? Come ti ho spiegatto,con dd command or (gdiskdump) o qt4-archiver non ti servono piu di qualche minuti di copiare MX Linux da un disco rigido nel un altro disco rigido(per esempio- da un HDD vechio nel un nuovo SSD...anche se il tuo HDD or SSD muori :-( ! ). Credimi meglio di fare come ti consiglio, piazolla. Mi dispiache, ma io non posso capire perche falische il tuo MX Snapshoot :-( !
Fai una prova come suggerisco io :). Nell tuo USB Boot di MX LInux installa qt4-fsarchiver ( fai persistent per salvare qt4-fsarchiver nell USB).Installa Mx Linux nell sda6 ed fa un backup dell MX Linux con qt4-fsarchiver.Salva i file di backup nell un altro partizione. Ti serve di ripristinare MX Linux ? Avvia Laptop con USB . Lanchia qt4-fsarchiver da USB ed ripristina MX LInux con i file di backup salvato nel partitione storage.Ma tu puoi rispristinare anche nel un altro partitione /non sd6 ma dichiame sda7. Ma fa attenzione! Se Grub non si parte, ripara come ti ho spiegato sopra(nell post precedente). Anche forse che bissognia di cambiare qualcosa ne fstab. Se trovi difficolta.... Avvia Windows ed usi DriveSnapshoot per fare backup di MX Linux.

piazzolla
Forum Novice
Forum  Novice
Posts: 10
Joined: Fri Jan 26, 2018 2:42 am

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#15 Post by piazzolla » Mon Jan 29, 2018 3:24 am

Penguin, sei grande. La soluzione migliore che mi hai suggerito, che conoscevo ma non sapevo potesse funzionare per linux, è DriveShapshoot. Ho provato a fare il backup di mx 16.1 da windows e poi l'ho ripristinato in un minuto e mezzo. Per il boot ho usato la live di mx 16, poi ho avviato MX RIPARA BOOT e tutto funziona alla perfezione. Velocissimo.
Per la versione mx 17 sono convinto che c'è un bug. Snapshot non funziona come ho già scritto.
Posso farti due domande che non riguardano questo argomento (dimmi tu se invece devo porre altri post sul forum!): 1. E' possibile cambiare l'immagine dell'uccello (che non mi piace) che appare all'avvio e subito prima della comparsa del desktop (del quale ho cambiato lo sfondo)?
2. Avendo installato Sylpheed come client di posta elettronica (che mi funziona molto bene) è possibile che si avvii al boot ridotto ad icona (o in background) in modo che mi possa avvisare della nuova posta arrivata (senza avviarlo io manualmente)?
Grazie

User avatar
penguin
Forum Regular
Forum Regular
Posts: 274
Joined: Wed Jan 04, 2017 3:15 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#16 Post by penguin » Mon Jan 29, 2018 5:35 am

In questo momento io sono lontano dall mio Linux Machines.
Per cambiare l'uccello non sono sicuro ma il sfondo si :p !
Nell Lenovo X201i Grub si parte con - Green Background da Calculate Linux
Nell HP 8570w Grub si parte con i due altri.
Per Grub
Semplicisima : usi GrubCustomizer (puo cambiare anche colori dei fonts ) - mi sempre che bisognia installare.

Code: Select all

 https://h20-platform.blogspot.no/2012/10/how-to-change-grub-splash-image.html
Per lightdm manager
Usi LightDM GTK+ Greeter per modificare il sfondo di lighdm (e preinstalato nell MX Linux)
I sfondi nell MX Linux si trovano (/usr/local/share/backgrounds/ ... non posso verificare in questo momento). Per coppiare cose nell cartele di Sistem, serve Sudo Privilege.Fai cosi.Click con i mouse destra nell finestra aperta nell Thunar( per sempio /usr/local/share/backgrounds/) e nell Pop Up Menu trovi > Open Thunar as Root here. Scrivi Password ed ti apre un altra finestra con Sudo Privilege. Incolla i cose ce tu hai copiato nell memoria.Chiudi finestre. Fai molto attenzione di non cancelare i cose, perche sei Sudo ).
Per il Sylpheed :
Vai nell wiskey menu , appri e trovi icona di Sylpheed ed fai click con mouse destro si appre una finetra. Vedi come si parte Sylpheed - nell riga dell command. Copia questa linea ed incolla come entry nell Settings>Startup. Io non use Sylpheed. Che un possibilita nell settings(di Sylpheed), per lanciare Sylpheed minimized? : Avvia Sylpheed > minimized? Se no.
Vedi questi links:

Code: Select all

http://www.murga-linux.com/puppy/viewtopic.php?t=67209&sid=5ff0646c458aa79a6732e00a553902ff
o

Code: Select all

https://bbs.archlinux.org/viewtopic.php?id=55629
o

Code: Select all

https://community.spotify.com/t5/Desktop-Linux/How-autostart-Spotify-minimized-on-Ubuntu/td-p/929219
o

Code: Select all

http://www.webupd8.org/2011/02/how-to-start-applications-minimized.html
o

Code: Select all

https://ubuntuforums.org/showthread.php?t=1619743

Hope it helps.
You do not have the required permissions to view the files attached to this post.

User avatar
Spartak77
Forum Regular
Forum Regular
Posts: 149
Joined: Tue Mar 01, 2011 2:10 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#17 Post by Spartak77 » Mon Jan 29, 2018 6:59 am

Intanto voglio ringraziare Penguin per la competenza, la disponibilità ed anche la bravura nel scrivere in italiano, nonostante non sia la sua lingua madre: si capisce che lo sa parlare bene, nello scrivere c'è qualche piccolo errore ma è tutto perfettamente comprensibile.
Io cerco di intervenire, se posso, nel forum italiano ma non ho le sue competenze e ci sono giorni che non ho la possibilità di accedere al computer, quindi è una fortuna per il forum in lingua italiana poter disporre delle competenze di un utente come Penguin

Comunque anche in questo caso vorrei integrare l'aiuto fornito da Penguin.

1) Per il Wallpaper
C'era stato un altro utente che aveva chiesto delucidazioni in merito, però la spiegazione è nascosta dentro un argomento con un titolo molto diverso, per cui chi ne ha bisogno non si accorge che la spiegazione è nascosta dentro quel tread.
Perciò ne apro ora io uno dandogli un nome riferito a questa domanda e ci copio la spiegazione data in precedenza che è anche abbastanza articolata, prevedendo diverse possibilità.

2) Per Sylpheed
Non aggiungo niente a quanto detto da Penguin, (ho imparato anche io leggendo la sua spiegazione) semplicemente scrivo i percorsi indicati da Penguin come li trovi nel desktop localizzato in italiano.

Apri il Whisker menu (pulsante menu-start) vai in Internet → Sylpeed
Clicchi col destro sopra alla voce “Sylpeed” e scegli dal menu che compare “modifaca applicazione”, qui potrai vedere il comando per avviare il programma, che nel caso specifico è
sylpheed %u

copia questo comando
Poi sempre dal Pulsante-Start del Menu-Whisker vai in Impostazioni →Gestore delle Impostazioni →Sessione e Avvio
Aperto il Tool Sessione e avvio, vai alla scheda Avvio automatico e clicca il pulsante Aggiungi, dove andrai a incollare il comando sylpheed %u

Poi come diceva Penguin, dopo aver aperto il programma Sylpheed vai sulla barra dei menu, in alto, e
vai su Configurazione-> Preferenze comuni poi vai alla scheda Dettagli → scheda Interfaccia
nel quadro che ti si apre metti le spunte sulle voci che riguardano l'icona nella tray, le provi e vedi cosa ti soddisfa.

piazzolla
Forum Novice
Forum  Novice
Posts: 10
Joined: Fri Jan 26, 2018 2:42 am

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#18 Post by piazzolla » Mon Jan 29, 2018 7:58 am

Spartak77
ringrazio naturalmente tanto anche te (non solo penguin) per l'aiuto che mi stai dando. Riguardo Sylpheed ho fatto tutto come mi hai scritto per l'avvio allo startup, ma andando su Configurazione-> Preferenze comuni non riesco a trovare una voce che mi dice: avvio minimizzato ad icona. Sulla distro ho visto che c'è installato Thunderbird il quale ha un plugin che permette questa funzione, ma il problema (ed ho molto cercato su internet) è che non riesco ad inviare email. Poi ho trovato Sylpheed, molto leggero e che ha subito funzionato nell'invio di email. Tu per caso non lo hai mai usato e se si, hai sempre dovuto inviarlo manualmente?
Devo ancora vedere in dettaglio i link che mi ha postato Penguin.
Grazie

User avatar
Spartak77
Forum Regular
Forum Regular
Posts: 149
Joined: Tue Mar 01, 2011 2:10 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#19 Post by Spartak77 » Mon Jan 29, 2018 9:02 am

Io la posta me la vado a vedere direttamente via web perchè voglio controllarla ogni tanto senza esserne assillato, ma ammetto che è un sistema un pò barbaro.
Comunque ho installato Sylpheed per dare un occhiata a cosa non ti funzionava, ma non ho voglia di configurarla del tutto perchè poi non la userei (come Thunderbird).
Ad ogni modo, ho fatto un paio di prove.
Andando su Configurazione-> Preferenze comuni
si apre un quadro con diverse schede, vai alla scheda Dettagli,qui ti si apre un altro quadro con alte schede, vai in Interfaccia
Effettivamente non è presente la voce "avvio minimizzato ad icona", però hai "Mostra l'icona nella Try" e "Minimizza l'icona nella try".
Metti il visto su queste 2 scelte.
Il comando che ti avevo detto di mettere in "Sessione e avvio" delle impostazioni del sistema:
sylpheed %u
potrebbe andare bene perchè ti avvia il programma all'apertura del desktop, però ti si apre completamente ed è un pò una seccatura, allora modificalo così:
sylpheed &
cioè invece di %u ci metti la "e commerciale" che indica di aprire il programma in background.
Forse ci sono altri sistemi più sofisticati per far funzionare un programma in background, io più di tanto non so, comunque vedi se così ti va bene.
Il programma chiaramente va settato a tua misura, ma è un programma che conosci e quindi sai meglio di me come fare.
Ciao

Post Reply

Return to “Forum Italiano”