Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Dopo il ripristino con lo snapshot la distro non si avvia.

Forum italiano degli utenti Mepis
Message
Author
piazzolla
Forum Novice
Forum  Novice
Posts: 10
Joined: Fri Jan 26, 2018 2:42 am

Dopo il ripristino con lo snapshot la distro non si avvia.

#1 Post by piazzolla » Fri Jan 26, 2018 3:04 am

Ho fatto lo snapshot di mx 17. Per ripristinarla (penso che la procedura sia giusta) ho masterizzato la iso su una pendrive. Avviata la pendrive ho installato la Snapshot, ma quando riavvio la distro non mi parte.
Qualcuno sa dirmi da cosa può dipendere?
La scheda madre del pc è UEFI, ma la distro installata dalla iso originale mi parte tranquillamente. Ho provato a lanciare la distro con la iso originale e lanciare: MX RIPARA BOOT, ma niante da fare. Quella installata con la Snapshot non mi parte.
Grazie

User avatar
penguin
Forum Regular
Forum Regular
Posts: 274
Joined: Wed Jan 04, 2017 3:15 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#2 Post by penguin » Fri Jan 26, 2018 7:15 am

Un momento.
Hai scaricato iso o hai fatto snapshot da un runing MX System (un MX gia lanchiato/aviato)?
Dove hai instalato questa snapsho?t ? Nell un altro computer ?

Per forsa qualcosa hai combinata durante MX Snapshot , ma penso che procedura di MX Snapshoot e SAFE ( sicuro )
MX Linux non si avvia?Chi sono mesaggi del errore nell boot o semplice Sistem non avvia - si bloca ?

Scusa - Italiano non il mia madre lingua.
Spero che mi capichi.

piazzolla
Forum Novice
Forum  Novice
Posts: 10
Joined: Fri Jan 26, 2018 2:42 am

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#3 Post by piazzolla » Fri Jan 26, 2018 7:32 am

Ho installato mx linux da live usb su una partizione di windows. Ho personalizzato il sistema. Ho fatto lo snapshot ed ho masterizzato la iso su pendrive. Ho avviato il pc dalla pendrive. Ho installato, quando MX avviato, la mx su una partizione reinstallando quindi anche grub2. Alla fine, quando riavvio il pc mi si aprono 5 righe in inglese dove sembrano dire che ci sono errori in grub.
Grazie

PS: se installo MX originale su un'altra partizione, dal grub posso avviare la partizione in cui ho installato lo snapshot (ma è una cosa molto lunga).

piazzolla
Forum Novice
Forum  Novice
Posts: 10
Joined: Fri Jan 26, 2018 2:42 am

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#4 Post by piazzolla » Fri Jan 26, 2018 7:34 am

Dimenticavo; dopo fatto lo snapshot ho creato un'altra partizione per eventuali altre installazioni. Non so se questo possa essere la causa.
Grazie ancora

User avatar
penguin
Forum Regular
Forum Regular
Posts: 274
Joined: Wed Jan 04, 2017 3:15 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#5 Post by penguin » Fri Jan 26, 2018 8:28 am

Tu dicci ho instalato MX sul Windows Partition.Si consiglia di prepare i partizioni prima di installare MX. Io faccio sepmre cosi. Tu puo creare partitioni da Windows, con Window avviato ( usando Easus, Minipartition etc) or da fuuori Windows. Consigliabile> Avvia Computer con una Boot USB o Hiren Boot CD or un altra BOOT Utility ed crea or modifica i partitioni (senza lanciare nessun OS - Operation System).
Dicciamo. Nel tuo computer tu hai C: (dove instalato Windows). Da Windows o meglio da fuori Windows(come ho spiegata sopra), crea un altra partizione ( puo essere NTFS che tu puo usare come partizione per salvare i dati:canzoni, documenti ed altra). Crea un altro partizione ( dicciamo FAT32 or ext4 - questo e partizionne per instalare MX Linux ). Se preferrichi di avere un altro partizione come Home ( configurazione dell utente per programi di Linux ) fai anche questo. Io uso solo uno partizione per Linux ( root and home nello steso partizione) ad... ultimo un altro partizione di 4GB ( doppio di ram instalato nell tuo computer come Swap).Ma 4GB e abbastanza.
Dicciamo il tuo disc ha 128 GB. Tu puo fare partizione cosi: Partizione dell Windows 45 GB,MX Linux 25 GB,Storage 54 GB ed Swap di 4GB.
Installa MX Linux and durante instalazione scelti.> partizione di MX Linux ( Secondo di 25 GB ) format come ext4 o etx3 o brtfs (io preferisco etx4) ed per swap scelti ultimo di 4GB ... ed procedi avanti.Penso che questa e semplice.
Quanto fai instalazione di MX Linux, installa no quanto MX Linux e avviato perche questa non ha senso (no lo so se tu hai fatto cosi e d se questa e possibile ma penso di no, perche i Linux sto usando il sistem ed files). Sempre avia da MX Boot USB ed installa sopra , come ti ho spiegato.
Io non posso capire il tuoi problemi. Ma forse computer non si riavia perche grub non trova i partizione per avviare MX Linux. Forse quanto tu hai creato un nuovo partizione ha cambiato il nome ( sda1,sda2 etc) grub usa il come percorso il vechio partizione. Se posti qua il messaggi di grub e meglio. Anche....Se instali un altro sistema di Linux o Windows nell un altro partizione, sempre update grub per richonochere i nuovi sistemi nel tuo disco rigido.

Se bisognia riparare grub in una sistema che non parte, tu puo usare il tuo MX USB Live come si spiega nel questo link.

Code: Select all

http://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd
Ed non dimentica . Sempre che un prima volta. Linux e piu di potente. E propia una bestia, ma una buona bestia.

Hope it helps.

User avatar
Spartak77
Forum Regular
Forum Regular
Posts: 149
Joined: Tue Mar 01, 2011 2:10 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#6 Post by Spartak77 » Fri Jan 26, 2018 9:42 am

Ciao Piazzolla,
Alla fine della settimana accuso un po' di stanchezza, perdo in lucidità per cui non so se ho capito bene tutti i passaggi che hai fatto, anche perché MX snapshot l'ho usata più di un anno fa e non mi ricordo con precisione tutto, ma credo che tu abbia fatto uno sbaglio durante l'installazione nella fase in cui stabilisci dove deve essere installato Grub.

Dai un occhiata, se non l'hai già fatto, al manuale in italiano che trovi qui:
https://mxlinux.org/user_manual_mx16/Tr ... aliano.pdf
OK, è quello di MX 16, non è aggiornato alla MX 17 ma non cambia tanto, il processo di installazione è lo stesso.
Eventualmente, per sicurezza, puoi controllare anche il manuale di MX 17 in inglese.
Controlla in particolare la figura 2. 17 a pag 38 del manuale in italiano dove ti spiega le scelte da fare per l'installazione di Grub.
A differenza di quando installi su una USB, quando installi su una partizione del computer, Grub andrà installato su Sda, (supponendo che il tuo computer abbia un disco fisso singolo).
Quindi nel campo "Disco di avvio del sistema" dovrai scegliere SDA.

Comunque prova a riportare il messaggio di errore del computer, che ti riferisce di un errore del grub, quando cerchi di avviare l'installazione che hai fatto su una partizione del tuo computer con la snapshot. Eventualmente fai una foto, che sia leggibile del messaggio.

Se effettivamente si tratta di un errore dell'installazione di Grub, puoi provare a reinstallare o a seguire i consigli che Penguin ti ha dato in precedenza sulla riparazione del Grub (e sull'installazione)

piazzolla
Forum Novice
Forum  Novice
Posts: 10
Joined: Fri Jan 26, 2018 2:42 am

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#7 Post by piazzolla » Sat Jan 27, 2018 4:51 am

Penguin, ho fatto come hai scritto tu. Unica differenza è che, avendo installato windows 7 la partizione sda1 è una piccolissima partizione riservata al sistema e windows è su sda2. E poi non ho creato la partizione di swap. Ho 3 partizioni che mi sono riservato per installare sistemi linux. Ho installato da usb live MX17 sulla prima di queste partizioni (sda6) come root. Dopo averla personalizzata, ho fatto lo snapshot e tramite questo (masterizzato su una usb live) ho reinstallato lo snapshot su sda6. Quando riavvio mi appare la schermata > vedi allegato. Se riavvio MX da live originale e poi faccio: ripara boot (reinstalla Grub su sda (mi indica l'intero disco e sotto sda6) non mi risolve niente. Se ti può servire, se da terminale root scrivo: update-grub, mi appare: /usr/sbin/grub-probe: errore: recupero del percorso canonico di "overlay" non riuscito.
Non mi si apre neanche Grub Customizer; mi appare la scritta: grub.mkconfig non è stato eseguito correttamente. Messaggio di errore: /usr/sbin/grub-probe: errore: recupero del percorso canonico di"overlay» non riuscito. E sotto: Impostazioni ambiente o esci.

Unica cosa; se installo da usb live ORIGINALE MX 17 su sda7 e poi riavvio, mi appaiono tutte le opzioni di grub ed anche la possibilità di avviare SDA6 (che mi si avvia normalmente). Ma fare tutto questo occupa molto tempo.
You do not have the required permissions to view the files attached to this post.

piazzolla
Forum Novice
Forum  Novice
Posts: 10
Joined: Fri Jan 26, 2018 2:42 am

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#8 Post by piazzolla » Sat Jan 27, 2018 4:54 am

Ho usato anche il tool boot repair tool per reinstallare grub2, ma non ho risolto niente.

User avatar
penguin
Forum Regular
Forum Regular
Posts: 274
Joined: Wed Jan 04, 2017 3:15 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#9 Post by penguin » Sat Jan 27, 2018 6:35 pm

Hmmm. Scusa.Io ho visto il tuo post solo in questo momento.
1- Tu hai laptop ? Che tipo ? O PC? Puo postare il tuo inzi -F ?
2- Quanti disci rigidi hai nell tuo computer ? Apri gparted ed fai un screenshot or un foto.Posta qua.
3- Io non capisco una cosa o forse tu non spiegi nell maniera correta.Tu hai un USB Bootable di MX Linux- 32bit or 64 ? Hai instalato corretamento dal tuo USB nel sda6 ( cosi ?). Qundo installer ti chiesta dove e il tuo / , tu scelti sda6 ? OK ? Nel ultimo, installer ti chiede per instalare Grub. Se hai solo in disco diciamo sda > schelti per Grub sda. Cosi Grub si installa nel MBR del tuo disco rigido. Non lo so che tipo ti laptop o computer hai. Ma se tu hai un laptop nuovo, entra nell bios ed trova UEFI (boot section).Scelti per boot ( Legacy + UEFI ) or Legacy Prima.
Domanda ? Tu hai riuchito di instalare MX Linux or No ? Se hai riuchito di instalare, rimouvi USB ed reboot. Nel avvio ti apre GRUB ed con i frecce di keyboard vai su e giu per scegliere MX Linux or Windows.
4- Io non capisco una cosa. Se tu hai instalato MX Linux nel sda6 anche Grub ed installer ti dice Reboot , che cosa fai tu ? Normalmente, laptop si riavia con Grub e si vede i rige di Mx Linux ed Windows (che Grub ha trovato durante processo di instalazione). Tu perche hai fatto snapshot ed reinstalla??? Solo per provare ? Io ancora non ho provato Snapshot dell MX Linux 17 (64 bit ) perche anchora io uso MX Linux 16.1, ed snapshot funziona corretamente. Forse questi giorni trovo il tempo di installare MX Linux 17.

Vedi questo video.

Code: Select all

https://www.youtube.com/watch?v=OFG1H96WuaA
per MX Linux 17

Code: Select all

https://www.youtube.com/watch?v=fnLMbXGkeE0
per Linux 16.1
anche questo

Code: Select all

https://www.youtube.com/watch?v=PA0QGL2d2Zk
anche MX Linux Manuale in italiano.

Code: Select all

https://mxlinux.org/user_manual_mx16/Translations/mxum_italiano.pdf
(pagina 33)

Ma io ti consiglio di preparare i partitioni prima di instalare MX Linux. Credimi. Non e difficile. 2 anni fa io non riuchito di instalare Debian, peche mi creava problemi durante instalazione di Grub.Mi viene da ridere perche con esperienca che ho in questo momento ..... Anche avevo priblemi di instalare Arch, Antergos o un altro Linux- Ma con Calamares anche con MX Linux instaler e molto facile.

Mi spieghi con calma, ti aiuto io ed ti sicuro che riuchirai.

Vedi il mio Gparted. Fa attenzione. Non piu di 4 Primary Partitions. Nel mio SSD. sda1,sda2,sda3 - Partizioni Primari ed sda4 - Partizione Logico.(sda5 ed Swap fanno parte di sda4)
You do not have the required permissions to view the files attached to this post.

User avatar
Spartak77
Forum Regular
Forum Regular
Posts: 149
Joined: Tue Mar 01, 2011 2:10 pm

Re: Dopo il ripristino con lo snapshot la distro non si avvia.

#10 Post by Spartak77 » Sat Jan 27, 2018 7:13 pm

Ciao Piazzolla,ho scritto il mio intervento, e nell'attimo prima di pubblicarlo ho visto che Penguin mi ha preceduto. A questo punto mi scoccia cestinarlo o modificarlo radicalmente perchè ci avevo già perso un pò di tempo a scriverlo.
Molte cose sono ripetitive rispetto a quanto vedo scritto da Penguin, pazienza vuol dire che questo post integra quello di Penguin.

Questo è quanto avevo scritto:

Ci sono alcune cose della tua procedura di installazione che non mi sono chiare.
Normalmente si scarica la ISO della distribuzione da installare ( nel nostro caso MX 17) sul computer e poi si masterizza su un DVD, se l'intenzione è quella di usare la ISO per un installazione sul computer. Si può utilizzare una chiavetta USB ma ad un principiante io consiglierei di usare un DVD per evitare confusione ed errori nell'installazione tra sda, sdb ecc.
La chiavetta USB è invece l'unica possibilità se il computer non ha un lettore CD/DVD.

Ad ogni modo tu hai scelto di usare la chiavetta, va bene anche così se stai attento a non fare errori (ma il lettore CD/DVD lo hai? ).
A questo punto, di solito, se l'intenzione è quella di installare su una partizione, si procede all'installazione con la ISO originale fornita dalla distro. Si controlla che tutto funzioni, (per la verità un controllo va fatto ancora prima dell'installazione in modalità Live, poi si installa e si controlla che tutto funzioni anche dopo l'installazione). Si chiude e si riavvia il sistema. Si fanno tutte le modifiche di personalizzazione del sistema, e a questo punto si fa la Snapshot (con MX Snapshot). Si ricava quindi una ISO personalizzata che potremo installare su una chiavetta (con MX Crea Live USb) che potrebbe farci comodo usare per avere un sistema operativo su un computer non nostro, o per un eventuale ripristino.

Però, ottenuta la ISO con MX Snapshot, io una copia la masterizzerei su un DVD (da usare come DVD_Live istallabile) perché per un ripristino il DVD è più sicuro della Live USB.
Non farei la copia su DVD solo se, oltre alle modifiche, ho installato molti programmi e la ISO che ne è risultata supera i 4,7 GB. di capienza del dvd (oppure se non ho il lettore dvd).
Questo è il modo classico di operare, ma tu dici:
piazzolla wrote:Ho installato da usb live MX17 sulla prima di queste partizioni (sda6) come root. Dopo averla personalizzata, ho fatto lo snapshot e tramite questo (masterizzato su una usb live) ho reinstallato lo snapshot su sda6.
Che senso ha ? Cioè, hai fatto l'installazione sul computer, hai fatto la personalizzazione, ne hai ricavato una snapshot e tramite la usb-live hai reinstallato il tuo stesso sistema personalizzato sopra a se stesso in sda6 ? Perchè ?

Tu dici:
piazzolla wrote: Ho installato da usb live MX17 sulla prima di queste partizioni (sda6) come root.
cosa intendi ?
Si, Ok, per poter istallare è necessario essere root, però attenzione qui potrebbe esserci un errore.
Se per caso tu hai avviato la tua ISO in modalità live e poi mentre eri in Live hai proceduto con l'installazione allora è importante che tu la Live l'hai aperta come utente normale, non come utente root, perché poi avrai problemi di permessi con molti programmi sulla distro installata.
Il fatto che il sistema ti chieda di fornire la password di root per avviare il programma di installazione non vuol dire che devi aprire la live come root, prima di installare, perché si fanno solo guai.

Poi dici
piazzolla wrote:E poi non ho creato la partizione di swap.
uhmm...si ok, questa cosa non ha alcuna implicazione con il problema del grub, e per carità si può fare, sopratutto se si dispone di computer potenti, basta però essere consapevoli che se il computer si ritrova in qualche momento a gestire una mole eccessiva di dati, ti si pianta e non si sblocca, lo devi spegnere e riaccendere, oppure se hai un portatile e chiudi il coperchio poi quando lo riapri non si riprende la sessione, ti si chiude.
Insomma si può fare, ma io non lo farei.

Riguardo la foto, avevi detto:
piazzolla wrote:Alla fine, quando riavvio il pc mi si aprono 5 righe in inglese dove sembrano dire che ci sono errori in grub
però nella foto che hai pubblicato non si vedono queste 5 righe dove viene segnalato il problema di grub.

Alla fine dici
piazzolla wrote:se installo da usb live ORIGINALE MX 17 su sda7 e poi riavvio, mi appaiono tutte le opzioni di grub ed anche la possibilità di avviare SDA6 (che mi si avvia normalmente). Ma fare tutto questo occupa molto tempo.
Scusa, perchè "fare tutto questo occupa molto tempo" ?
Installa la Iso originale su SDA 7 se questa ti installa un Grub funzionante che ti rileva l'installazione che ti interessa su SDA 6. Qual'è il problema? Ci si impiega un attimo ad installare quando sai cosa fare e se non devi fare personalizzazioni. Poi quando ti servirà la partizione SDA 7 per installare qualcos'altro, ci fai l'installazione sopra, e la nuova distro sovrascriverà il suo Grub che in teoria dovrebbe rilevarti anche MX su SDA6.

Scusa per questo lungo intervento, ma davvero ci sono cose poco chiare nella tua procedura di installazione, o forse sono io che, come ti dicevo, alla fine della settimana perdo un pò in elasticità, comunque fammi sapere.

Post Reply

Return to “Forum Italiano”