Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[RISOLTO] Disabilitare automount HD-Partizioni al boot

Forum italiano degli utenti Mepis
Message
Author
balarm
Forum Novice
Forum  Novice
Posts: 96
Joined: Thu Dec 07, 2017 3:15 pm

Re: Disabilitare automount HD-Partizioni al boot

#31 Post by balarm » Wed Nov 07, 2018 2:43 pm

Nothing has changed, anyway i post the output:

Code: Select all

mx17@mx:~
$ cat /etc/udev/rules.d/10-fix-esata.rules
# udsiks2 rule for mark esata device for not-automounting and non-removable
#
# /dev/sda
DEVPATH=="/devices/pci0000:00/0000:00:05.0/ata1/host0/*", ENV{UDISKS_AUTO}="0", ENV{UDISKS_SYSTEM}="1"
# /dev/sdb
DEVPATH=="/devices/pci0000:00/0000:00:05.0/ata2/host1/*", ENV{UDISKS_AUTO}="0", ENV{UDISKS_SYSTEM}="1"
mx1 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine: Device: laptop System: LENOVO product: 1951A47 v: ThinkPad T60

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2030
Joined: Wed Apr 11, 2018 5:09 pm

Re: Disabilitare automount HD-Partizioni al boot

#32 Post by fehlix » Wed Nov 07, 2018 3:15 pm

balarm wrote:
Wed Nov 07, 2018 2:43 pm
Nothing has changed, anyway i post the output:
So you rebooted and all your internal partitions are still automounted?
No saved session involved? No automounts manually enabled? Thunar automounts disabled?
No other app installed which do those mounts?
When unmount from Thunar and remount again, will you get asked for a password?
Hmme ... I need to take some holidays in Italy, I think ;=)
:cat:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

balarm
Forum Novice
Forum  Novice
Posts: 96
Joined: Thu Dec 07, 2017 3:15 pm

Re: Disabilitare automount HD-Partizioni al boot

#33 Post by balarm » Wed Nov 07, 2018 5:01 pm

fehlix wrote:
Wed Nov 07, 2018 3:15 pm
So you rebooted and all your internal partitions are still automounted?
No saved session involved? No automounts manually enabled? Thunar automounts disabled?
No other app installed which do those mounts?
When unmount from Thunar and remount again, will you get asked for a password?
Hmme ... I need to take some holidays in Italy, I think ;=)
:cat:
Yes, I rebooted and internal partitions/drives are still automounted.
No automounts manually enabled. Installed gnome-disk but it doesn't operate.
Thunar automunt disabled and when I unmount no any passwd requested.
I'll have to check the if saved session is involved.
I can add that the symbol related to partitions-drive is USB icons and no HD; I'll take a screen.
Good occasion/idea to take some holidays in Italy; what about Sicily??? Nice weather, good food, beautiful places and so on. Come on, you'll be welcome. :popcorn:
mx1 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine: Device: laptop System: LENOVO product: 1951A47 v: ThinkPad T60

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2030
Joined: Wed Apr 11, 2018 5:09 pm

Re: Disabilitare automount HD-Partizioni al boot

#34 Post by fehlix » Wed Nov 07, 2018 5:55 pm

I'll check my other Dsktop which also have some similar esata type of mothebord.

Could you post the output of this command:

Code: Select all

sudo ls -al /etc/polkit-1/localauthority/50-local.d/
balarm wrote:
Wed Nov 07, 2018 5:01 pm
to take some holidays in Italy; what about Sicily??? Nice weather, good food, beautiful places ...
I love Italy :needcoffee:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

balarm
Forum Novice
Forum  Novice
Posts: 96
Joined: Thu Dec 07, 2017 3:15 pm

Re: Disabilitare automount HD-Partizioni al boot

#35 Post by balarm » Wed Nov 07, 2018 6:12 pm

Yes of course.
Out of this topic; I use a DVB-T device to watch tv and I had to modify the /etc/initramfs-tool modules file adding some string since the kernel didn't charge the modules at boot; in fact I had to disconnect and connect the device without the strings added. I don't know if this can help.
mx1 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine: Device: laptop System: LENOVO product: 1951A47 v: ThinkPad T60

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2030
Joined: Wed Apr 11, 2018 5:09 pm

Re: Disabilitare automount HD-Partizioni al boot

#36 Post by fehlix » Wed Nov 07, 2018 6:30 pm

balarm wrote:
Wed Nov 07, 2018 6:12 pm
Out of this topic; I use a DVB-T device to watch tv and I had to modify the /etc/initramfs-tool modules file adding some string since the kernel didn't charge the modules at boot; in fact I had to disconnect and connect the device without the strings added. I don't know if this can help.
Can't hurt if you show yout DVB-T adjustments, perhaps also for others howto setup DVB-T...
Well, I stopped using DVB-T as the introduced here DVB-T2, which is a nightmare on linux to get running.
Hmm... anything else you can think of having installed ? E.g. any additonal filemanger installed? spacefm, nemo, caja ...
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

balarm
Forum Novice
Forum  Novice
Posts: 96
Joined: Thu Dec 07, 2017 3:15 pm

Re: Disabilitare automount HD-Partizioni al boot

#37 Post by balarm » Wed Nov 07, 2018 6:53 pm

There's already a Post here about the DVB-T device solution viewtopic.php?f=107&t=43910&p=436303#p436303 but i forget to add the module changes; sure I' 'll add.
I have also installed Polo (from a link posted here,in this forum I mean) and caja (from the mx-package installer) filemanager too, the same installed in my thinkpad.
Good night, my eyes are burning and ask to relax.
mx1 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine: Device: laptop System: LENOVO product: 1951A47 v: ThinkPad T60

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2030
Joined: Wed Apr 11, 2018 5:09 pm

Re: Disabilitare automount HD-Partizioni al boot

#38 Post by fehlix » Wed Nov 07, 2018 8:19 pm

balarm wrote:
Wed Nov 07, 2018 6:53 pm
I have also installed Polo (from a link posted here,in this forum I mean) and caja (from the mx-package installer) filemanager too, the same installed in my thinkpad.
As Caja does also watches out for removable media and handles "automount" you shall better disable this within Caja also, in additon to disable Thunar's own automount.
Open Caja -> Menu
-> Edit -> Preferences
[X] Media -> Never prompt or start programs on media insertion
[ ] Browse media when inserted
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

balarm
Forum Novice
Forum  Novice
Posts: 96
Joined: Thu Dec 07, 2017 3:15 pm

Re: Disabilitare automount HD-Partizioni al boot

#39 Post by balarm » Thu Nov 08, 2018 1:44 pm

Good evening, here the output

Code: Select all

mx17@mx:~
$ sudo ls -al /etc/polkit-1/localauthority/50-local.d/
[sudo] password di mx17: 
totale 8
drwxr-xr-x 2 root root 4096 mag 24  2017 .
drwx------ 7 root root 4096 dic 13  2017 ..
caja was already set as you suggested.
mx1 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15, 2017
Machine: Device: laptop System: LENOVO product: 1951A47 v: ThinkPad T60

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2030
Joined: Wed Apr 11, 2018 5:09 pm

Re: Disabilitare automount HD-Partizioni al boot

#40 Post by fehlix » Thu Nov 08, 2018 4:49 pm

balarm wrote:
Thu Nov 08, 2018 1:44 pm

Code: Select all

mx17@mx:~
$ sudo ls -al /etc/polkit-1/localauthority/50-local.d/
[sudo] password di mx17: 
totale 8
drwxr-xr-x 2 root root 4096 mag 24  2017 .
drwx------ 7 root root 4096 dic 13  2017 ..
caja was already set as you suggested.
Look's like we are back with gnome-disk-utility.
I don't assume you have setup automount with polo-filemanger.
Before you use gnome-disk-utility,
do open MX Tweak -> Other -> Allow normal user to mount drives.
This shall allow mounting manualy passwordless.
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Forum Italiano”