Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX-18 boote nicht an ASUS - "Sie müssen zuerst einen Kernel laden"

loik
Forum Novice
Forum  Novice
Posts: 86
Joined: Wed Dec 12, 2018 3:01 pm

Re: MX-18 boote nicht an ASUS - "Sie müssen zuerst einen Kernel laden"

#11

Post by loik » Sun May 19, 2019 11:24 am

O.K. danke für deine Hilfe.

Also, dass mit dem Wenigen USB-Strom könnte natürlich sein.
Aber um BunsenLabs zu booten braucht es ja auch strom.

Hier ist sowieso fast alles USB-2. vor allem, an dem alten ASUS.
Trotzdem laufen die Systeme gut, wenn sie erstmal gebootet sind.
Denkt man nicht, aber ist so.

Den Grub für MX, welches sich auf der externen Platte befindet, auf die Interne Platte des ASUS kopieren mag gehen, aber gefällt mir als Lösung nicht.Vielleicht erwäge ich es mal als Test. mal schaun.
Wenn du aber gemeint hast, den Grub von BL auf der externen Platte mit dem von MX zu überschreiben, dann ist das schon noch eine Option.


Aber, ich verstehe nicht, warum ausgerechnet an den beiden ASUS Grub no such device meint, aber beim booten an anderen Rechnern MX problemlos gefunden und gebootet wird.

Das soll am Strom liegen ?, wenn doch gleichzeitig BL fähig ist zu booten ?

Hmm ...

loik
Forum Novice
Forum  Novice
Posts: 86
Joined: Wed Dec 12, 2018 3:01 pm

Re: MX-18 boote nicht an ASUS - "Sie müssen zuerst einen Kernel laden"

#12

Post by loik » Sun May 19, 2019 11:58 am

o.k.
was für deine Vermutung spricht, ist folgendes.
Ich habe noch eine Weiter Externe Multiboot-Platte.
Da sind 11 Systeme drauf.
alle lassen sich prima boote.
Nur eben nicht an den beiden ASUS-Rechnern.
Da gibt es aber keine Fehlermeldung.
Der Rechner geht direkt in den Reboot, nach dem ich eines der Systeme ausgewählt habe.
Außer beim 1. System auf der Platte, welches den Grub stellt.

Ich habe versucht einen aktiven USB-Hub dazwischen zu hängen.
Immerhin, die Platte wurde erkannt und Grub wurde geladen.
Auch das "Main-System" ließ sich so wie gewohnt booten.
Die anderen Systeme aber trotzdem nicht.

Ich werde einen Y-Adapter besorgen und es nochmals versuchen.
( Verstehen tue ich diese Strommimosität aber überhaupt nicht )

Melde mich dann.

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 4046
Joined: Wed Apr 11, 2018 5:09 pm

Re: MX-18 boote nicht an ASUS - "Sie müssen zuerst einen Kernel laden"

#13

Post by fehlix » Sun May 19, 2019 12:12 pm

loik wrote:
Sun May 19, 2019 11:24 am
Wenn du aber gemeint hast, den Grub von BL auf der externen Platte mit dem von MX zu überschreiben, dann ist das schon noch eine Option.
So war das gedacht, statt Bunse-GRUB den MX-GRUB vom MBR starten , kannst das ja wieder zurückdrehen,
da Du ja vom MX Grub Menu auch wieder nach Bunsen wechslen kannst.
PS: Falls Du nur USB2 hast, ist das definitiv zuwenig für eine extern Platte.
USB2 lievert ca. max 0.5A und die Platte braucht manchmal bis zu 1A, daher ein zusätzliche Stromleitung angeraten.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

loik
Forum Novice
Forum  Novice
Posts: 86
Joined: Wed Dec 12, 2018 3:01 pm

Re: MX-18 boote nicht an ASUS - "Sie müssen zuerst einen Kernel laden"

#14

Post by loik » Fri Jun 07, 2019 2:32 am

Moin.
Ich war die letzten Wochen anderweitig beschäftigt, deshalb diese späte Rückmeldung.

habe jetzt einen Y-Adapter besorgt.
Hat nix geholfen.
Hatte ihn angeschlossen, sowohl über "beide Stecker in den USB-Ports" als auch das Strom-Zusatzkabel extra an ein Ladegerät ( 2A ).

Es hat nix geändert.

Den Grub wechseln habe ich nicht versucht.
Ich bin sicher, das es gehen würde.
Aber nur, das dann MX gebootet würde und BunsenLabs nicht.

Davon gehe ich aus, weil ja auf meiner andern 2 TB Platte das gleiche Problem besteht.
Es wird nur das System gebootet, welches den Main-Grub stellt. Die anderen Systeme weden einfach übersehen.

Den Grub um stellen durch Neuinstallation bringt mir da wenig, weil es sich um Multiboot-Platten handelt und ich gerne möchte, das alle Systeme bootbar sind.

So ist es auch an allen anderen PC und Notebooks, die mir hier zur Verfügung stehen ( etwa 10 Stück, 2004 bis 2018 ), nur an diesen beiden ASUS-Geräten klappt es nicht.
Es ist also kein MX-Fehler, das Problem liegt bei ASUS.
Damit könnte ich das Thema auf [GELÖST] setzen, aber ich hoffe, dass es doch noch einen erfolgreichen Tip geben wird, wie diese ASUS-Rechner multibootbar werden.

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 4046
Joined: Wed Apr 11, 2018 5:09 pm

Re: MX-18 boote nicht an ASUS - "Sie müssen zuerst einen Kernel laden"

#15

Post by fehlix » Fri Jun 07, 2019 1:24 pm

loik wrote:
Fri Jun 07, 2019 2:32 am
... dass es doch noch einen erfolgreichen Tip geben wird, wie diese ASUS-Rechner multibootbar werden.
Um nicht gleich dem Bunsen-GRUB die Schuld in die Schuhe zu schieben, versuch doch mal mit dem "Boot Rescue Menu", die verschiedenen Systeme, die auf der externen Festplatte installiert sind, zu booten. Das "Boot Rescue Menu" findest Du auf der antiX-19a..iso.Es ist so gebaut, dass es die verschiedenen Grub-Loader und auch die verschiedenen Grub-Menüs auf der Platte sucht, und daraus ein Boot Menü generiert.
"Boot Rescue Menu" dann unter -> "Switch to Grub loader"
Würde mich zumindest sehr interessieren, ob es damit besser gehen würde.

Falls das auch versagt, versuche auch mal von USB2 zustarten.
Dann würde ich auch noch schauen, ob es da irgendwas besonderes im System BIOS gibt... AHCI, RAID etc...
Ach so antiX Iso's mit neuestem "Boot Rescue Menu" findest du hier:
https://sourceforge.net/projects/antix- ... s/Testing/
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

loik
Forum Novice
Forum  Novice
Posts: 86
Joined: Wed Dec 12, 2018 3:01 pm

Re: MX-18 boote nicht an ASUS - "Sie müssen zuerst einen Kernel laden"

#16

Post by loik » Mon Jun 10, 2019 8:17 am

Danke, Felix.

Zur Zeit kann ich da leider meinen eigenen Interessen nicht Folgen.
Andere Dinge sind grad wichtiger.
Ich muß deinen Tip auf die lange Bank schieben.

Ich denke nicht, dass es am BL-Grub liegt.
Da es ja an "allen" anderen Rechnern Funktioniert.

Die zweite Multibootplatte hat ein ML-17-3-Grub.
Und auch hier nur Probleme an den ASUS.
Auf beiden Platten ist nur beim Grub stellenden Hauptsystem "OS-Prober" aktiviert.
Bei den nachrangigen Systemen ist es Deaktiviert, weil Grub sich sonst so mit Informations-Schleifen vollsaugt, dass es es irgendwann bis zu einer halben Stunde dauern kann, bis Grub überhaupt geladen ist und mir die Systeme zur Auswahl anbietet.

Aber das ausgeschaltetet OS-Prober kann es ja auch nicht sein, weil nun mal an Anderen Rechnern kein problem ist die nachrangigen Systeme auf den Platten zu booten.

Dem BIOS die Schuld zu geben scheint mir am naheliegensten.
Mit dem BIOS vom eeepc muß ich mich nochmal bechäftigen.

Das vom F5RL ist aber sehr spartanisch ( 2008 ) da is sowas wie AHCI gar nicht aufgelistet.

Jedenfalls ist das alles ne Menge Try and Error. Da fehlt mir im Moment die Zeit und die Muse.
Komme vielleicht erst im Herbst dazu, mich wieder damit zu befassen.

Gruß
Loik

Post Reply

Return to “Deutsches Forum”