Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

solved - mkvtoolnixgui and mkvtoolnix upgrade

User avatar
Stevo
Developer
Posts: 19875
Joined: Fri Dec 15, 2006 8:07 pm

Re: [sorted] mkvtoolnixgui and mkvtoolnix upgrade?

#11

Post by Stevo » Tue Jul 17, 2018 5:54 pm

Eadwine Rose wrote:
Tue Jul 17, 2018 4:24 pm
Stevo wrote:
Tue Jul 17, 2018 4:17 pm
Looks like Christian forgot to remove the -dmo (deb-multimedia branding) when he did the Stretch version... https://packages.debian.org/stretch/mkvtoolnix-gui
Ah is that what went wrong on my upgrade then. It's sorted though. And indeed deb multimedia.. I forgot to check that one.
You didn't get it from deb-multimedia, if that's what you mean. The Stretch version in the regular Debian repo still has the deb-multimedia dmo branding--that's what threw me at first, too.

I had to backport libmatroska, libebml, and libcmark versions from upstream before launching the mkvtoolnix builds, but using pbuilder makes that a lot quicker. Mkvtoolnix is a reasonably heavy build, which is nice to let the new powerful laptop get something to make it work hard today. :happy: So it'll pull in those updated libraries from the test repo when it gets installed.

User avatar
Eadwine Rose
Administrator
Posts: 8960
Joined: Wed Jul 12, 2006 2:10 am

Re: [sorted] mkvtoolnixgui and mkvtoolnix upgrade?

#12

Post by Eadwine Rose » Wed Jul 18, 2018 2:19 am

Thanks Stevo! Will it also upgrade over what I have just installed? *chuckle*


edit, it does:

Code: Select all

libebml4v5 (version 1.3.4-1) will be upgraded to version 1.3.6-2~mx17+1
mkvtoolnix (version 25.0.0-0~bunkus01) will be upgraded to version 25.0.0-1~mx17+1
mkvtoolnix-gui (version 25.0.0-0~bunkus01) will be upgraded to version 25.0.0-1~mx17+1
libcmark0 (version 0.28.3-1~mx17+1) will be installed

Another edit: it won't start anymore:

Code: Select all

$ mkvtoolnix-gui
mkvtoolnix-gui: symbol lookup error: mkvtoolnix-gui: undefined symbol: _ZN11libmatroska22KaxVideoProjectionType10ClassInfosE
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
Stevo
Developer
Posts: 19875
Joined: Fri Dec 15, 2006 8:07 pm

Re: Issue with test repo - mkvtoolnixgui and mkvtoolnix upgrade

#13

Post by Stevo » Wed Jul 18, 2018 1:35 pm

It doesn't look like you updated libmatroska6v5, which the error is coming from, so I think you still have the one from the other repo installed, and it's versioned higher. The simplest way I can think of to fix it is to uninstall libmatroska6v5, which will also remove mkvtoolnix packages, then reinstall mkvtoolnix* from the test repo without the outside repo being enabled.

User avatar
Eadwine Rose
Administrator
Posts: 8960
Joined: Wed Jul 12, 2006 2:10 am

Re: Issue with test repo - mkvtoolnixgui and mkvtoolnix upgrade

#14

Post by Eadwine Rose » Wed Jul 18, 2018 2:28 pm

Fixed :) it removed VLC so I had to install that back after I was done, but both programs are now fixed again :) Thanks!!
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

Post Reply

Return to “Package Requests/Status - MX 17/18”