Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Yarock

Post Reply
Message
Author
User avatar
wulf
Forum Regular
Forum Regular
Posts: 127
Joined: Mon Jan 22, 2018 9:56 am

Yarock

#1 Post by wulf » Wed Jul 04, 2018 7:08 pm

Is there any possibility of building Yarock audio player for the test repo again please?..I noticed it was in there in 2016, but I can't find it now. Thanks..
https://seb-apps.github.io/yarock/install.html

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4480
Joined: Wed Jul 12, 2006 4:05 pm

Re: Yarock

#2 Post by timkb4cq » Wed Jul 04, 2018 7:35 pm

It's in the main repo for MX-15/16 but we neglected to build it for MX-17.
I'll look at it tonight.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
wulf
Forum Regular
Forum Regular
Posts: 127
Joined: Mon Jan 22, 2018 9:56 am

Re: Yarock

#3 Post by wulf » Wed Jul 04, 2018 7:53 pm

timkb4cq wrote:
Wed Jul 04, 2018 7:35 pm
It's in the main repo for MX-15/16 but we neglected to build it for MX-17.
I'll look at it tonight.
Much obliged, thank you Tim.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4480
Joined: Wed Jul 12, 2006 4:05 pm

Re: Yarock

#4 Post by timkb4cq » Thu Jul 05, 2018 11:36 am

Took longer than I thought to get the dependencies right for the new Qt5 version, but Yarock 1.3.1 is now up in the MX-17 Test repository.
It is able to use all three backends: vlc, mpv, phonon/gstreamer but you may need to install the phonon4qt5-backend-vlc package for vlc as it doesn't force that to be installed.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
wulf
Forum Regular
Forum Regular
Posts: 127
Joined: Mon Jan 22, 2018 9:56 am

Re: Yarock

#5 Post by wulf » Thu Jul 05, 2018 2:25 pm

timkb4cq wrote:
Thu Jul 05, 2018 11:36 am
Took longer than I thought to get the dependencies right for the new Qt5 version, but Yarock 1.3.1 is now up in the MX-17 Test repository.
It is able to use all three backends: vlc, mpv, phonon/gstreamer but you may need to install the phonon4qt5-backend-vlc package for vlc as it doesn't force that to be installed.
I chose phonon and it Installs and runs without a hitch. Thank you very much for your time and effort to put this up.
Oops, I forgot to mention, it does indeed require install of the phonon4qt5-backend-vlc package for vlc, and as before, it all works perfectly..

Post Reply

Return to “Package Requests/Status - MX 17”