Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Package Request: xfce4-appmenu-plugin (Global Menu) & mate-hud

Post Reply
Message
Author
Alt
Forum Novice
Forum  Novice
Posts: 73
Joined: Wed Jan 27, 2016 1:28 am

Package Request: xfce4-appmenu-plugin (Global Menu) & mate-hud

#1 Post by Alt » Sun Jul 01, 2018 11:11 am

It became noticeable with WebUpd8 article Alternative Global Menu For MATE And Xfce, then Unity discontinued and Martin Wimpress (Ubuntu MATE lead developer) started to push Unity features into Ubuntu MATE. He & rilian-la-te worked on seperation from Unity and pushing it to Ubuntu & Debian (package in Buster repo).

Image

It works just fine on xUbuntu 18.04

Code: Select all

sudo apt install -y xfce4-appmenu-plugin
xfconf-query -c xsettings -p /Gtk/ShellShowsMenubar -n -t bool -s true
xfconf-query -c xsettings -p /Gtk/ShellShowsAppmenu -n -t bool -s true
----
MATE-HUD is an i3-hud-menu fork developed for Ubuntu MATE
Github page, Bitbucket page for Debian packagin.

Image

It's not in Debian (yet?), have few problems but works for me after some manipulations

Code: Select all

sudo apt install -y mate-hud
bash -c '/usr/lib/mate-hud/mate-hud'
Default shortcut is Alt_L which creates problems (Alt+F2 doesn't work for example). But hey, let's change it!

Code: Select all

sudo apt install -y dconf-editor
dconf-editor
/org/mate/hud/shortcut
Custom value: <Super>Alt_L
If everything alright just make custom shortcut for

Code: Select all

bash -c '/usr/lib/mate-hud/mate-hud'
at "XFCE Settings > Session and Startup > Application Autostart"

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4264
Joined: Wed Jul 12, 2006 4:05 pm

Re: Package Request: xfce4-appmenu-plugin (Global Menu) & mate-hud

#2 Post by timkb4cq » Sun Jul 01, 2018 1:23 pm

xfce4-appmenu-plugin requires vala-panel from buster and building vala-panel on stretch runs into a libglib2.0.0 bug. I'm not a very good C programmer so I don't see the way to work around it, though I don't doubt there is one.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: Package Request: xfce4-appmenu-plugin (Global Menu) & mate-hud

#3 Post by Stevo » Sun Jul 01, 2018 4:50 pm

We have a newer libglib2.0.0 in the test repo for gimp-2.10, along with a newer valac for some other backport, so adding the test repo to my pbuilder environments resulted in successful builds. I haven't installed and tested the packages yet, though: https://drive.google.com/open?id=11bCKW ... SHc5Ilzszn

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: Package Request: xfce4-appmenu-plugin (Global Menu) & mate-hud

#4 Post by Stevo » Tue Jul 03, 2018 2:37 pm

xfce4-appmenu-plugin is now in the test repo for testing.

TauTsar
Forum Novice
Forum  Novice
Posts: 27
Joined: Thu Jun 21, 2018 4:49 am

Re: Package Request: xfce4-appmenu-plugin (Global Menu) & mate-hud

#5 Post by TauTsar » Mon Jul 09, 2018 9:22 pm

Just installed this. It's great!

Post Reply

Return to “Package Requests/Status - MX 17”