Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 17 Repository: The GIMP Thread

Message
Author
User avatar
junagu
Forum Novice
Forum  Novice
Posts: 4
Joined: Sat Jul 07, 2018 7:21 am

Re: MX 17 Repository: The GIMP Thread

#51 Post by junagu » Sat Jul 07, 2018 8:53 am

I tried it from the testing repo but still no joy. :noway:

I have managed to get it to run by installing and running it through flatpak but it doesn't load the libgegl there either.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The GIMP Thread

#52 Post by Stevo » Sat Jul 07, 2018 12:58 pm

Is the error occurring right off, or later on when you attempt some operation?

Also, can you tell us the result of

Code: Select all

apt policy libgegl-0.4-0

User avatar
PondLife
Forum Novice
Forum  Novice
Posts: 17
Joined: Wed May 09, 2018 12:24 pm

Re: MX 17 Repository: The GIMP Thread

#53 Post by PondLife » Sun Jul 08, 2018 7:02 am

Found some time to upgrade and try out, all looks to be in working order.

2.10.2 to 2.10.4 through MX Package Installer.
MX-17.1_x64 | i3-4360T | 4GB RAM | Samsung 250GB SSD

User avatar
junagu
Forum Novice
Forum  Novice
Posts: 4
Joined: Sat Jul 07, 2018 7:21 am

Re: MX 17 Repository: The GIMP Thread

#54 Post by junagu » Sun Jul 08, 2018 4:30 pm

It's as soon as I try and run the program.

output from the command

Code: Select all

apt policy libgegl-0.4-0 
is:

Code: Select all

libgegl-0.4-0:
  Installed: 0.4.4-0.1~mx17+1
  Candidate: 0.4.4-0.1~mx17+1
  Version table:
 *** 0.4.4-0.1~mx17+1 500
        500 http://nl.mxrepo.com/mx/testrepo stretch/test amd64 Packages
        100 /var/lib/dpkg/status
     0.4.2-1 500
        500 http://http.us.debian.org/debian testing/main amd64 Packages
:tumbleweed:

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The GIMP Thread

#55 Post by Stevo » Sun Jul 08, 2018 4:35 pm

junagu wrote:
Sun Jul 08, 2018 4:30 pm
It's as soon as I try and run the program.

output from the command

Code: Select all

apt policy libgegl-0.4-0 
is:

Code: Select all

libgegl-0.4-0:
  Installed: 0.4.4-0.1~mx17+1
  Candidate: 0.4.4-0.1~mx17+1
  Version table:
 *** 0.4.4-0.1~mx17+1 500
        500 http://nl.mxrepo.com/mx/testrepo stretch/test amd64 Packages
        100 /var/lib/dpkg/status
     0.4.2-1 500
        500 http://http.us.debian.org/debian testing/main amd64 Packages
Why do you have debian testing (Buster) instead of Stretch repositories?

Didn't you think this would have any relevance to your problem at all?

User avatar
junagu
Forum Novice
Forum  Novice
Posts: 4
Joined: Sat Jul 07, 2018 7:21 am

Re: MX 17 Repository: The GIMP Thread

#56 Post by junagu » Mon Jul 09, 2018 3:13 am

I suspected it might. :footinmouth:

To be sort of fair my repo list has been a bit messy for one reason or another.

There's no easy way of tidying things up other than a reinstall from this point on is there.

Saying that gimp is the only thing that is suffering atm.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The GIMP Thread

#57 Post by Stevo » Mon Jul 09, 2018 8:10 pm

junagu wrote:
Mon Jul 09, 2018 3:13 am
I suspected it might. :footinmouth:

To be sort of fair my repo list has been a bit messy for one reason or another.

There's no easy way of tidying things up other than a reinstall from this point on is there.

Saying that gimp is the only thing that is suffering atm.
Probably a reinstall is the best way to make sure your system is sane. Luckily, saving home and the speed of the install from a USB drive makes it relatively painless.

Post Reply

Return to “Package Requests/Status - MX 17”