Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Cannot find packages in newly installed MX17 [SOLVED]

Message
Author
User avatar
aToloza
Forum Novice
Forum  Novice
Posts: 4
Joined: Wed Apr 11, 2018 5:31 pm

Cannot find packages in newly installed MX17 [SOLVED]

#1 Post by aToloza » Wed Apr 11, 2018 5:45 pm

I am running a Sony Vaio laptop 4.15.0-1-amd64 #1 SMP Debian 4.15.4-1~mx17+1 (2018-02-23) x86_64 GNU/Linux.

I just installed MX17 and used synaptic to an update of packages. After that, I set out to look for the package 'texlive', because I need to work with LaTeX, but I cannot find it. I have checked the list of repositories for MX17:

https://mxlinux.org/wiki/system/repos-mx-17

And I copied all the same lines to my relevant .list files. Still, I seem to have a considerably incomplete list of software to my disposition through synaptic.

Suggestions are appreciated. Thanks in advance.
Last edited by aToloza on Thu Apr 19, 2018 6:38 am, edited 1 time in total.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22453
Joined: Wed Jul 19, 2006 6:13 am

Re: Cannot find packages in newly installed MX17

#2 Post by Jerry3904 » Wed Apr 11, 2018 5:53 pm

It's there:

Code: Select all

$ apt policy texlive
texlive:
  Installed: (none)
  Candidate: 2016.20170123-5
  Version table:
     2016.20170123-5 500
        500 http://ftp.us.debian.org/debian stretch/main amd64 Packages
        500 http://ftp.us.debian.org/debian stretch/main i386 Packages
Did you reload synaptic?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
radissthor
Forum Regular
Forum Regular
Posts: 339
Joined: Mon Sep 13, 2010 11:18 am

Re: Cannot find packages in newly installed MX17

#3 Post by radissthor » Wed Apr 11, 2018 6:27 pm

Hi. I am a friend of aToloza, helping him with his new MX install. I can say that yes, he did. He did reload.
Image

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22453
Joined: Wed Jul 19, 2006 6:13 am

Re: Cannot find packages in newly installed MX17

#4 Post by Jerry3904 » Wed Apr 11, 2018 6:34 pm

He should try a command:

Code: Select all

sudo apt install texlive
If that doesn't work, then we should see his repos:

Code: Select all

inxi -r
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2032
Joined: Mon Nov 21, 2011 5:50 pm

Re: Cannot find packages in newly installed MX17

#5 Post by Gordon Cooper » Wed Apr 11, 2018 9:25 pm

Been using Lyx for a few years and found that installation of Lyx package brings in texcommon but not texlive. Have to use synaptic to get several of the tex* packages and expect that latex would be the same. Perhaps there is a repo missing in Toloza's. I have these active:

gordon@gordondesktop:~
$ inxi -r
Repos:
Active apt repos in: /etc/apt/sources.list.d/antix.list
1: deb http://antix.daveserver.info/stretch stretch main
Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
1: deb http://ftp.nz.debian.org/debian/ stretch-updates main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/debian.list
1: deb http://ftp.nz.debian.org/debian/ stretch main contrib non-free
2: deb http://security.debian.org/ stretch/updates main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/mx.list
1: deb http://mxrepo.com/mx/repo/ stretch main non-free
No active apt repos in: /etc/apt/sources.list.d/various.list
~
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16286
Joined: Fri Dec 15, 2006 8:07 pm

Re: Cannot find packages in newly installed MX17

#6 Post by Stevo » Wed Apr 11, 2018 9:32 pm

It's in the main Debian repos, so should not be having any of our known dead MX mirror problems. So it has to be something with the Debian repo list, not the MX ones.

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2032
Joined: Mon Nov 21, 2011 5:50 pm

Re: Cannot find packages in newly installed MX17

#7 Post by Gordon Cooper » Wed Apr 11, 2018 11:50 pm

Don't know about Latex, but for Lyx (which is a front end for Latex) the Lyx dependency automatic download list has several vacancies that have to be selected and downloaded manually. When we were using Lyx for the Manual I ended up downloading all the texlive packages, then deleting them one at a time to get all the
right collection.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
aToloza
Forum Novice
Forum  Novice
Posts: 4
Joined: Wed Apr 11, 2018 5:31 pm

Re: Cannot find packages in newly installed MX17

#8 Post by aToloza » Thu Apr 12, 2018 10:47 am

Thank you very much for your responses,

I tried typing

sudo apt install texlive

and accepting instal, then I go again to synaptic and I don't find texlive yet. Here I attach mi repost (I hope the image appears properly)
Screenshot-1.png
Thakns again

Adolfo
You do not have the required permissions to view the files attached to this post.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22453
Joined: Wed Jul 19, 2006 6:13 am

Re: Cannot find packages in newly installed MX17

#9 Post by Jerry3904 » Thu Apr 12, 2018 11:29 am

and accepting instal, then I go again to synaptic and I don't find texlive yet
I'm sorry, but I don't understand.

--When you typed in that command, did you then press Return and provide your password?
--Did you see a question about going ahead with the installation, and did you answer "y"?
--Did the process finish correctly and leave you back at a command prompt?

If the answer to all three of those is "yes" then you should be able to click on the Start menu, type "texlive" (without quotes) and find the application. If it is not there, please press F4 and type "texlive" (without quotes) and press Return. The application should launch. If it does not, please highlight, right-click and copy any messages that appeared after you pressed Return and paste them back here.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
aToloza
Forum Novice
Forum  Novice
Posts: 4
Joined: Wed Apr 11, 2018 5:31 pm

Re: Cannot find packages in newly installed MX17

#10 Post by aToloza » Thu Apr 12, 2018 11:53 am

Hi Jerry,

The answer to your questions is Yes,

I type texlive in the start menu and nothing appears

I type the same in the terminal (F4) and the output is

bash: texlive: command not found

Thanks again

Post Reply

Return to “Package Requests/Status - MX 17”