Welcome!
Important information
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.1 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 17 Repository: The qBittorrent Thread

bwhawk
Forum Novice
Forum  Novice
Posts: 27
Joined: Mon Mar 19, 2018 8:26 am

Re: MX 17 Repository: The qBittorrent Thread

#41

Post by bwhawk » Fri Oct 19, 2018 5:08 am

libtorrent-rasterbar9:
Installed: 1.1.7+git20180527.6ec6c1b340+patched-configure1-1~mx17+1

bwhawk
Forum Novice
Forum  Novice
Posts: 27
Joined: Mon Mar 19, 2018 8:26 am

Re: MX 17 Repository: The qBittorrent Thread

#42

Post by bwhawk » Fri Oct 19, 2018 5:25 am

Stevo wrote:
Thu Oct 18, 2018 3:30 pm
I wonder if it could be related to the version of libtorrent-rasterbar9 in use.
I think it is. I had libtorrent-rasterbar9 1.1.7+git20180527.6ec6c1b340+patched-configure1-1~mx17+1 installed. I uninstalled that along with qBittorent using the MX Package Installer. I then installed libtorrent-rasterbar9 1.1.4 and qBittorrent 1.1.3 from the Stable Repo. Everything is now working normally again.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 18392
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The qBittorrent Thread

#43

Post by Stevo » Fri Oct 19, 2018 2:46 pm

I built some earlier versions against the test repo libtorrent, but qBittorrent 4.1.3 against the MX main repo 1.1.4 version. Maybe it's happiest with the version it was built against, or the test repo libtorrent is buggy.

Does bwhawks fix work for anyone else?

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2295
Joined: Mon Nov 21, 2011 5:50 pm

Re: MX 17 Repository: The qBittorrent Thread

#44

Post by Gordon Cooper » Fri Oct 19, 2018 4:58 pm

Confirming what happened here. After problems with qbittorrent 4.1.3 on my usual desktop, I upgraded the older 4.0.3 version to 4.1.3 on another desktop and a check shows that it has rasterbar9 1.1.4 installed. All running perfectly with 8 torrents covering MX-17.1 and AntiX 17.2.
Primary: Dell9010, MX-18, Win7, 120 SSD, WD 232GIB HD, 4GB RAM
Backup :Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.

redsparro
Forum Novice
Forum  Novice
Posts: 13
Joined: Mon Apr 02, 2018 9:41 am

Re: MX 17 Repository: The qBittorrent Thread

#45

Post by redsparro » Sat Oct 20, 2018 7:38 am

Stevo wrote:
Fri Oct 19, 2018 2:46 pm
I built some earlier versions against the test repo libtorrent, but qBittorrent 4.1.3 against the MX main repo 1.1.4 version. Maybe it's happiest with the version it was built against, or the test repo libtorrent is buggy.

Does bwhawks fix work for anyone else?
Yes, i think you've identified the problem. I had upgraded past versions from the test repo (4.1.1 in particular which pulled in libtorrent 1.1.7). I don't think there's anything wrong with the test repo libtorrent (qBittorrent 4.1.1 - 4.1.2 worked perfectly). Rather, it would suggest the latest version being built against an older libtorrent version was the cause for the instability.

Reverting to libtorrent 1.1.4 has resolved the issues for me.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 18392
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The qBittorrent Thread

#46

Post by Stevo » Mon Nov 19, 2018 11:35 pm

We now have 4.1.4 in main, built against the same libtorrent-rasterbar 1.1.4 in MX 17 main. It has a few new features and many bugfixes, as usual: https://www.qbittorrent.org/news.php

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 18392
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The qBittorrent Thread

#47

Post by Stevo » Thu Dec 27, 2018 3:45 pm

We now have qBittorrent 4.1.5 in testing, just to make sure it doesn't break anything before we move it to main.

Please note that it was built against the libtorrent-rasterbar 1.1.4+git in main, not the version in testing. Please do not upgrade libtorrent-rasterbar from testing, as this might lead to unpredictable results, as can be seen earlier in this thread. I don't think that installing it from the test repo with MX Package Installer will upgrade libtorrent.

After this build is moved to main, I will upgrade libtorrent to 1.1.11 in the test repo and rebuild another version of 4.1.5 against it for test, for those that want the bleeding edge.

Changes are in the news link.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 18392
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The qBittorrent Thread

#48

Post by Stevo » Thu Jan 03, 2019 6:12 pm

Has anyone tried this new version yet? I'd like to move it to main.

User avatar
postcd
Forum Novice
Forum  Novice
Posts: 79
Joined: Mon Oct 29, 2018 2:02 pm

Re: MX 17 Repository: The qBittorrent Thread

#49

Post by postcd » Thu Jan 03, 2019 6:35 pm

I have not yet figured out how to move my qbt configuration from Windows to Linux :-( https://github.com/qbittorrent/qBittorrent/issues/9912
OS: MXLinux GPU: AMD Radeon RX 560 ; full HW specs. as of 1/2019

User avatar
Paul..
Forum Guide
Forum Guide
Posts: 2526
Joined: Sun Mar 18, 2007 6:34 pm

Re: MX 17 Repository: The qBittorrent Thread

#50

Post by Paul.. » Thu Jan 03, 2019 10:55 pm

Stevo wrote:
Thu Jan 03, 2019 6:12 pm
Has anyone tried this new version yet? I'd like to move it to main.
It is a non-starter, Steve...tried installing twice and it is NG...the app appears to be running but the gui shows no torrents after they are loaded.

When I tried to load the torrents again, the app informed me "that particular torrent was already running"...though I could not see them displayed in the gui.

Uninstalled and autoremoved the libtorrent-rasterbar9 thingy...

Then went back to the current version 4.1.4-0.1~mx17+1 and it worked fine.

EDIT: running fresh install of MX-18 and 4.20.0-antix.1-amd64-smp kernel

Asus Prime X470-Pro | AMD Ryzen 5 1400 (8 threads)
16 Gig DDR4 3000 | nVidia - GeForce GTX 750 Ti
Samsung 970 NVMe SSD | 860 500GB SSD

Post Reply

Return to “Package Requests/Status - MX 17/18”