Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 17 Repository: The qBittorrent Thread

Message
Author
bwhawk
Forum Novice
Forum  Novice
Posts: 24
Joined: Mon Mar 19, 2018 8:26 am

Re: MX 17 Repository: The qBittorrent Thread

#41 Post by bwhawk » Fri Oct 19, 2018 5:08 am

libtorrent-rasterbar9:
Installed: 1.1.7+git20180527.6ec6c1b340+patched-configure1-1~mx17+1

bwhawk
Forum Novice
Forum  Novice
Posts: 24
Joined: Mon Mar 19, 2018 8:26 am

Re: MX 17 Repository: The qBittorrent Thread

#42 Post by bwhawk » Fri Oct 19, 2018 5:25 am

Stevo wrote:
Thu Oct 18, 2018 3:30 pm
I wonder if it could be related to the version of libtorrent-rasterbar9 in use.
I think it is. I had libtorrent-rasterbar9 1.1.7+git20180527.6ec6c1b340+patched-configure1-1~mx17+1 installed. I uninstalled that along with qBittorent using the MX Package Installer. I then installed libtorrent-rasterbar9 1.1.4 and qBittorrent 1.1.3 from the Stable Repo. Everything is now working normally again.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16509
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The qBittorrent Thread

#43 Post by Stevo » Fri Oct 19, 2018 2:46 pm

I built some earlier versions against the test repo libtorrent, but qBittorrent 4.1.3 against the MX main repo 1.1.4 version. Maybe it's happiest with the version it was built against, or the test repo libtorrent is buggy.

Does bwhawks fix work for anyone else?

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 2075
Joined: Mon Nov 21, 2011 5:50 pm

Re: MX 17 Repository: The qBittorrent Thread

#44 Post by Gordon Cooper » Fri Oct 19, 2018 4:58 pm

Confirming what happened here. After problems with qbittorrent 4.1.3 on my usual desktop, I upgraded the older 4.0.3 version to 4.1.3 on another desktop and a check shows that it has rasterbar9 1.1.4 installed. All running perfectly with 8 torrents covering MX-17.1 and AntiX 17.2.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

redsparro
Forum Novice
Forum  Novice
Posts: 12
Joined: Mon Apr 02, 2018 9:41 am

Re: MX 17 Repository: The qBittorrent Thread

#45 Post by redsparro » Sat Oct 20, 2018 7:38 am

Stevo wrote:
Fri Oct 19, 2018 2:46 pm
I built some earlier versions against the test repo libtorrent, but qBittorrent 4.1.3 against the MX main repo 1.1.4 version. Maybe it's happiest with the version it was built against, or the test repo libtorrent is buggy.

Does bwhawks fix work for anyone else?
Yes, i think you've identified the problem. I had upgraded past versions from the test repo (4.1.1 in particular which pulled in libtorrent 1.1.7). I don't think there's anything wrong with the test repo libtorrent (qBittorrent 4.1.1 - 4.1.2 worked perfectly). Rather, it would suggest the latest version being built against an older libtorrent version was the cause for the instability.

Reverting to libtorrent 1.1.4 has resolved the issues for me.

Post Reply

Return to “Package Requests/Status - MX 17”