Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 17 Repository: The Kodi Thread

Message
Author
User avatar
stsoh
Forum Regular
Forum Regular
Posts: 449
Joined: Sun Aug 20, 2017 10:11 am

Re: MX 17 Repository: The Kodi Thread

#31 Post by stsoh » Fri Jan 19, 2018 3:06 pm

ok, thank you all.
MX-17.1_x64 Horizon, G41M-P33 Combo (MS-7592), Pentium E5400 (2706 MHz), 8Gb RAM (984 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.
Accepted Linux when i found MX-Linux in 2016.

nathan2423
Forum Regular
Forum Regular
Posts: 290
Joined: Tue Dec 22, 2015 8:33 am

Re: MX 17 Repository: The Kodi Thread

#32 Post by nathan2423 » Thu Oct 11, 2018 9:07 pm

For what it's worth, on my updated MX17 today I installed Kodi from the main part (popular programs) of the MXPI. It installed fine and played audio, but no audio or picture in playing video.

I then went to the TEST section and reinstalled kodi. Now it works fine. Noticed that it installed a file with the name "wild" at the end (sorry I don't remember the full name). Not sure if that was the difference or not, but in case someone else runs into this and checks here I wanted to report my experience.

User avatar
stsoh
Forum Regular
Forum Regular
Posts: 449
Joined: Sun Aug 20, 2017 10:11 am

Re: MX 17 Repository: The Kodi Thread

#33 Post by stsoh » Wed Nov 14, 2018 12:29 pm

upgrade lib files from mxpi testrepo removes kodi.
these upgrades are not right, after upgraded unable to install kodi again.
can this issue be corrected?

Code: Select all

The following packages will be REMOVED:
  gstreamer1.0-libav kodi kodi-bin libavdevice57 libavfilter6
  libffmpegthumbnailer4v5 tumbler-plugins-extra
The following NEW packages will be installed:
  libbluray2 libcroco3:i386 libdatrie1:i386 libgdk-pixbuf2.0-0:i386
  libgraphite2-3:i386 libharfbuzz0b:i386 libpango-1.0-0:i386
  libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386 librsvg2-2:i386
  libthai0:i386
The following packages will be upgraded:
  libavcodec57 libavcodec57:i386 libavformat57 libavresample3
  libavresample3:i386 libavutil55 libavutil55:i386 libmlt++3 libmlt6
  libswresample2 libswresample2:i386
11 upgraded, 11 newly installed, 7 to remove and 44 not upgraded.

Code: Select all

$ apt policy kodi
kodi:
  Installed: 2:17.6+dfsg1-1~mx17+1
  Candidate: 2:17.6+dfsg1-1~mx17+1
  Version table:
 *** 2:17.6+dfsg1-1~mx17+1 100
        100 /var/lib/dpkg/status
     2:17.3+dfsg1-1mx17+1 500
        500 http://iso.mxrepo.com/mx/repo stretch/main amd64 Packages
     2:17.1+dfsg1-3 500
        500 http://ftp.hk.debian.org/debian stretch/main amd64 Packages

Code: Select all

Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb http://iso.mxrepo.com/antix/stretch/ stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.hk.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.hk.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb http://iso.mxrepo.com/mx/repo/ stretch main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
You do not have the required permissions to view the files attached to this post.
MX-17.1_x64 Horizon, G41M-P33 Combo (MS-7592), Pentium E5400 (2706 MHz), 8Gb RAM (984 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.
Accepted Linux when i found MX-Linux in 2016.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16937
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The Kodi Thread

#34 Post by Stevo » Wed Nov 14, 2018 5:31 pm

I can't reproduce that here.

Can you let the upgrades in main complete and remove those packages, then reinstall tumbler-plugins-extra and then Kodi from the test repo?

User avatar
stsoh
Forum Regular
Forum Regular
Posts: 449
Joined: Sun Aug 20, 2017 10:11 am

Re: MX 17 Repository: The Kodi Thread

#35 Post by stsoh » Thu Nov 15, 2018 12:33 am

tried a few times, same thing happen on my set. if i upgrade those ffmpeg lib files, automatically delete kodi, kodi-bin and kodi-data. after which can't install kodi due to dependencies, even i did download all those dependence debs and install them unsuccessful.

Code: Select all

The following packages will be REMOVED:
  gstreamer1.0-libav libavfilter6 libffmpegthumbnailer4v5
  tumbler-plugins-extra
The following NEW packages will be installed:
  libcroco3:i386 libdatrie1:i386 libgdk-pixbuf2.0-0:i386 libgraphite2-3:i386
  libharfbuzz0b:i386 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 librsvg2-2:i386 libthai0:i386
The following packages will be upgraded:
  libavcodec57 libavcodec57:i386 libavutil55 libavutil55:i386 libswresample2
  libswresample2:i386
6 upgraded, 10 newly installed, 4 to remove and 8 not upgraded.

Code: Select all

2018-11-15  12:39:16  remove   mysql-common                all    5.8+1.0.2              <none>
2018-11-15  12:39:16  remove   libtinyxml2.6.2v5           amd64  2.6.2-4                <none>
2018-11-15  12:39:16  remove   libopenrawgnome1v5          amd64  0.0.9-3.10             <none>
2018-11-15  12:39:16  remove   libopenraw1v5               amd64  0.0.9-3.10             <none>
2018-11-15  12:39:16  remove   libmicrohttpd12             amd64  0.9.51-1               <none>
2018-11-15  12:39:16  remove   libmariadbclient18          amd64  10.1.26-0+deb9u1       <none>
2018-11-15  12:39:16  remove   libjs-jquery                all    3.1.1-2                <none>
2018-11-15  12:39:16  remove   libjs-iscroll               all    5.2.0+dfsg1-1          <none>
2018-11-15  12:39:16  remove   libgsf-1-common             all    1.14.41-1              <none>
2018-11-15  12:39:16  remove   libgsf-1-114                amd64  1.14.41-1              <none>
2018-11-15  12:39:16  remove   libcrossguid0               amd64  0.0+git200150803-2     <none>
2018-11-15  12:39:16  remove   fonts-roboto-hinted         all    2:0~20160106-2         <none>
2018-11-15  12:38:49  upgrade  mx-remaster                 all    0.1.9.5                18.11.02
2018-11-15  12:38:49  upgrade  adobe-flash-properties-gtk  amd64  1:20181009.1-1mx17+1   1:20181113.1-1mx17+1
2018-11-15  12:38:49  upgrade  adobe-flashplugin           amd64  1:20181009.1-1mx17+1   1:20181113.1-1mx17+1
2018-11-15  12:38:00  upgrade  libswresample2              i386   7:3.3.4-1mx17+1        7:3.4.2-1~mx17+1
2018-11-15  12:38:00  upgrade  libswresample2              amd64  7:3.3.4-1mx17+1        7:3.4.2-1~mx17+1
2018-11-15  12:38:00  install  librsvg2-2                  i386   <none>                 2.40.16-1+b1
2018-11-15  12:37:59  install  libthai0                    i386   <none>                 0.1.26-1
2018-11-15  12:37:59  install  libpangoft2-1.0-0           i386   <none>                 1.40.5-1
2018-11-15  12:37:59  install  libpangocairo-1.0-0         i386   <none>                 1.40.5-1
2018-11-15  12:37:59  install  libpango-1.0-0              i386   <none>                 1.40.5-1
2018-11-15  12:37:59  install  libharfbuzz0b               i386   <none>                 1.4.2-1
2018-11-15  12:37:59  install  libgraphite2-3              i386   <none>                 1.3.10-1
2018-11-15  12:37:59  install  libgdk-pixbuf2.0-0          i386   <none>                 2.36.5-2+deb9u2
2018-11-15  12:37:59  install  libdatrie1                  i386   <none>                 0.2.10-4+b1
2018-11-15  12:37:58  upgrade  libavutil55                 amd64  7:3.3.4-1mx17+1        7:3.4.2-1~mx17+1
2018-11-15  12:37:58  install  libcroco3                   i386   <none>                 0.6.11-3
2018-11-15  12:37:57  upgrade  libavutil55                 i386   7:3.3.4-1mx17+1        7:3.4.2-1~mx17+1
2018-11-15  12:37:57  upgrade  libavcodec57                amd64  7:3.3.4-1mx17+1        7:3.4.2-1~mx17+1
2018-11-15  12:37:56  upgrade  libavcodec57                i386   7:3.3.4-1mx17+1        7:3.4.2-1~mx17+1
2018-11-15  12:37:56  remove   tumbler-plugins-extra       amd64  0.1.31-2+b3            <none>
2018-11-15  12:37:56  remove   libffmpegthumbnailer4v5     amd64  2.1.1-0.1+b3           <none>
2018-11-15  12:37:56  remove   libavfilter6                amd64  7:3.3.4-1mx17+1        <none>
2018-11-15  12:37:55  remove   gstreamer1.0-libav          amd64  1.10.4-1               <none>
2018-11-15  12:36:31  remove   kodi-repository-kodi        all    2:17.6+dfsg1-1~mx17+1  <none>
2018-11-15  12:35:52  remove   kodi-data                   all    2:17.6+dfsg1-1~mx17+1  <none>
2018-11-15  12:35:52  remove   kodi-bin                    amd64  2:17.6+dfsg1-1~mx17+1  <none>
2018-11-15  12:35:51  remove   kodi                        amd64  2:17.6+dfsg1-1~mx17+1  <none>

Code: Select all

The following packages have unmet dependencies:
 kodi : Depends: kodi-bin (>= 2:17.3+dfsg1-1mx17+1) but it is not going to be installed
        Depends: kodi-bin (< 2:17.3+dfsg1-1mx17+1.1~) but it is not going to be installed
MX-17.1_x64 Horizon, G41M-P33 Combo (MS-7592), Pentium E5400 (2706 MHz), 8Gb RAM (984 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.
Accepted Linux when i found MX-Linux in 2016.

User avatar
stsoh
Forum Regular
Forum Regular
Posts: 449
Joined: Sun Aug 20, 2017 10:11 am

Re: MX 17 Repository: The Kodi Thread

#36 Post by stsoh » Thu Nov 15, 2018 1:10 am

try again, same as b4, autoremove kodi.

Code: Select all

The following packages were automatically installed and are no longer required:
  fonts-roboto-hinted kodi-data kodi-repository-kodi libcrossguid0
  libgsf-1-114 libgsf-1-common libjs-iscroll libjs-jquery libmariadbclient18
  libmicrohttpd12 libopenraw1v5 libopenrawgnome1v5 libtinyxml2.6.2v5
  mysql-common
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libavcodec57 libavcodec57:i386 libavutil55 libavutil55:i386 libcroco3:i386
  libdatrie1:i386 libgdk-pixbuf2.0-0:i386 libgraphite2-3:i386
  libharfbuzz0b:i386 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 librsvg2-2:i386 libswresample2:i386 libthai0:i386
Suggested packages:
  librsvg2-bin:i386
Recommended packages:
  librsvg2-common:i386
The following packages will be REMOVED:
  gstreamer1.0-libav kodi kodi-bin libavfilter6 libffmpegthumbnailer4v5
  tumbler-plugins-extra
The following NEW packages will be installed:
  libcroco3:i386 libdatrie1:i386 libgdk-pixbuf2.0-0:i386 libgraphite2-3:i386
  libharfbuzz0b:i386 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 librsvg2-2:i386 libthai0:i386
The following packages will be upgraded:
  libavcodec57 libavcodec57:i386 libavutil55 libavutil55:i386 libswresample2
  libswresample2:i386
6 upgraded, 10 newly installed, 6 to remove and 8 not upgraded.
Need to get 12.0 MB of archives.
After this operation, 20.9 MB disk space will be freed.
Do you want to continue? [Y/n] 
MX-17.1_x64 Horizon, G41M-P33 Combo (MS-7592), Pentium E5400 (2706 MHz), 8Gb RAM (984 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.
Accepted Linux when i found MX-Linux in 2016.

User avatar
stsoh
Forum Regular
Forum Regular
Posts: 449
Joined: Sun Aug 20, 2017 10:11 am

Re: MX 17 Repository: The Kodi Thread

#37 Post by stsoh » Thu Nov 15, 2018 2:08 am

this is done on vb with orig mx17.1 64 default w/o any mod upgrade.

Code: Select all

The following packages were automatically installed and are no longer required:
  fonts-roboto-hinted kodi-data kodi-repository-kodi libcrossguid0
  libgsf-1-114 libgsf-1-common libjs-iscroll libjs-jquery libmariadbclient18
  libmicrohttpd12 libopenraw1v5 libopenrawgnome1v5 libtinyxml2.6.2v5
  mysql-common
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libavcodec57 libavcodec57:i386 libavutil55 libavutil55:i386 libcroco3:i386
  libdatrie1:i386 libgdk-pixbuf2.0-0:i386 libgraphite2-3:i386
  libharfbuzz0b:i386 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 librsvg2-2:i386 libswresample2:i386 libthai0:i386
Suggested packages:
  librsvg2-bin:i386
Recommended packages:
  librsvg2-common:i386
The following packages will be REMOVED:
  gstreamer1.0-libav kodi kodi-bin libavfilter6 libffmpegthumbnailer4v5
  tumbler-plugins-extra
The following NEW packages will be installed:
  libcroco3:i386 libdatrie1:i386 libgdk-pixbuf2.0-0:i386 libgraphite2-3:i386
  libharfbuzz0b:i386 libpango-1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 librsvg2-2:i386 libthai0:i386
The following packages will be upgraded:
  libavcodec57 libavcodec57:i386 libavutil55 libavutil55:i386 libswresample2
  libswresample2:i386
6 upgraded, 10 newly installed, 6 to remove and 8 not upgraded.
Need to get 12.0 MB of archives.
After this operation, 20.9 MB disk space will be freed.
Do you want to continue? [Y/n] 
You do not have the required permissions to view the files attached to this post.
MX-17.1_x64 Horizon, G41M-P33 Combo (MS-7592), Pentium E5400 (2706 MHz), 8Gb RAM (984 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.
Accepted Linux when i found MX-Linux in 2016.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16937
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The Kodi Thread

#38 Post by Stevo » Thu Nov 15, 2018 5:15 pm

OK, I can reproduce that in Virtual Box. Do you really need to upgrade those particular libav libraries from the test repo? If you just want a newer ffmpeg, we have 4.0.2 in the test repo that'll pull in different libraries, such as libavcodec 58, and not remove Kodi.

Or I could just rebuild Kodi against the ffmpeg 4.0.2 libraries to fix that issue.

User avatar
stsoh
Forum Regular
Forum Regular
Posts: 449
Joined: Sun Aug 20, 2017 10:11 am

Re: MX 17 Repository: The Kodi Thread

#39 Post by stsoh » Fri Nov 16, 2018 2:57 am

already upgraded ffmpeg, it's good to have.
You do not have the required permissions to view the files attached to this post.
MX-17.1_x64 Horizon, G41M-P33 Combo (MS-7592), Pentium E5400 (2706 MHz), 8Gb RAM (984 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.
Accepted Linux when i found MX-Linux in 2016.

Post Reply

Return to “Package Requests/Status - MX 17”