Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 17 Repository: The firefox thread

Message
Author
User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16983
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The firefox thread

#131 Post by Stevo » Sun Aug 05, 2018 5:18 pm

Whoops, I wrote too soon. Debian hasn't added any cargo packages yet...which is odd, because you need it to build rustc.

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2523
Joined: Thu May 01, 2014 10:12 am

Re: MX 17 Repository: The firefox thread

#132 Post by mmikeinsantarosa » Sat Aug 11, 2018 3:53 pm

firefox-61.0.2 is now available to upgrade to. We're holding back on the switch to libavcodec for now.

Feel free to check the mozilla release notes page for more info.

This update is also good for MX 14, 15 & 16.

- mike
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2523
Joined: Thu May 01, 2014 10:12 am

Re: MX 17 Repository: The firefox thread

#133 Post by mmikeinsantarosa » Wed Sep 05, 2018 6:33 pm

firefox_62.0 is available to upgrade to.

Check the release notes page for more info.

- mike
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16983
Joined: Fri Dec 15, 2006 8:07 pm

Video no longer works on mlb.com

#134 Post by Stevo » Sat Sep 08, 2018 6:05 pm

Suddenly, video playback is broken on mlb.com with the latest Firefox, while it continues to work on Pale Moon 28.0.1.
I have both libavcodec57 and libavcodec58 installed. Can any one else check this? They have some that are supposed to play automatically on the mlb.com home page, and I also dug deeper into the site--none of them work now.

I also tried on a different "generic" MX 17.1 install and had the same failures.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2368
Joined: Wed Apr 11, 2018 5:09 pm

Re: Video no longer works on mlb.com

#135 Post by fehlix » Sat Sep 08, 2018 6:28 pm

Stevo wrote:
Sat Sep 08, 2018 6:05 pm
Suddenly, video playback is broken on mlb.com with the latest Firefox, while it continues to work on Pale Moon 28.0.1.
I have both libavcodec57 and libavcodec58 installed. Can any one else check this? They have some that are supposed to play automatically on the mlb.com home page, and I also dug deeper into the site--none of them work now.

I also tried on a different "generic" MX 17.1 install and had the same failures.
I can whatch thos video's with no issues with both latest PM 28.0.1 and FF 62.0~mozillabinaries-1mx17+1.
My settings: with in both: blocking with umatrix and uBlock-origin most stuff per default,
having manual enabled only mlb.com mlbstatic.com.
In additon disabaled autoplayback in about:config.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Mauser
Forum Regular
Forum Regular
Posts: 746
Joined: Mon Jun 27, 2016 7:32 pm

Re: MX 17 Repository: The firefox thread

#136 Post by Mauser » Sat Sep 08, 2018 6:40 pm

Videos are playing fine on Firefox 62.0.

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2523
Joined: Thu May 01, 2014 10:12 am

Re: MX 17 Repository: The firefox thread

#137 Post by mmikeinsantarosa » Sat Sep 08, 2018 6:44 pm

FF-62.0 playing here AOK sample mlb video
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16983
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 17 Repository: The firefox thread

#138 Post by Stevo » Sat Sep 08, 2018 7:08 pm

Well, I probably have something blocking it, though I turned off uBlock Orign for the site. After about 15 seconds, I get a yellow bar notification that something's blocking a script on the page, and do I want to cancel it... Let me try in safe mode.

In other Firefox related news, I was finally able to do a test package build of Stretch's new Firefox-esr 60.0 by adding

Code: Select all

export SHELL=/bin/sh
to the beginning of the rules file. Apparently MX doesn't set SHELL in the environment at all...odd. We'd also probably be able to backport 62.0 from Sid if we ever had the need to do do, though right now I think repackaging the Mozilla binaries are still going to be our best bet.

User avatar
Mauser
Forum Regular
Forum Regular
Posts: 746
Joined: Mon Jun 27, 2016 7:32 pm

Re: MX 17 Repository: The firefox thread

#139 Post by Mauser » Sat Sep 08, 2018 8:37 pm

Stevo wrote:
Sat Sep 08, 2018 7:08 pm
Well, I probably have something blocking it, though I turned off uBlock Orign for the site. After about 15 seconds, I get a yellow bar notification that something's blocking a script on the page, and do I want to cancel it... Let me try in safe mode.
It's not that because have uBlock Origin and httpseverywhere on FF 62.0 and I use Astrill VPN in stealth mode and the videos play fine. I also have all telemetry disabled and Full Screen notice set to zero in about:config

turtlebay777
Forum Regular
Forum Regular
Posts: 245
Joined: Sat Apr 14, 2018 2:40 pm

Re: MX 17 Repository: The firefox thread

#140 Post by turtlebay777 » Sun Sep 09, 2018 1:54 am

Just to let you know that my Waterfox 56.2.2 (64bit) works perfectly and plays all videos.

Post Reply

Return to “Package Requests/Status - MX 17”