Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

alacritty Request

Post Reply
User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1753
Joined: Sat Jun 30, 2018 6:33 pm

alacritty Request

#1

Post by manyroads » Mon Jul 15, 2019 7:13 pm

Time to beg again... would it be possible to have alacritty (terminal) added to the testrepos?

https://github.com/jwilm/alacritty
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
bspwm MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
"For every complex problem there is an answer that is clear, simple, and wrong." H. L. Mencken

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19820
Joined: Fri Dec 15, 2006 8:07 pm

Re: alacritty Request

#2

Post by Stevo » Mon Jul 15, 2019 8:57 pm

It requires rustc >= 1.32 to build, and Stretch has only 0.24. Rustc is not feasible to backport to Stretch.

Debian Buster has 1.34, so I'll try a port of alacritty for MX 19 from the Pop OS ppa.

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1753
Joined: Sat Jun 30, 2018 6:33 pm

Re: alacritty Request

#3

Post by manyroads » Mon Jul 15, 2019 8:58 pm

Thanks @stevo!
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
bspwm MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
"For every complex problem there is an answer that is clear, simple, and wrong." H. L. Mencken

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19820
Joined: Fri Dec 15, 2006 8:07 pm

Re: alacritty Request

#4

Post by Stevo » Tue Jul 16, 2019 3:24 pm

Boy, this one is a nightmare. It might be trying to download additional components during the build, which is a big no-no in Debian package builds, not least because those can't be vetted. But it doesn't even warn you about that.

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1753
Joined: Sat Jun 30, 2018 6:33 pm

Re: alacritty Request

#5

Post by manyroads » Tue Jul 16, 2019 6:55 pm

Maybe we should leave it alone then. No need to have software intrusions. Thanks for checking it out, @stevo
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
bspwm MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
"For every complex problem there is an answer that is clear, simple, and wrong." H. L. Mencken

Post Reply

Return to “Package Requests/Status - MX 17/18”