Welcome!
Important information
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-18.1 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.3.1 release info here

New users[/u
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX-17 Repository - The Synaptic thread

Post Reply
User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4658
Joined: Wed Jul 12, 2006 4:05 pm

MX-17 Repository - The Synaptic thread

#1

Post by timkb4cq » Sat Jun 23, 2018 9:31 am

I patched the current version of Synaptic to be able to retrieve changelogs (with the Get Changelog button that shows up when you select a package) from the MX main repository as well as the debian repo.
There should be no other changes in function since my patch is localized to that routine, and it works well here.
However, I would like some others to test it before it gets pushed to the main repo, just to make sure.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 23748
Joined: Wed Jul 19, 2006 6:13 am

Re: MX-17 Repository - The Synaptic thread

#2

Post by Jerry3904 » Sat Jun 23, 2018 9:40 am

I installed it, and the button shows up. But I get this output:

Code: Select all

This change is not coming from a source that supports changelogs.

Failed to fetch the changelog for mx-cleanup
URI was: http://nl.mxrepo.com/pool/main/m/mx-cleanup/mx-cleanup_18.06.1_amd64.changelog
Maybe I am doing something wrong--is it the repo?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4658
Joined: Wed Jul 12, 2006 4:05 pm

Re: MX-17 Repository - The Synaptic thread

#3

Post by timkb4cq » Sat Jun 23, 2018 10:01 am

Well, the patch hardcodes the path to use http://mxrepo.com since the mirrors don't get the changelogs.
Does

Code: Select all

apt-cache policy synaptic
show you have 0.84.2-1mx17+1 ?
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 23748
Joined: Wed Jul 19, 2006 6:13 am

Re: MX-17 Repository - The Synaptic thread

#4

Post by Jerry3904 » Sat Jun 23, 2018 10:37 am

It shows correctly (on my testing machine, which uses that default repo. Will check again on my production box.

It's a very nice addition BTW.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 23748
Joined: Wed Jul 19, 2006 6:13 am

Re: MX-17 Repository - The Synaptic thread

#5

Post by Jerry3904 » Sat Jun 23, 2018 10:44 am

Yup, it works on my production machine which I tried earlier. Not sure what happened the first time, but it looks good now.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
Redacted
Forum Regular
Forum Regular
Posts: 212
Joined: Sat Apr 29, 2017 6:53 am

Re: MX-17 Repository - The Synaptic thread

#6

Post by Redacted » Sat Jun 23, 2018 11:38 am

It works for me. Very nice.

User avatar
PondLife
Forum Novice
Forum  Novice
Posts: 86
Joined: Wed May 09, 2018 12:24 pm

Re: MX-17 Repository - The Synaptic thread

#7

Post by PondLife » Sun Jun 24, 2018 6:12 am

All working correctly. I did get the same error as Jerry3904 #2 when I tried checking a package that required updating (because I had the test repo enabled). Once the test repo was disabled so the package was listed as up to date the changelog worked as intended.
Desktop: MX-18_x64 | Intel i3-4360T | 4GB RAM | Samsung 250GB SSD
Laptop: antiX-17.3.1 | Intel T2310 | 1GB RAM | 150GB HDD

Post Reply

Return to “Package Requests/Status - MX 17/18”