Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Petit problème de démarrage après essai de noyau

Forum français des utilisateurs Mepis
Message
Author
User avatar
Insam
Forum Novice
Forum  Novice
Posts: 42
Joined: Mon Sep 10, 2018 11:45 am

Petit problème de démarrage après essai de noyau

#1 Post by Insam » Sat Nov 03, 2018 2:48 pm

Bonsoir tous,
Voilà, je viens d'installer le kernel 4.18 présent dans l'installateur de paquets,
Faut dire que ça n'a pas vraiment été rapide.

Au reboot, j'ai grub, puis plymouth, puis ....Rien ! Écran noir.

Bon, je me dis que le matos n'en veut pas, et redémarre sur le noyau habituel....Mais zut ! idem !
Je reboote sur 4.15, idem, encore une troisième fois et cette fois j'ai mon bureau avec le curseur minuscule (alors qu'il est réglé taille XXL)

Comme je suis un vieux breton curieux et borné, je redémarre sur le 4.18 : écran noir, je reboote dessus, idem, et encore une fois, et j'ai le bureau, cette fois encore avec le curseur liliputien.
Je redémarre une énième fois toujours sur le 4.18, et cette fois j'ai le bureau avec le curseur qui va bien.

Donc quel que soit le kernel utilisé, depuis cette mise à jour, il faut au moins 3 reboot pour avoir mon bureau intact !
Par prudence, je réinstalle le dernier ghost de la partition système d'avant la MAJ du noyau.

Ben peine perdue, bizarrement ça recommence, je n'ai mon bureau qu'au 3ème reboot, donc le souci est logé dans mon dossier perso !

Quelqu'un a une idée pour me dire ce qui a bien pu bien se passer ?
Je peux bien sûr réinstaller le ghost de mon home, mais avant j'aimerai mieux comprendre !

D'ailleurs je viens de réinstaller le kernel 4.18, histoire d'avoir tout les paramètres de cette incongruité.
Merci d'avance pour les lumières..
Image

User avatar
oops
Forum Regular
Forum Regular
Posts: 460
Joined: Tue Apr 10, 2018 5:07 pm

Re: Petit problème de démarrage après essai de noyau

#2 Post by oops » Sat Nov 03, 2018 5:41 pm

Bonsoir,
J'ai déjà eu le cas avec un seul utilisateur (ma femme), tous les autres n'avaient pas ce problème ... bref j'ai fini par recréer un nouvel utilisateur (pour rebasculer ma femme dessus) ... je n'ai jamais vraiment compris pourquoi (fréquence du moniteur 75Hz trop haut? profondeur de couleurs?,, image de fond d'écran ?, secteur défectueux/corrompu du disque dur, ou autres? ) , , en faisant Ctrl+Alt+Fx sur son user, j'avais des fois un écran noir (mais pas toujours en plus, et quelque soit la version du noyau/kernel).

Bref, des fois mieux vaut recréer un nouvel user et repartir sur du neuf.
$ inxi -Fxxxz : System: Host:XEON ... Distro: MX-18_x64 Continuum

User avatar
Insam
Forum Novice
Forum  Novice
Posts: 42
Joined: Mon Sep 10, 2018 11:45 am

Re: Petit problème de démarrage après essai de noyau

#3 Post by Insam » Sun Nov 04, 2018 5:37 am

oops wrote:
Sat Nov 03, 2018 5:41 pm
...j'ai fini par recréer un nouvel utilisateur (pour rebasculer ma femme dessus)...
Ça a beau être bien écrit....Ça fait drôle à lire ! :happy: mais vu ton pseudo ça ne surprend pas trop ! :wink:

Alors, histoire de ne pas perdre la config patiemment élaborée, tu fais comment pour rebasculer ta femme sur le nouvel utilisateur ?

(bon, l'effet induit par ma réponse n'est pas terrible non plus ! )
Image

User avatar
oops
Forum Regular
Forum Regular
Posts: 460
Joined: Tue Apr 10, 2018 5:07 pm

Re: Petit problème de démarrage après essai de noyau

#4 Post by oops » Sun Nov 04, 2018 6:43 am

Bonjour,
Je me doutais que pour un esprit placé un peu en dehors de l'informatique ça ferait sourire (c'est bien car il n'y a pas que l'informatique dans la vie) ... c'est comme l'histoire des bits et kilo-bits en classe, mais j'aime bien faire sourire, bref c'était un oops volontaire ;-).
Pour la bascule, c'est simple, c'est qu'une histoire d'expérience aussi ;-) ... généralement, il n'y a juste que les e-mails (j'ai claws-mail et c'est assez simple), et les bookmarks du navigateur internet à copier. Bref, j'ai fais cette affaire de bascule assez tranquillement et facilement, et ma femme a été contente ;-).
$ inxi -Fxxxz : System: Host:XEON ... Distro: MX-18_x64 Continuum

callmeal
Forum Novice
Forum  Novice
Posts: 26
Joined: Sun Oct 09, 2016 6:15 am

Re: Petit problème de démarrage après essai de noyau

#5 Post by callmeal » Sun Nov 04, 2018 7:15 am

Bref, j'ai fais cette affaire de bascule assez tranquillement et facilement, et ma femme a été contente ;-).
c'est qu'à force de bascule ... :happy:

User avatar
Insam
Forum Novice
Forum  Novice
Posts: 42
Joined: Mon Sep 10, 2018 11:45 am

Re: Petit problème de démarrage après essai de noyau

#6 Post by Insam » Sun Nov 04, 2018 8:08 am

oops wrote:
Sun Nov 04, 2018 6:43 am
... généralement, il n'y a juste que les e-mails (j'ai claws-mail et c'est assez simple), et les bookmarks du navigateur internet à copier. Bref, j'ai fais cette affaire de bascule assez tranquillement et facilement,
Ben chez moi c'est précisément ce genre de chose que j'e n'ai nul besoin de "basculer" vu que j'utilise Waterfox et Thunderbird français, décompressés direct dans une autre partition et non installés par les versions dépôts. avec juste des lanceurs depuis les homes de Mint et MX (homes distincts pour chaque distro)
Mais y'a tout le reste : les tableaux de bords (10, je sais ça surprend mais je veux tout sous la main esthétiquement placé autour d'un bureau vierge d'icônes et visible tout le temps, même fenêtres agrandies), les dossiers icons, sounds, themes, les apps locales sans installations, les configs Wine, les configs d'applis avec report au démarrage, etc...Surtout qu'en plus, j'ai eu un profil neuf lors de ma tentative d'install nvidia, que j'ai conservé puisque je n'ai réinstallé que le ghost-système, donc y'a pas longtemps, et qui a très bien fonctionné jusqu'à la MAJ du noyau !
Le pire, c'est que le ghost de mon home d'avant la MAJ n'avait pas de problème de démarrage...Donc sa réinstallation sans toucher au système, aurait du régler le souci...Et ben non !...Je pige pas ! je vais tabler sur un blème matériel du SSD à l'endroit ou ça binze !

Ce matin, aucun souci de démarrage MX kernel 4.18, mais je l'ai eu au reboot après être passé sur Mint pour les MAJ.
Et pour corser ma matinée, c'est Mint qui ne voulait plus laisser la main, obligé de redémarrer à la hussarde !
Mon matos est bon pour la retraite, je le sais bien...
et ma femme a été contente ;-).
:happy: Je n'en doute pas une seconde !
Image

User avatar
oops
Forum Regular
Forum Regular
Posts: 460
Joined: Tue Apr 10, 2018 5:07 pm

Re: Petit problème de démarrage après essai de noyau

#7 Post by oops » Sun Nov 04, 2018 8:48 am

RE:
C'est une bonne idée d'avoir les config email et waterfox sur une partiton séparée ... personnellement j'ai un répertoire isolé dans /home/partage/user1, user2, etc , mais sur la même partittion, mais pour les fichiers perso documents, photos, etc.
C'est rigolo, nous avons tous nos propres organisations et customisations (bref nos petites manies) et tant mieux, ça crée de la diversité et de l'originalité comme ça.
PS: sinon, idem, j'ai mis ce même problème sur le compte d'un secteur HDD conrompu ou défecteux à un certain moment. Et j'ai activé le fsck (idée de Fehlix) tous les 90 fois ou 3 mois pour la partition /home (j'ai déjà eu ce problème sous / aussi)
viewtopic.php?f=108&p=444382#p444382
$ inxi -Fxxxz : System: Host:XEON ... Distro: MX-18_x64 Continuum

User avatar
Insam
Forum Novice
Forum  Novice
Posts: 42
Joined: Mon Sep 10, 2018 11:45 am

Re: Petit problème de démarrage après essai de noyau

#8 Post by Insam » Sun Nov 04, 2018 11:51 am

C'est une bonne idée d'avoir les config email et waterfox sur une partiton séparée .
Heu, chez moi c'est pas juste les configs, ce sont les logiciels entiers, téléchargés en zip et dézippés dans ma partition de données.
Waterfox : https://www.waterfoxproject.org/en-US/waterfox/new/ à mettre en français ensuite avec le module langue de Firefox
Thunderbird : https://www.thunderbird.net/en-US/thunderbird/all/ directement traduit.
Les profils se mettent quand même dans le dossier perso automatiquement, suffit de les copier/coller dans le dossier dézippé et de remplacer par un lien dans le home
Rien dans le système, juste au besoin recréer les lanceurs où on veut.
Les mises à jour se font exactement comme si installés par l'installateur ou synaptic.
Une seule installation dans une partition séparée pour autant de systèmes en multiboot que tu veux, et toujours avec le même profil. (Et des sauvegardes incrémentielles quotidiennes à deux endroits différents, mais ça, ça devrait être enfoncé dans chaque cervelle, quel que soit le système et quel que soit la compétence de l'interface chaise/clavier.)
J'ai tout un tas d'applications dans ce cas, dont Libre-Office - si téléchargé depuis le site dédié : installé une fois dans l'une des distros, migré le dossier dans la partition de données, et mis les profils dedans, juste remplacé tous les fichiers du home concernés par des liens, puis désinstaller/purger Libroffice. (j'te dis pas la place qu'il prend, il est en passe de devenir la même usine à gaz que l'Office de Microsoft)
Juste recréer les lanceurs dans chaque home de chaque distro, et donc un seul libre-office toujours avec la même config, pour autant de distro en multiboot que tu veux. (je suis contre le home commun à plusieurs systèmes je préfère de loin la partition de données communes à plusieurs systèmes)

Cela dit, je fini là de me HS-iser tout seul ! Je vais encore réfléchir à me basculer sur un nouvel utilisateur, je ne suis pas encore assez chaud pour ça ;)
Image

User avatar
oops
Forum Regular
Forum Regular
Posts: 460
Joined: Tue Apr 10, 2018 5:07 pm

Re: Petit problème de démarrage après essai de noyau

#9 Post by oops » Sun Nov 04, 2018 3:14 pm

Re:
J'ai quelques logiciels et scripts en commun aussi, mais ce n'est pas la règle , j'en suis resté au /home pour chacun, et quelques appimage pour la customisation par user. Du coup je ne peux pas trop vous conseiller pour votre configuration.
à part réactiver le fsck automatique (s'il a été désactivé sur les partitions concernées).
$ inxi -Fxxxz : System: Host:XEON ... Distro: MX-18_x64 Continuum

User avatar
Insam
Forum Novice
Forum  Novice
Posts: 42
Joined: Mon Sep 10, 2018 11:45 am

Re: Petit problème de démarrage après essai de noyau

#10 Post by Insam » Mon Nov 05, 2018 11:47 am

Ben pour le moment, RAS, ça ne me l'a plus fait, donc je verrais si je cherche ou non ce qui m.... si ça revient !
fsck est actif par pour toutes les partitions, je ne change jamais cette option là.
Image

Post Reply

Return to “Forum Français”