Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Firefox not opening after update.

Help on MX KDE Re-spins
Message
Author
User avatar
Eino
Forum Regular
Forum Regular
Posts: 147
Joined: Thu Jan 09, 2014 7:54 am

Firefox not opening after update.

#1 Post by Eino » Sun Mar 19, 2017 8:32 am

After the update from MX linux firefox is not opening, When I try opening it from the terminal I get a file format error.
You never really die. Your spirit, your music, and your wisdom carryover for generations to come, we are spiritual beings on a human journey.
Visit me at https://soundcloud.com/eino1953

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 8877
Joined: Wed Jul 12, 2006 1:42 am

Re: Firefox not opening after update.

#2 Post by Adrian » Sun Mar 19, 2017 10:04 am

First thing I do to troubleshoot this kind of things is to move away the ~/.mozilla folder, rename it to something else and try again.

User avatar
Eino
Forum Regular
Forum Regular
Posts: 147
Joined: Thu Jan 09, 2014 7:54 am

Re: Firefox not opening after update.

#3 Post by Eino » Sun Mar 19, 2017 11:36 am

Adrian wrote:First thing I do to troubleshoot this kind of things is to move away the ~/.mozilla folder, rename it to something else and try again.
I renamed the folder, and I'm still getting the same error.

Code: Select all

eino@mx1:~
$ firefox
bash: /usr/bin/firefox: cannot execute binary file: Exec format error
eino@mx1:~
$ 
You never really die. Your spirit, your music, and your wisdom carryover for generations to come, we are spiritual beings on a human journey.
Visit me at https://soundcloud.com/eino1953

plzd
Forum Novice
Forum  Novice
Posts: 36
Joined: Fri Feb 10, 2017 11:03 pm

Re: Firefox not opening after update.

#4 Post by plzd » Sun Mar 19, 2017 11:48 am

This just happen on my other machine this morning (MX16 32bit).

I uninstalled firefox and reinstalled it, AND I renamed .mozilla file -- still can't get it to work -- had to use palemoon.
Dell E6220 i7 2640M CPU @ 2.80GHz Intel Sandybridge Mobile 8GB Ram 128GB SSD - 23" Acer G235h Monitor

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 8877
Joined: Wed Jul 12, 2006 1:42 am

Re: Firefox not opening after update.

#5 Post by Adrian » Sun Mar 19, 2017 11:58 am

Sounds like you installed the package for the wrong architecture (not sure how), can you please run:

Code: Select all

file /opt/firefox/firefox

Code: Select all

uname -a

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9318
Joined: Wed Jul 12, 2006 2:26 pm

Re: Firefox not opening after update.

#6 Post by kmathern » Sun Mar 19, 2017 12:02 pm

I just checked, the 32bit firefox package, 52.0.1~mozillabinaries-1mx15+1 version, has the 64bit executable in it instead of the 32bit.

Code: Select all

kent@mx1:~/firefox_52.0.1~mozillabinaries-1mx15+1_i386/opt/firefox
$ file firefox
firefox: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.18, BuildID[sha1]=6315677124cf311616b98bea20cf063af2acca4f, stripped

plzd
Forum Novice
Forum  Novice
Posts: 36
Joined: Fri Feb 10, 2017 11:03 pm

Re: Firefox not opening after update.

#7 Post by plzd » Sun Mar 19, 2017 12:05 pm

Code: Select all

$ file /opt/firefox/firefox
/opt/firefox/firefox: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.18, BuildID[sha1]=6315677124cf311616b98bea20cf063af2acca4f, stripped

Code: Select all

Linux mx1 3.16.0-4-686-pae #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) i686 GNU/Linux
...so then it's a 64bit package packaged for 32bit distro???
Dell E6220 i7 2640M CPU @ 2.80GHz Intel Sandybridge Mobile 8GB Ram 128GB SSD - 23" Acer G235h Monitor

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16175
Joined: Fri Dec 15, 2006 8:07 pm

Re: Firefox not opening after update.

#8 Post by Stevo » Sun Mar 19, 2017 12:33 pm

Yes, there's some kind of screwup with it, probably my fault. :bagoverhead: Hang on a couple minutes and I'll have a fixed 32-bit deb for download and then push the correct builds to the repo.

MelDawson
Forum Novice
Forum  Novice
Posts: 9
Joined: Mon Feb 20, 2017 12:39 pm

Re: Firefox not opening after update.

#9 Post by MelDawson » Sun Mar 19, 2017 12:39 pm

Thank you Stevo.
System: Host: mx1764 Kernel: 4.14.0-3-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17_x64 Horizon December 15, 2017
Machine: Device: laptop System: TOSHIBA product: Satellite L70-A v: PSKN2C-00H007

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16175
Joined: Fri Dec 15, 2006 8:07 pm

Re: Firefox not opening after update.

#10 Post by Stevo » Sun Mar 19, 2017 12:49 pm

Here's the link to the 32-bit deb. It can also be safely installed in M12 or MX 14. This one requires pulseaudio, or apulse from the test repo be installed: https://drive.google.com/open?id=0BxE7w ... 3QzdG5tSjA

MX has pulseaudio installed by default, MEPIS 12 does not. Some people don't like it, so apulse now gives us a choice.

Post Reply

Return to “MX KDE”