Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

(SOLVED) Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

Help on MX KDE Re-spins
joejac
Forum Novice
Forum  Novice
Posts: 76
Joined: Sat Apr 30, 2016 1:25 pm

Re: Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

#11

Post by joejac » Sun May 01, 2016 12:08 am

Hello,

1.- I followed the manual HPLIP installation: http://hplipopensource.com/hplip-web/in ... ebian.html
But after all that work, same problem. I also used Foomatic drivers and same problem.
2.- I change the drivers in CUPS with this:

Code: Select all

Driver:	HP DeskJet 845C - CUPS+Gutenprint v5.2.10 (color, 2-sided printing)
This time there is no error, but nothing is printed, I get:
"completed at Sat 30 Apr 2016 11:18:31 PM"
Status: Idle - "Sending data to printer."
:confused:

User avatar
Gordon Cooper
Forum Regular
Forum Regular
Posts: 2399
Joined: Mon Nov 21, 2011 5:50 pm

Re: Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

#12

Post by Gordon Cooper » Sun May 01, 2016 12:29 am

Am following this thread with more than little interest. Updated daughter's system from Mepis 11 to MX 15, thought all the correct packages had been loaded but
her HP printer does not work now either.
Backup: Dell9010, MX-18.2, Win7, 120 SSD, WD 232GIB HD, 4GB RAM
Primary :Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
MX-18.2 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.

User avatar
v3g4n
Developer
Posts: 1829
Joined: Sat Jan 16, 2016 8:20 pm

Re: Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

#13

Post by v3g4n » Sun May 01, 2016 1:19 am

Gordon Cooper wrote:Am following this thread with more than little interest. Updated daughter's system from Mepis 11 to MX 15, thought all the correct packages had been loaded but
her HP printer does not work now either.
What version are you using? 3.15.11?
Does the jessie version work? 3.14.6?
https://packages.debian.org/source/jessie/hplip
Or the jessie-backports version?
https://packages.debian.org/source/jess ... orts/hplip

joejac
Forum Novice
Forum  Novice
Posts: 76
Joined: Sat Apr 30, 2016 1:25 pm

Re: Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

#14

Post by joejac » Sun May 01, 2016 2:09 am

Hello,
Please let me know which version to use because I was trying to install hplip-3.15.4.run but the terminal stuck for more than an hour with - and / rotating and nothing happened.
Regards
joejac

User avatar
v3g4n
Developer
Posts: 1829
Joined: Sat Jan 16, 2016 8:20 pm

Re: Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

#15

Post by v3g4n » Sun May 01, 2016 2:25 am

joejac wrote:Hello,
Please let me know which version to use because I was trying to install hplip-3.15.4.run but the terminal stuck for more than an hour with - and / rotating and nothing happened.
Regards
joejac
I cannot say for certain what version you need to use, sorry. All I can say is that version 3.15.11 in the main MX 15 repo is the upgraded version from the 3.14.6 version that is available in vanilla Jessie. This means that the original version from Jessie has been upgraded in the MX repos, which may not be working for you for some reason. All I can suggest is to try the version from Jessie and see if it works for you and report back.
https://packages.debian.org/jessie/hplip

joejac
Forum Novice
Forum  Novice
Posts: 76
Joined: Sat Apr 30, 2016 1:25 pm

Re: Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

#16

Post by joejac » Sun May 01, 2016 12:05 pm

Hello v3g4n

1.- I did what you suggested, I installed 3.14.6 from Jessie but same problem.
Then I printed an internal test page, using configuration, printer properties of print setting, and I got from the printer:
If you can read this, you are using the wrong driver for your printer
So the printer is working but the problem is: "wrong driver"
2.- Again I ran from Console: hp-check -t

Code: Select all

hp-check -t
Saving output in log file: /home/myuser/hp-check.log

HP Linux Imaging and Printing System (ver. 3.14.6)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or 
.run) to determine if the proper dependencies are installed to successfully compile HPLIP.                          
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or  
an already built HPLIP supplied tarball has the proper dependencies installed to successfully run.                  
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases     
(both compile- and run-time dependencies).                                                                          

Check types:                                                                                                        
a. EXTERNALDEP - External Dependencies                                                                              
b. GENERALDEP - General Dependencies (required both at compile and run time)                                        
c. COMPILEDEP - Compile time Dependencies                                                                           
d. [All are run-time checks]                                                                                        
PYEXT SCANCONF QUEUES PERMISSION                                                                                    

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: mx distro is not found in AUTH_TYPES
warning: debian-0.0 version is not supported. Using debian-7.5 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.4.0-0.bpo.1-amd64 #1 SMP Debian 4.4.6-1~bpo8+1 (2016-03-20) GNU/Linux
 Host: astur                                                                                                        
 Proc: 4.4.0-0.bpo.1-amd64 #1 SMP Debian 4.4.6-1~bpo8+1 (2016-03-20) GNU/Linux
 Distribution: debian 0.0
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.14.6
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for debian distro  0.0 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.14.6

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip-doc/HTML
html=/usr/share/doc/hplip-3.14.6
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.14.6
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[last_used]
device_uri = "hp:/usb/DeskJet_845C?serial=TH2242269F3J"
printer_name = DeskJet_845C_2
working_dir = .

[installation]
date_time = 05/01/16 11:05:05
version = 3.14.6

[settings]
systray_visible = 0
systray_messages = 0

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list = 

[fax]
voice_phone = 
email_address = 

[upgrade]
notify_upgrade = false
last_upgraded_time = 1461987825
pending_upgrade_time = 0
latest_available_version = 3.16.3


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

--------------------------
|  External Dependencies |
--------------------------

 policykit            Admin-Policy-framework    OPTIONAL        -               0.105           OK         -
 error: gs            Ghostscript               REQUIRED        7.05            -               MISSING    'gs needs to be installed'
 network              Network-wget              OPTIONAL        -               1.16            OK         -
 scanimage            Shell-Scanning            OPTIONAL        1.0             1.0.24          OK         -
 avahi-utils          avahi-utils               OPTIONAL        -               0.6.31          OK         -
 dbus                 DBus                      REQUIRED        -               1.8.20          OK         -
 cups                 CUPS                      REQUIRED        1.1             1.7.5           OK         'CUPS Scheduler is running'
 xsane                SANE-GUI                  OPTIONAL        0.9             0.998           OK         -

-------------------------
|  General Dependencies |
-------------------------

 error: reportlab     Python-PDF-Lib            OPTIONAL        2.0             3.1.8           MISSING    'reportlab needs to be installed'
 libcrypto            OpenSSL-Crypto-Lib        REQUIRED        -               1.0.1           OK         -
 pil                  Python-Image-Lib          OPTIONAL        -               1.1.7           OK         -
 pyqt4-dbus           PyQt4-DBUS                REQUIRED        4.0             4.11.2          OK         -
 libjpeg              JPEG-Lib                  REQUIRED        -               -               OK         -
 libpthread           POSIX-Threads-Lib         REQUIRED        -               2.19            OK         -
 python-dbus          Python-DBUS               REQUIRED        0.80.0          1.2.0           OK         -
 python-devel         Python-SDK                REQUIRED        2.2             2.7.9           OK         -
 pyqt4                Python-Qt4                REQUIRED        4.0             4.11.2          OK         -
 cups-devel           CUPS-SDK                  REQUIRED        -               1.7.5           OK         -
 sane-devel           SANE-SDK                  REQUIRED        -               1.0.24          OK         -
 libusb               USB-Lib                   REQUIRED        -               1.0             OK         -
 sane                 Scan-Lib                  REQUIRED        -               1.0.24          OK         -
 cups-image           CUPS-Image-Lib            REQUIRED        -               1.7.5           OK         -
 libnetsnmp-devel     SNMP-Networking-SDK       REQUIRED        5.0.9           5.7.2           OK         -
 python-xml           Python-XML-Lib            REQUIRED        -               2.1.0           OK         -
 error: python-notify Desktop-notifications     OPTIONAL        -               -               MISSING    'python-notify needs to be installed'

------------------------------
|  Compile Time Dependencies |
------------------------------

 gcc                  gcc-Compiler              REQUIRED        -               4.9.2           OK         -
 libtool              Build-tools               REQUIRED        -               2.4.2           OK         -
 make                 GNU-Build-tools           REQUIRED        3.0             4.0             OK         -

----------------------
|  Python Extentions |
----------------------

 cupsext              CUPS-Extension            REQUIRED        -               3.14.6          OK         -
 pcardext             PhotoCard-Extension       REQUIRED        -               3.14.6          OK         -
error: NOT FOUND OR FAILED TO LOAD! Please reinstall HPLIP and check for the proper installation of hpmudext.
 error: hpmudext      IO-Extension              REQUIRED        -               3.14.6          MISSING    'Not Found or Failed to load, Please reinstall HPLIP'

-----------------------
|  Scan Configuration |
-----------------------

 hpaio                HPLIP-SANE-Backend        REQUIRED        -               3.14.6          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension       REQUIRED        -               3.14.6          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `v4l:/dev/video0' is a Noname HP Webcam virtual device


--------------
| PERMISSION |
--------------

 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'ghostscript' package is missing/incompatible 
error: 'ghostscript-cups' package is missing/incompatible 
error: 'ghostscriptx so thi' package is missing/incompatible 

Missing Optional Dependencies
-----------------------------
error: 'python-reportlab' package is missing/incompatible 
error: 'python-notify' package is missing/incompatible 

Total Errors: 4
Total Warnings: 0

Run 'hp-doctor' command to prompt and fix the issues. 

Done.
3.- And this is what hp-doctor output:

Code: Select all

hp-doctor
Traceback (most recent call last):
  File "/usr/bin/hp-doctor", line 37, in <module>
    from base import utils, tui, module,queues, os_utils, services, smart_install
  File "/usr/share/hplip/base/module.py", line 30, in <module>
    import tui, utils, device
  File "/usr/share/hplip/base/device.py", line 42, in <module>
    import status
  File "/usr/share/hplip/base/status.py", line 59, in <module>
    import hpmudext
ImportError: /usr/lib/python2.7/dist-packages/hpmudext.so: undefined symbol: hpmud_make_par_uri
4.- In summary:
Missing Required Dependencies
-----------------------------
error: 'ghostscript' package is missing/incompatible
error: 'ghostscript-cups' package is missing/incompatible
error: 'ghostscript-x' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'python-reportlab' package is missing/incompatible
error: 'python-notify' package is missing/incompatible
I have ghostscript 9.06 so I conclude these packages are incompatible with HPLIP
And python package also gives an error.
This is unsolvable if these dependencies are not corrected and I am a Lunux user not a developer. ¿What can I do?
I hope someone can help me.
Best regards
joejac

User avatar
tascoast
Forum Regular
Forum Regular
Posts: 1166
Joined: Sat Aug 06, 2011 4:58 am

Re: Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

#17

Post by tascoast » Sun May 01, 2016 1:23 pm

I too have some issues printing to a HP Deskjet 2540 via router/wi-fi, although previously it has worked great. Appearing as jobs but not printing recently in MX-15 so I went to MX-14 and had success, by contrast. Since I print infrequently, it seems a glitch of recentish origins (a couple of weeks?) akin to Gordon's descriptions. I've noticed a little trouble loading daveserver in Synaptic (NZ repo setting) but this may be irrelevant and coincidental.
Lenovo ThinkCentre A58 4GBRAM (64-bit), MX17/MX-16/antiX17/Mint 19

joejac
Forum Novice
Forum  Novice
Posts: 76
Joined: Sat Apr 30, 2016 1:25 pm

Re: Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

#18

Post by joejac » Sun May 01, 2016 2:53 pm

Thanks tascoast for your information.

1.- So it most be a problem with some wrong dependencies in MX15, so how can we report this issue, to the developers?

2.- I am sleeping very little because I need my laptop working for tomorrow, and I found this page:
http://www.linux-drivers.org/printer_scanner.html
2.1 I tested turboprint and my printer worked flawless at first try, very easy to configure:
http://www.zedonet.com/en_p_turboprint_ ... tml?arch=1

Please see the attached screen capture and the printed page scaned into pdf, so my even older HP scanner was recognized by the nice gscan2pdf, so in a minute I was able to test many things, all working fine except the printing via CUPS or HPLIP.

3.- Today I did my first test of MX15 KDE Desktop, lovely! it works fine with the aesthetics I need. The screenshot shows about 9 applications, Firefox with many tabs open, 2 graphics programs, one very heavy, both running under q4wine/wine, and I still have 60% memory free, much more free RAM than if I have used a Windows Virtual machine. Temperature is between 10 to 20 Celsius below compared if I use a Windows virtual machine. Once KDE start, I do not notice a big difference in speed compared with XFCE but I do feel a big difference in aesthetics.

MX community is friendly and helpful, thanks for all your fast responses.

If I can have the printer working without using 3rd. party software, MX-15 will be the distro to use, and I would stop testing more distros.

Best regards
joejac
You do not have the required permissions to view the files attached to this post.

joejac
Forum Novice
Forum  Novice
Posts: 76
Joined: Sat Apr 30, 2016 1:25 pm

Re: Hello, HP Printer is recognized but it is not printing, please see the reports, thanks

#19

Post by joejac » Tue Jun 14, 2016 5:37 pm

Hello, this is an update.

Today I needed to print and I got a big logo from Turboprint, that had expired, printed over my stuff. I uninstalled Turboprint completely. I had to manually delete the Turboprint folders that were in etc, usr and share. Nothing personal, Turboprint is very good, but in this country citizens do not have access to foreign currencies to purchase anything online.
I checked HPLIP and I have now 3.15.11-0mx150+1
I added and configured the printer again and it worked! :happy:
The test page said:
Driver: hp-deskjet_845c.ppd
Driver Version: 3.16.3 (Humm... HPLIP 3.15.11 ?? )
Make and Model: HP Deskjet 845c, hpcups 3.16.3
I like when things begin to work fine by magic, I guess I have to thank to Stevo :toast:
Best regards
joejac :linuxlove:


Post Reply

Return to “MX KDE”