Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 15/16 Repository: The OBS Studio Thread

Post Reply
Message
Author
User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16272
Joined: Fri Dec 15, 2006 8:07 pm

MX 15/16 Repository: The OBS Studio Thread

#1 Post by Stevo » Sat May 27, 2017 1:35 pm

We now have the latest release of the popular OBS Studio 19.0.2 in our test repository.

The many changes and fixes for the various releases can be seen here: https://github.com/jp9000/obs-studio/releases

OBS Studio is designed for efficiently recording and streaming live video
content. It supports live RTP streaming to various streaming sites.

Other features include:
* Encoding using H264 (x264) and AAC
* Unlimited number of scenes and sources
* File output to MP4 or FLV
* GPU-based game capture for high performance game streaming
* Bilinear or lanczos3 resampling

Note that OBS Studio requires an OpenGL 3.2 compatible video card and driver, and may have trouble with AMD graphics drivers.

User avatar
richb
Administrator
Posts: 17085
Joined: Wed Jul 12, 2006 2:17 pm

Re: MX 15/16 Repository: The OBS Studio Thread

#2 Post by richb » Sat Jun 17, 2017 4:27 pm

Installed OBS Studio 19.0.2 from the test repo. As you recall I could not run previous versions with the ATI/AMD graphics drivers. This one works. First installed OBS Studio then the drivers. I do not know if that sequence did the trick or the new packages. Still struggling to get audio right but same config problem I had with the older versions. I just do not remember what I did to get it working.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16272
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15/16 Repository: The OBS Studio Thread

#3 Post by Stevo » Tue Sep 05, 2017 2:56 pm

Ported over the latest 20.0.1 release from deb-multimedia repo fro the test repo, since Debian still only has 19.0.3, and DMO stayed with Debian's packaging layout for obs. The PPA guys are still sticking with their single deb package in spite of how Debian and Ubuntu package it. As usual, quite a few changes: https://github.com/jp9000/obs-studio/releases

This version has also been ported over to the MX 17 development repository.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16272
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15/16 Repository: The OBS Studio Thread

#4 Post by Stevo » Tue Nov 14, 2017 8:44 pm

Now updated to 20.1.1 in the test repo, again ported from deb-multimedia, as Debian is stuck at 19.0.3. MX 17 version also built.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16272
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15/16 Repository: The OBS Studio Thread

#5 Post by Stevo » Thu Feb 22, 2018 4:00 pm

Debian Sid had the latest 21.0.2, so I backported that to the test repository. I also decided to drop the deb-multimedia epoch "1:" at the start of the version to get back in sync with Debian, which means it won't be seen as an upgrade. Users should remove obs-studio, obs-plugins, and libobs0, then reinstall obs-studio to get the new version.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16272
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15/16 Repository: The OBS Studio Thread

#6 Post by Stevo » Mon Apr 23, 2018 7:14 pm

We've now rolled the latest 21.1.1 release into the test repo. Some changes since 21.0.2 include:

Dockable windows can now be nested.

Changed log file uploading to hastebin (for now) instead of anonymous github gists due to github removing anonymous gist support.

Fixed an issue where the AMD encoder wouldn't show up for some people since 21.0.

Bug Fixes

Fixed a bug where you could import a scene collection with an already-existing name.
Fixed a potential crash on startup.
Fixed a few scripting-related crashes.
Fixed a bug where setting a blank replay buffer prefix would reset to the default prefix when the program was restarted.
Fixed a bug where the slideshow source would get stuck on the last image is the slideshow image list was cleared.
Selection rectangles are no longer drawn for audio-only sources.

Post Reply

Return to “Package Requests/Status - MX-15/16”