Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 15/16 Repository: The GPSD thread

Message
Author
User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2252
Joined: Thu May 01, 2014 10:12 am

MX 15/16 Repository: The GPSD thread

#1 Post by mmikeinsantarosa » Sat May 13, 2017 9:18 pm

gpsd-3.16-4 from stretch is now available for download from the MX test repository.
There have been quite a few bug fixes since the stock jessie release 3.11-3.
I don't have HW to test this so if you do, please post results.

thanks
Mike
Last edited by mmikeinsantarosa on Sun May 14, 2017 11:09 am, edited 2 times in total.
LT: Intel Core i7-6820HQ Kernel: 4.12.0-8.3-liquorix-amd64 x86_64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

Re: MX 15/16 Repository: The GPSD thread

#2 Post by GuiGuy » Sun May 14, 2017 7:24 am

I have upgraded all gpsd-related packages to 3.16-4 in my MX16 installation: gpsd still not working with either of my dongles.
Not tried on MX15 because gpsd was already working OK with one of the dongles.

So my gpsd functionality remains as described in
viewtopic.php?f=108&t=42199

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21627
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 15/16 Repository: The GPSD thread

#3 Post by Jerry3904 » Sun May 14, 2017 7:50 am

It's hard with these upstream applications to know how to help. Have you gone through these?

http://catb.org/gpsd/installation.html

http://www.catb.org/gpsd/troubleshooting.html
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

Re: MX 15/16 Repository: The GPSD thread

#4 Post by GuiGuy » Sun May 14, 2017 8:48 am

Jerry3904 wrote:It's hard with these upstream applications to know how to help. Have you gone through these?

http://catb.org/gpsd/installation.html

http://www.catb.org/gpsd/troubleshooting.html
Not comprehensively - they are very long-winded and hard to understand in parts.
It is easier for me to stay with MX15 which has no gpsd problems.
BTW MX14 also has no problems.

If you can suggest a simple test for MX16 I will try it.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21627
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 15/16 Repository: The GPSD thread

#5 Post by Jerry3904 » Sun May 14, 2017 8:57 am

If you can suggest a simple test for MX16 I will try it.
Unfortunately, I know nothing about this software and don't have the hardware to test it.
You might think of taking the May snapshot just released, put it on a USB, and see if gpsd works on it with your dongle(s)?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

Re: MX 15/16 Repository: The GPSD thread

#6 Post by GuiGuy » Sun May 14, 2017 9:14 am

Jerry3904 wrote:.......
You might think of taking the May snapshot just released, put it on a USB, and see if gpsd works on it with your dongle(s)?
Would that be any different from a fully-updated installation?

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

Re: MX 15/16 Repository: The GPSD thread

#7 Post by GuiGuy » Sun May 14, 2017 9:20 am

Summary of my gpsd problem:-
On MX15 and MX14, with one of my gps dongles foxtrotGPS and xgps work OK.
But on MX16 xgps comes up blank and foxtrotGPS does not respond to the dongle.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21627
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 15/16 Repository: The GPSD thread

#8 Post by Jerry3904 » Sun May 14, 2017 9:54 am

GuiGuy wrote:
Jerry3904 wrote:.......
You might think of taking the May snapshot just released, put it on a USB, and see if gpsd works on it with your dongle(s)?
Would that be any different from a fully-updated installation?
It would be free of any changes/additions you might have made since installation, that's all I was thinking. Or use a clean install.

BTW: could you reboot MX-16 without the dongle inserted, insert the dongle that doesn't work on MX-15, then run

Code: Select all

dmesg | tail
Then try it with the one that does work. Paste the output back here so we can see how the system reacts.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

Re: MX 15/16 Repository: The GPSD thread

#9 Post by GuiGuy » Sun May 14, 2017 1:01 pm

This is the dongle which works on openCPN but not on xgps :-
dave@mx16barry:~
$ dmesg | tail
[ 44.499839] r8169 0000:04:00.0 eth0: link up
[ 44.499849] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 176.796015] usb 6-1: new full-speed USB device number 2 using uhci_hcd
[ 177.158041] usb 6-1: New USB device found, idVendor=1546, idProduct=01a7
[ 177.158045] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 177.158048] usb 6-1: Product: u-blox 7 - GPS/GNSS Receiver
[ 177.158051] usb 6-1: Manufacturer: u-blox AG - http://www.u-blox.com
[ 177.707275] cdc_acm 6-1:1.0: ttyACM0: USB ACM device
[ 177.709144] usbcore: registered new interface driver cdc_acm
[ 177.709146] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
dave@mx16barry:~
This is the dongle which does not work at all on MX16 but does work with xgps and foxtrotGPS on MX15 :-
dave@mx16barry:~
$ dmesg | tail
[ 536.694047] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 536.694050] usb 6-1: Product: USB-Serial Controller D
[ 536.694052] usb 6-1: Manufacturer: Prolific Technology Inc.
[ 537.278959] usbcore: registered new interface driver usbserial
[ 537.278976] usbcore: registered new interface driver usbserial_generic
[ 537.278989] usbserial: USB Serial support registered for generic
[ 537.280740] usbcore: registered new interface driver pl2303
[ 537.280756] usbserial: USB Serial support registered for pl2303
[ 537.280781] pl2303 6-1:1.0: pl2303 converter detected
[ 537.292170] usb 6-1: pl2303 converter now attached to ttyUSB0
dave@mx16barry:~

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21627
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 15/16 Repository: The GPSD thread

#10 Post by Jerry3904 » Sun May 14, 2017 5:01 pm

Thanks.

For the first: it looks like the system recognized it and installed a driver--you or somebody probably needs to look around to see if that is the right driver.

For the second: if you do a web search on the last line "pl2303 converter now attached to ttyUSB0" you will see a zillion hits. I suggest you look through a page or two and see if any apply.

All I have for now.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

Post Reply

Return to “Package Requests/Status - MX-15/16”