Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 15/16 Repository: The GPSD thread

Message
Author
User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

Re: MX 15/16 Repository: The GPSD thread [bump]

#21 Post by GuiGuy » Fri Jun 02, 2017 9:17 am

Still have this problem with MX16 fully upgraded. Sticking to MX15 fully upgraded for now because it works OK.
But I keep hoping that somebody with an interest in gps will appear and suggest a fix for MX16 :crossfingers:

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

GPSD thread [bump2]

#22 Post by GuiGuy » Sat Dec 23, 2017 1:45 pm

MX17 is no better than MX16 in this respect.
MX15 (both32 bit and 64bit) fully updated still work fine with foxtrotgps and xgps.
Mx14 fully updated also still works.

What changed in MX16 and MX17 which did not change with all the updates to 15 and 14?

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21659
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 15/16 Repository: The GPSD thread

#23 Post by Jerry3904 » Sat Dec 23, 2017 2:05 pm

Here's one possibilty: look at the last line of the installation code

Code: Select all

Setting up gpsd (3.16-4) ...
Creating/updating gpsd user account...
Created symlink /etc/systemd/system/sockets.target.wants/gpsd.socket → /lib/systemd/system/gpsd.socket.
Processing triggers for systemd (232-25+deb9u1) ...
I don't really know anything about this, but have you looked at the Installation directions and the troubleshooting page?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15428
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX 15/16 Repository: The GPSD thread

#24 Post by Stevo » Sat Dec 23, 2017 2:10 pm

Worth an experiment to boot MX 16 or 17 with systemd, IMO.

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

Re: MX 15/16 Repository: The GPSD thread

#25 Post by GuiGuy » Sat Dec 23, 2017 2:52 pm

Stevo wrote:Worth an experiment to boot MX 16 or 17 with systemd, IMO.
I am on MX17 now : how can I make it boot with systemd?

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21659
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 15/16 Repository: The GPSD thread

#26 Post by Jerry3904 » Sat Dec 23, 2017 3:01 pm

Select it on the Grub screen by arrowing down and selecting Alternatives or Advanced something (however it's worded) right below the MX-17 entry.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

Re: MX 15/16 Repository: The GPSD thread

#27 Post by GuiGuy » Sat Dec 23, 2017 3:10 pm

I still use legacy grub :frown:
It works with all my installs back to M11 and M12 so I'm scared to abandon it.

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1382
Joined: Sun Dec 16, 2007 6:29 pm

Re: MX 15/16 Repository: The GPSD thread

#28 Post by GuiGuy » Sun Dec 24, 2017 11:52 am

Now running MX1764 from the grub screen alternative "*MX 17 Horizon with Linux 4.13.0-1-amd64 (systemd)"
Everything seems to work except xgps and foxtrotgps still cannot see my gps dongle.

lsusb shows the dongle as
Bus 006 Device 002: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
just as it does in MX15, so why is it ignored by MX17 and 16?

Post Reply

Return to “Package Requests/Status - MX-15/16”