Welcome!

Site Interruption information here

GPG Error fix here

NewsCurrent releases
  • MX-16 release info here
  • antiX-16 release info here
New users
  • Please read this first, and don't forget to add system and hardware information to posts!
  • Read Forum Rules

MX-15/16 Repository: The Mesa Thread

Message
Author
User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1712
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX-15/16 Repository: The Mesa Thread

#31 Postby v3g4n » Wed Mar 22, 2017 11:57 am

mesa_13.0.6 is now available in the test repo.
https://www.mesa3d.org/relnotes/13.0.6.html
Mesa 13.0.6 is a bug fix release which fixes bugs found since the 13.0.5 release.

Mesa 13.0.6 implements the OpenGL 4.4 API, but the version reported by glGetString(GL_VERSION) or glGetIntegerv(GL_MAJOR_VERSION) / glGetIntegerv(GL_MINOR_VERSION) depends on the particular driver being used. Some drivers don't support all the features required in OpenGL 4.4. OpenGL 4.4 is only available if requested at context creation because compatibility contexts are not supported.

Bug fixes

Bug 68504 - 9.2-rc1 workaround for clover build failure on ppc/altivec: cannot convert 'bool' to '__vector(4) __bool int' in return
Bug 97102 - [dri][swr] stack overflow / infinite loop with GALLIUM_DRIVER=swr
Bug 98869 - Electronic Super Joy graphic artefacts (regression,bisected)
Bug 99401 - [g33] regression: piglit.spec.!opengl 1_0.gl-1_0-beginend-coverage
Bug 99456 - Firefox crashing when opening about:support with WebGL2 enabled
Bug 99677 - heap-use-after-free in glsl
Bug 99715 - Don't print: "Note: Buggy applications may crash, if they do please report to vendor"
Bug 99850 - Tessellation bug on Carrizo
Bug 100049 - "ralloc: Make sure ralloc() allocations match malloc()'s alignment." causes seg fault in 32bit build

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 12498
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX-15/16 Repository: The Mesa Thread

#32 Postby Stevo » Wed Mar 22, 2017 8:29 pm

It's working well on my laptop after an install and reboot:

Code: Select all

inxi -F
System:    Host: mx1 Kernel: 4.9.0-16.1-liquorix-amd64 x86_64 (64 bit) Desktop: Xfce 4.12.3
           Distro: MX-16_x64 Metamorphosis 12 December 2016
Machine:   Device: laptop System: Acer product: Aspire E5-575G v: V1.20
           Mobo: Acer model: Ironman_SK v: V1.20 UEFI: Insyde v: V1.20 date: 12/13/2016
Battery    BAT1: charge: 49.7 Wh 100.0% condition: 49.7/56.0 Wh (89%)
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2301 MHz 1: 500 MHz 2: 1000 MHz 3: 1000 MHz 4: 800 MHz
Graphics:  Card-1: Intel HD Graphics 520
           Card-2: NVIDIA Device 179c
           Display Server: X.Org 1.16.4 driver: intel Resolution: 1920x1080@60.01hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) GLX Version: 3.0 Mesa 13.0.6
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel Sound: ALSA v: k4.9.0-16.1-liquorix-amd64
Network:   Card-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci
           IF: wlan0 state: up mac: 54:8c:a0:79:52:2d
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: down mac: 54:ab:3a:b2:a4:5f
Drives:    HDD Total Size: 760.1GB (51.1% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD0 size: 500.1GB
           ID-2: /dev/sdb model: HFS256G39TND size: 256.1GB
           ID-3: USB /dev/sdc model: Internal_Storage size: 3.9GB
Partition: ID-1: / size: 117G used: 27G (24%) fs: ext4 dev: /dev/sdb4
           ID-2: /home size: 416G used: 330G (84%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 3.66GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 44.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 257 Uptime: 5:55 Memory: 5085.3/7861.4MB Client: Shell (bash) inxi: 2.3.8


Memory use is high with a virtual machine doing a compile...

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8799
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: MX-15/16 Repository: The Mesa Thread

#33 Postby kmathern » Thu Mar 23, 2017 8:33 am

Also working here:

Code: Select all

$ inxi -Gxxx
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8240 / R3 Series]
           bus-ID: 00:01.0 chip-ID: 1002:9838
           Display Server: X.Org 1.16.4 drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 1600x900@60.00hz
           GLX Renderer: Gallium 0.4 on AMD KABINI (DRM 3.9.0 / 4.10.1-antix.1-amd64-smp, LLVM 3.9.1)
           GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes


Have you tried building mesa 17.x yet or is llvm-4.0 a stumbling block? There is a repo with a llvm-4.0 jessie backport here: http://apt.llvm.org/ and I think you can find it's debian.tar.xz file here: http://llvm-jenkins.debian.net/job/llvm ... .0-source/ that you could maybe look at.

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1712
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX-15/16 Repository: The Mesa Thread

#34 Postby v3g4n » Thu Mar 23, 2017 9:44 am

Thanks for testing and the feedback guys!! :number1:

I did try once, but llvm-4.0 failed after an hour or so. Thanks for the link, that's awesome!! I will check it out tonight!!

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1712
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX-15/16 Repository: The Mesa Thread

#35 Postby v3g4n » Sun Apr 09, 2017 2:34 am

* Experimental *
mesa_17.0.3 is now available in an experimental repo.
The following repo will need to be enabled

Code: Select all

deb http://mxrepo.com/mx/testrepo mx15 experimental

You will want to upgrade vlc from this repo do to mesa_17.03 no longer producing the libgles1-mesa package so in order to have a smooth upgrade you will have to uninstall vlc_nox. If you don't use vlc then this is not necessary and vlc will be replaced with smplayer. This will be fixed next round of updates.

libgles1-mesa is also a dependency of libopentk1.0-cil, which I am working on as a replacement. So far I have not been able to replace it, but have not fun into a problem with normal use. If anyone runs into an issue please post.
Thanks!

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 8799
Age: 58
Joined: Wed Jul 12, 2006 2:26 pm

Re: MX-15/16 Repository: The Mesa Thread

#36 Postby kmathern » Sun Apr 09, 2017 8:41 am

v3g4n wrote:* Experimental *
mesa_17.0.3 is now available in an experimental repo. ...

Seems to be working here:

Code: Select all

$ inxi -SGxxx
System:    Host: mx1 Kernel: 4.11.0-041100rc5-generic x86_64 (64 bit gcc: 6.2.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.25) info: xfce4-panel dm: lightdm
           Distro: MX-16_x64 Metamorphosis 12 December 2016
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8240 / R3 Series]
           bus-ID: 00:01.0 chip-ID: 1002:9838
           Display Server: X.Org 1.16.4 drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 1600x900@60.00hz
           GLX Renderer: Gallium 0.4 on AMD KABINI (DRM 3.10.0 / 4.11.0-041100rc5-generic, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.0.3 Direct Rendering: Yes

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1712
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX-15/16 Repository: The Mesa Thread

#37 Postby v3g4n » Sun Apr 09, 2017 2:47 pm

:number1:
Thanks for testing and I hope it wasn't to much of a pain to upgrade.

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1712
Joined: Sat Jan 16, 2016 8:20 pm

Re: MX-15/16 Repository: The Mesa Thread

#38 Postby v3g4n » Sun Apr 09, 2017 4:48 pm

Have you noticed any difference from the 13 series or is it just pretty much a version increase?


Return to “Package Requests/Status - MX-15/16”

Who is online

Users browsing this forum: No registered users and 5 guests