Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 15 Community Repository: The Thunderbird Thread

Message
Author
User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2371
Joined: Thu May 01, 2014 10:12 am

Re: MX 15 Community Repository: The Thunderbird Thread

#71 Post by mmikeinsantarosa » Wed Apr 26, 2017 10:10 am

cyrilus31 wrote:I don't know if it's the good place to talk about it (move it if needed) but we are discussing problem about thunderbird localization on french forum.

Even though we update the language pack with the last version available (thunderbird-l10n-xpi-fr_52.0.1) into the repos thunderbird displays the old 45.5.0 version and so can't be used because of compatibility issue. The only solution Jerry gave us is to directly download the addon.
I see the same thing. The language packs do have the correct epoch-ized rev but they sure don't show up in synaptic. Until this is resolved, cyrilus31 could download from the repo directly here and install what they need. and for French that would be one of the following:
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
cyrilus31
Forum Regular
Forum Regular
Posts: 546
Joined: Thu Nov 03, 2016 3:24 pm

Re: MX 15 Community Repository: The Thunderbird Thread

#72 Post by cyrilus31 » Wed Apr 26, 2017 10:15 am

I've rapidly taken a look at the package. I'm totally noob but the install.rdf file displays "version 45.5.0" and not 52.0.1 as expected. Is this file only used to display the version?
I let you packagers do the job. You're the best :number1:

Edit : I've taken a look at Editing_an_add-on and I may be right.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9305
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX 15 Community Repository: The Thunderbird Thread

#73 Post by dolphin_oracle » Wed Apr 26, 2017 8:03 pm

the language packs DO show up in synaptic. They are also screwed up somehow. As cyrilus31 says, they are reporting themselves as not compatiable with anything over 45. I'm guessing this affects ALL the language packs (I've tried french and spanish).

Code: Select all

<?xml version="1.0"?>
<!--

-->

<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
     xmlns:em="http://www.mozilla.org/2004/em-rdf#">
  <Description about="urn:mozilla:install-manifest"
               em:id="langpack-es-ES@thunderbird.mozilla.org"
               em:name="Español (España) Language Pack"
               em:version="45.5.0"
               em:type="8"
               em:creator="mozilla.org">
    <em:targetApplication>
      <Description>
        <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
        <em:minVersion>45.5.0</em:minVersion>
        <em:maxVersion>45.*</em:maxVersion>
      </Description>
    </em:targetApplication>
  </Description>
</RDF>

so either the install.rdf file is wrong, or the packages are the old versions with new numbers.

I manually hacked an xpi file and while my error messages now show up in spanish, thunderbird doesn't run. Based on that, I'm going with the actual contents of the package are wrong for the package version. That's a best guess at the moment.

the thunderbird - 45 language packs (which debian now uses by default instead of icedove) are also showing up in synaptic because they don't have the same package name. So be careful what you install.

***edit because of erroneous statement***

Mx-packageinstaller (mx15/16/16.1) all install the correct package. But the packages themselves are hosed.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22420
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 15 Community Repository: The Thunderbird Thread

#74 Post by Jerry3904 » Wed Apr 26, 2017 8:24 pm

Bizarre! But that direct download worked for French, so maybe we need to announce a set of URLs?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9318
Joined: Wed Jul 12, 2006 2:26 pm

Re: MX 15 Community Repository: The Thunderbird Thread

#75 Post by kmathern » Wed Apr 26, 2017 9:05 pm

In the thunderbird-l10n-xpi source (http://mxrepo.com/mx/repo/pool/main/t/t ... ian.tar.xz), line 7 of the debian/download-l10n script will always download the version 45.5.0 xpi files
wget http://ftp.mozilla.org/pub/mozilla.org/ ... /releases/45.5.0/linux-$(echo "$j" | sed 's/amd64/x86_64/;s/i386/i686/')/xpi/"$i".xpi -P "$1"/"$j"
I'm not sure how long it's been like that, it's supposed to be this
wget http://ftp.mozilla.org/pub/mozilla.org/ ... /releases/"$2"/linux-$(echo "$j" | sed 's/amd64/x86_64/;s/i386/i686/')/xpi/"$i".xpi -P "$1"/"$j"

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 1997
Joined: Mon Nov 21, 2011 5:50 pm

Re: MX 15 Community Repository: The Thunderbird Thread

#76 Post by Gordon Cooper » Wed Apr 26, 2017 9:19 pm

Kent: Is that "S2" in the middle of the 'supposed to be' line, and not "52" ?
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22420
Joined: Wed Jul 19, 2006 6:13 am

Re: MX 15 Community Repository: The Thunderbird Thread

#77 Post by Jerry3904 » Wed Apr 26, 2017 9:21 pm

It's dollar-sign 2, I believe.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2371
Joined: Thu May 01, 2014 10:12 am

Re: MX 15 Community Repository: The Thunderbird Thread

#78 Post by mmikeinsantarosa » Wed Apr 26, 2017 9:24 pm

kmathern wrote:In the thunderbird-l10n-xpi source (http://mxrepo.com/mx/repo/pool/main/t/t ... ian.tar.xz), line 7 of the debian/download-l10n script will always download the version 45.5.0 xpi files
wget http://ftp.mozilla.org/pub/mozilla.org/ ... /releases/45.5.0/linux-$(echo "$j" | sed 's/amd64/x86_64/;s/i386/i686/')/xpi/"$i".xpi -P "$1"/"$j"
I'm not sure how long it's been like that, it's supposed to be this
wget http://ftp.mozilla.org/pub/mozilla.org/ ... /releases/"$2"/linux-$(echo "$j" | sed 's/amd64/x86_64/;s/i386/i686/')/xpi/"$i".xpi -P "$1"/"$j"
ugh. Let me do a +3
Last edited by mmikeinsantarosa on Wed Apr 26, 2017 9:54 pm, edited 1 time in total.
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9318
Joined: Wed Jul 12, 2006 2:26 pm

Re: MX 15 Community Repository: The Thunderbird Thread

#79 Post by kmathern » Wed Apr 26, 2017 9:28 pm

It's dollar-sign 2. Mike (mmikeinsantarosa) needs to make the change, re-run `debian/rules get-orig-source` and rebuild the packages.

edit: nevermind, it looks like he's on it.

User avatar
Gordon Cooper
Forum Guide
Forum Guide
Posts: 1997
Joined: Mon Nov 21, 2011 5:50 pm

Re: MX 15 Community Repository: The Thunderbird Thread

#80 Post by Gordon Cooper » Wed Apr 26, 2017 9:31 pm

Sorry, it is a dollar sign. Aged eyes, can see it properly with a magnifier.
Homebrew64 bit Intel duo core 2 GB RAM, 120 GB Kingston SSD, Seagate1TB.
Primary OS : MX-17.1 64bit. Also MX17, Kubuntu14.04 & Puppy 6.3.
Dell9010, MX-17.1, Win7

Post Reply

Return to “Package Requests/Status - MX-15/16”